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and integrity are important, but who you are is more
important than what you have done.



Acknowledgments

I would like to acknowledge three individuals who have together inspired me and pushed me to
be my best whatever I'm doing.

Alin Vargatu of Javelin Technologies (located in Oakville, Ontario, Canada) was the technical
editor for this book, and is responsible for improving the thoroughness and accuracy of the entire
book. Alin has a drive and integrity that is truly an example for us all. His dedication to helping
his own customers as well as those who aren’t his customers coupled with the boggling amount
of energy he must put into this endeavor is really inspiring.

Imre Szuc is Alin’s equivalent in the Solid Edge world, as a Solid Edge reseller in Hungary.
Imre’s enthusiasm for what he does and for technical excellence and sheer drive to help others in
highly technical tasks have helped me see what’s possible with some dedication.

Arthur Patrick is a Siemens PLM employee who shows real dedication to those who use the
product of his efforts. He’s responsible for many of the best enhancements to his software over
the last several years. He’s able to develop and communicate highly productive techniques, and
does it all while keeping a sense of humor and not taking himself too seriously. I wish that
I could get some of the brilliance from these people to rub off on me a little.

Thanks also to Kim and Zoey, who help with the details in life, allowing me to do this
kind of work.



About the Author

Matt Lombard is an independent engineering consultant specializing in design, CAD
Management, and product development process consulting. He also writes a blog on product
development and related technology, which you can find at www.dezignstuff.com. Matt lives
in the picturesque Shenandoah Valley of Virginia, where he enjoys reading the classics

and fishing.



Contents

INtroduction ... ... XxXx1ii
Part I « Introducing SolidWorksBasics .. .......cciviiiiiiiieiniinnenenennnnns 1
Chapter 1 « IntroducingSolidWorks ..............c.coiviiiiiiienenn. 3
Installing SolidWorks for the First Time .. ............ ... ... ... ... ... 3
Starting SolidWorks for the First Time ................ .. ... ... o oot 6
Examining the SolidWorks License Agreement ................................ 6
UsingtheHelpMenu........... ... i 6
Creatinga New Document ................. i 8
Identifying SolidWorks Documents .................. .. .. 9
Saving Your Setup. ... 11
Using Templates . ......... ..o 12
Understanding Feature-Based Modeling . ................... ... ... ... ..., 15
Understanding History-Based Modeling . .................. ... ... ... ... 16
Sketching with Parametrics ......... ... ... ... . .. 19
Understanding DesignIntent................ .. ... ... i 21
Editing DesignIntent. ....... ... ... .. . 21
Choosing Sketch Relations. . ............. .. .. i 22
Selecting Display/Delete Relations .. ............. ... ... ... .o i 22
Using Suppressed Sketch Relations . ............... ... ... . oo ... 23
Working with Associativity. ........... ... ... . 24
The Bottom Line....... ... 24
Chapter 2 » Navigating the SolidWorks Interface ..................... 25
Identifying Elements of the SolidWorks Interface............................. ... 25
Using the CommandManager and Toolbars. ................................. 25
Controlling Menus . ........ ...t 37
Changing CUISOTS. . .. ..ottt 38
Working with Models in the FeatureManager and PropertyManager Windows . . . 38
Getting Around the Task Pane .............. ... ... ... oL 43
Getting Familiar with the Status Bar ................... ... ... .. .. ... ..., 45
Using SolidWorks Search. .......... ... .. 46
Making the Interface Work for You ........... ... .o o i i 47
Customizing Colors . ....... ... 47
Customizing Strategies ........ ... ... .. ... 49
Working with Multiple Document Windows................................. 55

The Bottom Line . . .. ..o 59



XII

CONTENTS

Chapter 3 « Working with Sketches and Reference Geometry ........... 61
Creatinga New Part.............o 61
CreatingaSketch ....... ... . . 62
Identifying Sketch Entities .............. ... ... i 64
Using the Sketch Toolbar.......... ... ... i 64
Driving Sketches with Smart Dimensions .................. ... oo, 83
Using Tools on the Dimensions/Relations Toolbar............................ 86
Inferencing inSketch . ....... ... .. 89
Exploring Sketch Settings . ......... ... ... 90
Using Sketch BIocks . .. ... 92
Working with Reference Geometry ............... ... ... . .. .. 93
Creating Planes . . ... i 93
Working With AXes .. ... ... 94
Using Coordinate Systems. . ........... ... i 94
Using Points as Reference Geometry................. ... oo it 96
Sketching with Touch Interface.............. ... ... . ... ... . . it 96
Tutorial: Learning to Use Sketch Relations. ................ ... ... ... ... ..., 98
Tutorial: Using Blocksand Belts. . .............. ... o o i i 102
Tutorial: Creating Reference Geometry................... ... ..., 105
TheBottom Line............ ... i 109
Chapter 4 « Creating Simple Partsand Drawings .................... 111
Discovering DesignIntent. . ............ ... ... ... ... ... ... .. ... L. 111
Using Symmetry .. ... 112
Determining Primary or Functional Features. ............................... 112
Predicting Change. ............. i 112
Creatinga Simple Part. ........... . i 113
Deciding WheretoStart. ........... ... ... i i 113
Building in Symmetry ......... ... 116
Making It Solid . ...... .. 117
UsingInstant3D ........ ... 122
Making the First Extrude Feature. ............ ... ... ... ... ... ... ... ... 123
Creating a Simple Assembly........ ... ... ... . 125
Creating the Assembly . ........ ... ... . i 126
Populating the Assembly........... ... ... . 126
Examining Mates. ......... ... 127
Creating a Simple Drawing. . . ............ oo 128
Tutorial: Creating a Simple Part . ............. ... ... ... oL 128
Tutorial: Making a Simple Drawing. . .......... ... ... i 137
TheBottom Line.......... ... ... 142
Chapter 5 « Using Visualization Techniques................cccovvn. 143
Manipulatingthe View ........... ... 143
Using Arrow Keys. . ... 144
Using the Middle Mouse Button. . ............ ... ... ..o o oo, 144

Using Mouse Gestures . . ... 145



CONTENTS

Using the View Toolbar ......... ... ... i 146
Adding Scrollbars and Splitters ................. ... ... ... 147
Using the Magnifying Glass .............. .. ... i ... 148
Clicking the Triad AXes ....... ... i 148
Using the View Tools . . . ... 149
Zebra Stripesand Curvature. . ........... ... i 153
View Orientation. .............o i 154
Annotation Views . ... 156
Using the DisplayManager. . ... 157
ApPPlying Appearances. . ...........oiiiiiii 157
Using Decals ....... ... i 165
Using Scenes, Lights,and Cameras . .................. ... ... 166
The Display Pane . ............ 173
Applying Color Automatically to Features .................................... 174
Using Edge Display Settings. . .............oo i 174
Tutorial: Applying Visualization Techniques. ........................ ... ... ... 175
TheBottom Line. ... ... ... 179
Part II « Building Intelligenceinto YourParts ....................oiiaan... 181
Chapter 6 « Getting More from Your Sketches....................... 183
Editing Sketch Relations . .......... ... .. .. . i 183
Using Display/Delete Relations. .............. ... i .. 184
Using Replace Entity ........... .o i 186
Using SketchXpert. ... 188
Getting More from Dimensions . ............. ... i 189
Dimensioning from Centerlines . .............. ... ... .. . i, 189
Sketching with NumericInput............ .. . ..o o i 189
Working with Sketch Entities . .......... .. ... ... . o i 189
Moving, Rotating, Copying, and Scaling Entities ............................ 190
ModifyingaSketch.......... ... .. . 191
Copying and Pasting Sketch Entities................... ... ... ... ..., 192
Dragging Entities .................... ... 192
Creating a Derived Sketch........... ... ... . ... i 193
Using Sketch Pictures. ............ .. i 193
Using Three Views .......... . i 195
Compensating for Perspective ............ ... .. i i i 196
Estimating Sharp Edges........... ... ... i 196
Using Auto Trace. ....... ... ... 196
Using Stick Fonts. . ... 196
Using Sketch Text. . ... ... i 196
Using Colors and Line Styles with Sketches ................................... 198
Working in Color Display Mode. . ......... ... ... ... o i i 198
Assigning Line Color . ........ .. 198
Using the Edit Sketch or Curve Color Tool............... ... ... ..., 198

Assigning Line Thickness and Line Style ................ ... ... ... ... ... 198

XIII



XIvV

CONTENTS

Using Other Sketch Tools .......... ... i 199
Working with RapidSketch ............... .. .. ... . 199
Adding Sensors. . ... 199
Using Metadata for Sketches. ............... ... ... ... i 200
Creating Construction Geometry ........... ... ... ..o, 201

Sketching in 3D . .. ... ... 201
NavigatinginSpace .............. 201
Exploring Sketch Relations in 3D Sketches. ................................. 202
Using PlanesinSpace. .......... ... 203
Using Planar Path Segments . ............. .. ... ... .. i 204
Defining DIimensions . ....... ... 204
Using 3D Sketch Summary ............... i 204

Tutorial: Editing and Copying .............c.o i 204

Tutorial: Controlling Pictures, Text, Colors, and Styles .......................... 208

Tutorial: Using Metadata. . .......... ..o i 211

Tutorial: Sketching Calculator ......... ... ... .. ... i i 212

TheBottom Line. ... ... ... 214

Chapter 7 » Modeling with Primary Features........................ 217

Identifying When to Use Which Tool ............. ... ... ... ... o .. 217
Using the Extrude Feature............. ... .. ... ... ... i 217
Understanding Instant 3D .. .............. 221
Working with the Revolve Feature..................... ... ... ... ...... 222
Introducing Loft, Boundary,and Sweep ............... ... . ... ..o oL 223
Controlling Sweep Features. ............. ... ... ... . i 227

Understanding Fillet Types. .. ....... ..o 231
Creating a Constant-Size Fillet .. ......... ... ... ... . o oL, 233
Creating Variable-Radius Fillets. .. ....... ... ... ... .. oo oL 243
Using Face Fillets ............. i 246
ApplyingaFullRound Fillet. . ............ .. ... i 250
Building a Setback Fillet. . .......... ... .. 251

Using Chamfers ......... ... . i 253
Creating Asymmetrical Chamfers ............... ... .. ... ... ... .. ... ... 254
Switching Between Fillet and Chamfer Features............................. 255

Tutorial: Bracket Casting............ ... .. o i i 256

TheBottom Line. ... ... ... 260

Chapter 8 « Selecting SecondaryFeatures ................ccovvnenn. 261

Creating Curve Features . ............ ... ... ... ... ... ... ... .. 261
Manipulating Curves . . .......... . 262
Working with Helix Curve Features ................... ... ... ... ... .... 262
Creating Projected Curves. ......... ... i 264
Using the Curve Through XYZ Points Feature............................... 265
Using the Curve Through Reference Points Feature.......................... 266
Putting Together a Composite Curve. ................ ..., 266
Using SplitLines. ... 267

Using the Equation-Driven Curve ............. ... ... .o i .. 267



CONTENTS
Selecting a Specialty Feature. ............. ... ... ... ... . i 267
Using Scale. ... ... ... 268
Using the Dome Feature ............ ... .. ... . i i, 269
Usingthe Wrap Feature............. ... .. ... ... ... .. 271
Using the Flex Feature ........... ... . ... . i i 273
Applying the Deform Feature. ............... ... ... ... i, 275
Using theIndent Feature . ............ ... ... .. ... . il 277
Using Intersect. ......... ... i 279
Tutorial: Creating a Wire-Formed Part . ........... ... ... ... ... ... ... ... 280
TheBottom Line. ... ... ... . 282
Chapter 9 « Patterningand Mirroring.................ccivinnn.. 283
PatterninginaSketch ....... ... ... .. . 283
Debunking More SketchMyths ........... .. ... ... . i 286
PatterningaSketch.......... ... .. .. 287
MirroringinaSketch........ ... . 289
Using Mirror Entities . ...... ... ... . 289
Using Dynamic Mirror. . ... 290
Using Symmetry Sketch Relation.............. ... ... ... ... o .. 291
Using Mirroringin 3D Sketches . ......... ... ... ... ... ool 291
Working with 3D Patterns. . ......... ... ... i 291
Exploring the Geometry Pattern Option.................................... 292
Patterning Bodies ............. ... 293
Patterning Faces .......... ... ... ... 294
Patterning Fillets. . ........... . 295
Understanding Pattern Types. . ........... .. i i i 295
Using the Linear Pattern .......... ... ... ... .. i i i i 296
Using the Circular Pattern............... ... .. .. o i i, 299
Using a Curve-DrivenPattern .................... .. ... ... ... ..ol 300
Using a Sketch-Driven Pattern . .......... ... ... ... ... .o L. 302
Using a Table-Driven Pattern ............ ... ... ... ... .. 302
Using the Fill Pattern . ........ ... ... 303
Using a Variable Pattern. . .......... ... ... .. . . i i i 304
CosmeticPatterns. . .......... ... ... . 307
Mirroring 3D Solids . . . ... 308
Mirroring Bodies. ............ . 308
Mirroring Features ........ ... ... ... 309
Mirroring Entire Parts ........ ... .. ... ... 309
Tutorial: Creating a Circular Pattern..................... ... ... ... ..., 310
Tutorial: Mirroring Features . ........... ... .. ... ... . 311
Tutorial: Applying a Cosmetic Pattern . ............. ... . ... ... .. ..., 313
TheBottom Line. . ... ... 314
Chapter10 « UsingEquations............coitiiiiiininrnenencnnenes 317
Understanding Equations........... ... .. ... . . i 317
Creating Equations................... .. 318
Using Driven Dimensions . . ...............o i 323

Using Equation Tricks .......... ... ... i 325

XV



XVI

CONTENTS

Using Global Variables ............ ... .. i i 326
Using the Modify Box ... 327
Using EXpressions . ........................... .. ... ... 329
Controlling Suppression States of Features .................................... 329
Linking to External Equations .............. ... ... ... ... i 330
Tutorial: Using Equations . ........... ... ... .. . . o i 330
The Bottom Line. ... ... 333
Chapter 11 . Working with Part Configurations ..................... 335
Controlling Items with Configurations. ................... ... ... ... ..., 336
Finding Configurations ........... .. ... ... . . i i 336
Deleting Configs .. ... ... 337
Sorting Configs ... ... 338
Activating Configurations. ............... .. .. i i 339
Creating Configurations. . .......... ... i 340
Using the Modify Configurations Dialog Box ............................... 344
Using Custom Property Managers. ..., 346
Using Derived Configurations ............... ... oo, 347
Understanding How File Size Affects Speed ...................... ... ... ... 348
Controlling Dimensions. . ........... ... 350
Controlling SUppression . ...t 350
Controlling Custom Properties............... ... ... o .. 351
Controlling Sketch Relations. ............. .. ... ... o i, 352
Controlling Sketch Planes ................. . ... i 353
Controlling Configurations of Inserted Parts..................... ... ... ... 354
Using Library Features. . ........ ... ... ... i i 355
Using Design Tables. .. ... 355
Identifying What Can Be Driven by a Design Table .......................... 356
Creating a Simple Design Table . . ........... ... ... ... . i, 357
Editing Design Table Settings .. ........... ... ... ... ... i 362
Editing the Design Table ........... ... ... ... i 364
Using the Configuration Publisher . ........... ... ... . ... ... ... ... ... 364
Tutorial: Working with Configurations and Design Tables . ...................... 365
The Bottom Line. ... ... 368
Chapter 12 . Editing, Evaluating, and Troubleshooting............... 371
Using Rollback ....... ... 371
Using the Rollback Bar............ ... ... i i 372
Using Other Rollback Techniques ............. ... ... ... ... oo i, 376
Using Part Reviewer. ................ i 377
Reordering Features. ............. ... i 378
Reordering Folders. ............. 379
Using the Flyout and Detachable FeatureManagers............................. 380
Displaying the FeatureManager and PropertyManager....................... 381
Following Selection Breadcrumbs ............ ... ... ... . ..o ool 381

Summarizing Part Modeling Best Practices......................... ... ... ... 383



CONTENTS | XVII

Using Design forChange ........... ... .. i 385
Keeping Track of References .............. .. ... ... i, 386
Visualizing Horizontal Modeling. . ............ ... ... . ... ... .. ... ..., 386
Understanding Resilient Modeling ..................... ... ... ..., 386
Using Skeleton Sketches. . .......... ... ... .. o 387

Using Evaluation Techniques............. ... ... . o i i, 387
Using Verification OnRebuild ............ ... ... oo ool 388
Using the Check Tool ....... ... . i 389
Evaluating Geometry with Reflective Techniques............................ 390

Troubleshooting Errors ........... ... .. . i 397
Interpreting Rebuild Errors............... .. .. i 397
Identifying Common Errors .............. .. 398
Dismissing Errors . ....... ... .o 400
Using SolidWorks RX and Performance Benchmark. ......................... 401

Tutorial: Utilizing Editing and Evaluation Techniques .......................... 406

TheBottom Line....... ... 412

Part III « Working with Assemblies .............c.ciiiiiiiiiiiiniieienennn. 413

Chapter 13 « Building Efficient Assemblies ......................... 415

Understanding the Purpose of Assemblies .................................... 415
Identifying Types of Assemblies. .............. ... ... . o i 416
Creating an Alternative to Multiple Assemblies ............................. 422

Identifying the Elements of an Assembly.................. ... ... ... 423
Working with Assembly Equations .................... ... ... . ... ..., 424
Using an Assembly Layout Sketch............ ... ... ... ... ... 426
Working with Virtual Components ............ ... ... ... ..o oo 428
Creating Assembly Reference Geometry................. ... ..., 428
Comparing History-Based and Non-History-Based Portions of

the Assembly Tree ............ i 428
Understanding Parts and Subassemblies ................................... 429
Organizing Mates . ............ . i 429
Applying Assembly Features ................ ... ... i 430
Using Component Patterns and Mirror Components......................... 432

Using SpeedPaks ...........o 432
Using Ghosts .. ... 432
Sharing Self-Contained Data.................. ... ... o i i, 433
Using SpeedPaks with Drawings.............. ... ... i .. 433

Using Subassemblies . ............. . i 433
Creating Subassemblies from Existing Parts................................. 434
Organizing for Performance ............... .. ... i 435
Organizing for the Bill of Materials .. ............ ... . ... .. o i 436
Grouping Subassemblies by Relative Motion. ............................... 437
Organizing Groups of Purchased Components.............................. 437
Depicting an Assembly Process ... 437

Patterning Considerations. ............... ... . i i i 438



XVIII

CONTENTS

Using Folders ...... ... ... 438
Creating Folders in the FeatureManager.................................... 439
Reordering ItemsintheTree............. ... ... i .. 439

Working with Tree Display Options .............. ... ... ... .. 440
Showing Feature Names and Descriptions. ................................. 440
Showing Component and Config Names and Descriptions ................... 440
Using Component Reference perInstance .................................. 441
Viewing Features, Mates, and Dependencies................................ 442

Tutorial: Arranging Assemblies . ............. ... .. i 443

Tutorial: Managing the FeatureManager ............................. ... ...... 446

The Bottom Line....... ... 447

Chapter 14 « GettingMorefromMates..............c.ccivivinnn.. 449

Applying Mates . ... ... 449
Mating Through the Mate PropertyManager..........................c..... 450
Taking Advantage of SmartMates ............... ... .. ... . i i 454
Using the Component Preview Window. .............. ... . ... ... ... ... 457
Using Copy WithMates......... ... ... .. . i 457
Mating with Macros .. ... 458

Mating for Motion . ......... .. 459
Analyzing Degree of Freedom ............... ... ... .. .. il 459
Setting Up Successful Motion.............. ... ... ... .. 460
Using Reference Entities ............... .. ... ... i 462

Working with Advanced and Mechanical Mate Types........................... 462
Profile Center Mate. . ...... ... ... 463
SymmetricMate ........ ... 463
CamMate. ... ... o 464
Width Mate. . . ... 465
GearMate. ... ... .. 466
Rack and Pinion Mate. . ........ ... ..o 466
LimitMates ....... .. .. 466
Screw Mate. ... ... 468
PathMate .. ... ... 468
Linear Coupler Mate. . ......... ... i 470
Hinge Mate. . ... ... 470
Belt/Chain . . ..o 470

Editing and Troubleshooting ........... ... .. ... ... . i 471
Editing Existing Mates............. ... i 471
Troubleshooting Assembly Mates. . ............ ... ... ... 473
Troubleshooting Warnings and Errors................. ... ... . ... .. ..., 474

Examining Mate Options ........... ... ... ... ... . 474

Reviewing Mate Best Practices. ............ ... ... ... ... ... .. L 475

Tutorial: Mating for Success . .......... ..o 477

The Bottom Line . . . ..o i e 480



CONTENTS

Chapter 15 « Patterning and Mirroring Components ................. 483
Component Patterns ............. ... 483
Using Local Component Patterns ............... ... ... ... ... 484
Creating Local Pattern References ............. ... ... ... ... ... ... 484
Using Mirror Components. . ... 486
Using Feature-Driven Component Patterns. . ............... ... ... ... ... ... 491
Creating a ChainPattern........... ... .. ... .. i i i 492
Understanding Other Pattern Options . .............. ... oo ... 494
Tutorial: Creating Component Patterns ................... ... ... ... 495
The Bottom Line....... ... 497
Chapter 16 + Working with Assembly Sketches and Layouts ........... 499
Looking at the Techniques .......... ... ... ... . ... . . i 499
Using the Assembly LayoutSketch ........... ... ... ... . ... ... ... ... 500
Using Master Model............ ... .. i 504
Using the Layout Feature .......... ... .. ... ... .. .. . . i 505
Using the Layout Workflow . ....... ... ... .. . . i i 505
Working with Virtual Components ............... ... ... ..o oo 506
Balancing Advantages and Limitations........................ ... ... . . 507
Tutorial: Working withaLayout ............. .. ... ... o i, 507
TheBottom Line....... ... 513
Chapter 17 + UsingAssemblyTools ..................c.ciiiiniaa.., 515
Placing Parts without Mates. ........... ... .. .. ... ... i 515
Using the Move Component Options ...................ooiiiii ... 516
Using the For Positioning Only Option. .................. ... ... ... ..., 519
Building PartsinPlace.......... ... ... i 520
Using Proximity Tools . .......... . ... i 520
Using Interference Detection. . ........... ... .. .. o i i 521
Using Clearance Verification. ............. ... .. .o i .. 523
Using Dynamic Clearance . ............... ... 524
Using Collision Detection .......... ... ... .. i 525
Using Physical Dynamics ..............ooii i, 526
USING SENSOTS. . . o oottt 526
Selecting Components. ......... ...t 528
Selecting witha Volume. ......... ... . ... ... 529
Selecting Suppressed Components .............. ..., 530
Selecting Hidden Components............... ... ... o i i, 530
Selecting Subassemblies. . .......... ... ... . o 530
Selecting Parts Mated to Another Part.................... ... . ... ... ..., 530
Selecting Identical Components.............. ... ... o i i 530
Selecting Internal Components. ............ ... ... ... i i 530
Selecting Toolbox Parts. ......... ... ... i 530
Using the Advanced Select Options. ............. ... ... 531

Selecting by Size . ... 532

XIX



XX

CONTENTS

Reading Assembly Performance Evaluation Results ............................ 532
Using Defeature ....... ... .. 533
Using the Hole Alignment Tool ............. ... ... ... ... .. 534
TheBottom Line........ ... 535
Chapter 18 « Using Libraries, Assembly Features, and Hole Wizard..... 537
Using Library Features ........... ... ... i i 537
Getting Started with Library Features...................................... 538
Applying the Library Feature Interface..................... ... ... .. ... ... 538
Exploring Other Design Library Functions. . ........................ ... ... 541
Creating Library Features........... ... ... ... .. i i i 543
Creating a Library Feature. . ........... ... .. .. . i i 544
Creating a Library Feature from an Existing Part ............................ 549
Adding Folderstothe Library ............ ... ... ... i i, 550
Locating Dimensions and Internal Dimensions.............................. 550
Creating Assembly Cuts ........... ... i 551
Using the Feature Scope. ............ ..o i 552
Propagating FeaturestoParts............ ... ... . ... . ool 553
Making Fillets and Chamfers in Assemblies ................................... 554
Usingthe Hole Wizard ............ ... .. . i 555
Using the Hole Series........... ... 556
Creating Weld Beads . ........ ..o 558
Working with Envelopes.......... ... ... i 560
Understanding Smart Components. . ... ... 562
Using Smart Components. ....... ...ttt 563
Getting Started with a Simple Smart Component . ........................... 563
Auto-Sizing Smart Components. . ... 566
Making Smart Components . ... 568
Getting Started with a Simple Smart Component ............................ 568
Creating an Auto-Sizing Smart Component................................. 570
Managing Files with Smart Components ................................... 574
Editing Smart Components. ................ i 575
Tutorial: Working with Smart Components.................................... 576
Tutorial: Working with Library Features ................... ... ... ... ....... 579
The Bottom Line. ... ... .. 586

Chapter 19 « Controlling Assembly Configurations

and Display States .........cooitiitiiitieietieieieerteneneneanes 589
Using Display States ............. .. i 589
Controlling Display States and Configurations .............................. 590
Using Display States with Drawings.................. ... ... ..o .. 592
Using Part Display StatesinParts ............. ... ... ... ... o oL 592
Understanding Assembly Configurations ..................................... 592
Applying Configurations for Performance.................................. 592
Using Configurations for Positions .................... ... ... .. ... 596
Applying Configurations for Product Variations. . ........................ ... 598

Using Design Tables for Assembly Configurations........................... 599



CONTENTS
Working with Modify Configurations and the Configuration Publisher. ........ 599
Looking at Assembly Configuration Dosand Don’ts ......................... 600
Tutorial: Working with Assembly Configurations .............................. 600
TheBottom Line.......... ... . 604
Chapter 20 « ModelinginContext ............oiviitieieinnnnnnnn. 605
Understanding In-Context Modeling ................ ... ... ... ... ..., 605
Working Through a Simple In-Context Example............................. 606
Weighing the Advantages of In-Context Modeling. .......................... 613
Anticipating Problems with In-Context Modeling ........................... 613
Identifying Alternatives to In-Context Modeling. ......................... ... 614
Dealing with the Practical Details of In-Context Modeling....................... 615
Understanding the In-Context Process ................. ... ... .. oL, 616
Looking at In-Context Best Practices . .................. ... ... ... ... 624
Using Other Types of External References . .................................... 630
Working with Split Parts . ......... ... ... .. .. o 631
Using Mirror Parts . ....... ... 631
Tutorial: Working In-Context . ............ ..o i 631
The Bottom Line....... ... 635
Chapter 21 « Editing, Evaluating, and Troubleshooting Assemblies. .. .. 637
Working with Mates. . .......... .. 637
Listing Mates inthe Mates Folder ............. ... .. ... ... . ... ... .. ... 637
Listing Mates Under the Component. .................. ... oo, 639
Displaying Mates Instead of Features ...................................... 639
Working with the View Mates Tool .................... ... ... . ..., 640
Using the View Mate Errors Window .................. ... ... ... ... ... 641
Using the MateXpert. . ... 641
Editing Mates. . ... ... 642
Editing File Management Issues .............. ... ... .o i 645
Using Save Options and Pack And Go ................. ... ... ot 645
Replacing Components . ...ttt 647
Forming and Dissolving Subassemblies .................................... 649
Evaluating Assemblies. . ........... ... .. 651
Using the Performance EvaluationTool .................... ... ... ... ..., 651
Identifying FeatureManager Symbols . ................ ... . ... ... .o ... 652
Using the Isolate Function.......... ... ... .. ... i i i 653
UsingReload ......... ... 653
TheBottom Line. ... ... .. 654
Chapter 22 . Working with Large ScaleDesign ...................... 657
Using Large Design Review . ........... ... ... .. ... ... ... ... .. 657
Updating Large Design Review .......... ... ..o .. 660
Resolving Components . ............ooiuiiiiiiiiii i, 660
Taking Snapshots .............. . 660

Creatinga Walk-Through .......... ... ... ... . ... 661

XXI



XXII

CONTENTS

Creating a GridSystem. ........... ... 663
Starting the GridSystem Feature. .............. ... ... ... . ... . ... ..., 664
CreatingtheSketch....... ... ... . ... 664
Using the GridSystem PropertyManager ................ ... ..., 665
Understanding the GridSystem Output ................ ... ... ... ... ... 665
Viewing the Grid Components. .............. ..., 666

Transferring Data with the IFC File Type . ........... ... ... ... i .. 667

The Bottom Line....... ... 668

Chapter 23 « Animating with the MotionManager ................... 669

Familiarizing Yourself with the MotionManager ............................... 670
Understanding the Terminology. .............. ... ... . o .. 670
Drivingan Animation ................ ... . oo i 671
Planning an Animation ............ ... ... i 672
Identifying Elements of the MotionManager ................................ 673
Using Display Options. ....... ... i 673
Using the MotionManager Interface .............. ... ... ... ... ... ..., 673
FormattingOutput ............... .. 673

Using the Animation Wizard ........... ... ... ... . i i 674
Creating a Rotating Animation........................ .. ... ... . oL 674
Creating an Exploded View Animation..................................... 677
Animatingan Assembly. ........ ... ... 678

Animating the View......... ... ... 683
Driving the View with Key Points ............. ... ... ... ... ... ... 684
Using Paths to Control Cameras. . ..., 688

Animating with Key Points .......... ... ... . . 691
Getting Started. . ........ ... 691
Using the Timebar with Key Points . . .................. ... ... o .. 692
Copying and Mirroring Motion ............ .. ... i i i 693
Adjusting the Speed of Actions. . ............ ... . i 693
Outputting the Animation.................. ... . i 694

Animating with Basic Motion. .................. ... . o i 696
Using Gravityand Contact ............. ... i 696
Using Motors and Springs. ... 697
Animating a Chain and a Spring Using Motors. . ............................ 698

Using the Mate Controller. . ........... ... ... . i 700

TheBottom Line. ... ... ... . 702

PartIVeCreating Drawings .. .......coiuiiiiiiiiiiineineenrerneneencannns 703

Chapter 24 « Automating Drawings: TheBasics...................... 705

Comparing Templatesand Formats ...................... ... ... .. oL, 705
Changing Existing Templates . ............... ... ... i .. 705
Maintaining Different Templates or Formats.......................... ... ... 706

Creating Custom Drafting Standards .................. ... ... ... ... ... 706



CONTENTS | XXIII

Creating Drawing Formats.......... ... ... ... ... ... ... ... ... ... ..., 707
Customizing an Existing Format ............. ... ... ... ... ... 708
Using Custom Properties. .................. i 710
Using the Title Block Function ............... ... ... ... ... .. .. 715
Creating a Format from an Imported DWG/DXFfile......................... 716
Saving the Format. ............ ... 718
Using Second Sheet Formats. ............ ... .. . oo i i 718

Creating Drawing Templates . .......... ... .. i i i 720
Using Predefined Views in Drawing Templates. . ............................ 720
Using Styles and Blocks in Templates ...................................... 724
Using Custom Properties in Templates . .................. ... ... ... ... 725
SavingaTemplate.............. 725

Creating Blocks. . ... .o 725

The Bottom Line. ... ... 726

Chapter 25 « Working with Drawing Views. ...........ccvivivnnenn. 727

Creating Common View Types. . ......... ... .. . i 727
Using the View Palette. . ........ ... .. ... o i i 727
Using Model VIEWS. . ... 728
Using the Projected View........... ... ... ... i i i 732
Using Standard 3 View. ......... ... . i 733
Using Detail View . ... 734
Working with Section Views .............. ... ... o 736

Creating Other View Types. . ... ... 740
Usinga Crop VIEW .. ..o 740
Using a Broken-Out Section View ............. ... ... .. i i, 740
UsingaBreak View. ......... ... i 744
Using an Auxiliary View . ... ... ... i i i 745
Using an Alternate Position View. ............. ... ... .. . oL 745
Using a Predefined View . ....... ... ... ... . 747
Usingan Empty View....... ... 747
UsingaSaved View ......... ... i 747
Converting a Drawing View toaSketch............... ... ... .. ... ... 748
Savinga View to DWG/DXF . ... i 748
Using a Relative View. . ....... ... o i 748
Using the 3D Drawing ViewMode ............ ... ... ... oo, 749
Changing View Orientation and Alignment. ................................ 750

Using Display Optionsin Views ............ ... i, 751
Using Display States. ........... ... . i 751
Using Display Styles. . ......... 751
Working with Tangent Edge Display Options ............................... 753
Choosing View Quality Settings. .............. ... ... .o i i 755

Distinguishing Views from Sheets................ ... ... ... ... o oo 756

Tutorial: Working with View Types, Settings, and Options....................... 756

The Bottom Line . . . ... e 762



XXIV | CONTENTS

Chapter 26 + Using AnnotationsandSymbols ....................... 765
Using Notes. ........... . 765
Setting Up a Workflow for Placing Notes .. ................................. 765
Utilizing Fonts. . ... ... 766
Using Text Boxes and Wrapping. . ......... ... ... ... o i .. 766
Placing Notesand Leaders .............. ... .. . i i i, 769
Adding Styles . ... ... 772
Using FormatPainter................. ... ... .. i i 774
Linking Notes to Custom Properties . .................. ... ... .. .. 774
Hyperlinking Text. ........... 775
Adding Notes and Symbols. .............. .. ... 775
Using Blocks in Drawings. . ...... ... 775
Inserting Blocks. ... 775
Creating Blocks .. ... 778
Editing Blocks .. ... 779
Using Symbols . ... ... 779
Using Symbols in Notes and Dimensions. ............... ... ..o, 779
Creating Custom Symbols. ........... ... ... ... ... 780
Using Center Marks and Centerlines ..................... ... ... ..., 780
Tutorial: Using Annotations . .............. ... o i 782
TheBottom Line......... ... .. . 784
Chapter 27 « Dimensioningand Tolerancing ..............c.covuven.. 787
Putting Dimensionson Drawings ................. ... ... ... ... ... . L 787
Using Insert Model Items. .. ........ ... ... o i 787
Using Reference Dimensions. . ............. ... ..o i i, 790
Understanding Dimension Options. ........... ... ... ..o oo, 795
Adding Tolerances . . ... 799
Changing Precision Values ............... .. ... i i 801
Using Geometric Tolerancing Symbols . ................ ... ... ... ..., 801
Using Dimension Styles. . .......... ... i 802
Aligning Dimensions and Annotations. . ................... ... ... o o 802
Using the Alignment Tools .............. ... ... i i i, 803
Inferencing Alignment and Grid Snapping ....................... ... ... ... 803
Using Dimension Palette Alignment Options ............................... 803
Arranging Dimensions Automatically.................. .. ... oo oL 804
Tutorial: Working with Dimensions and Tolerances............................. 805
The Bottom Line....... ... 808
Chapter 28 « Using Layers, Line Fonts,and Colors ................... 809
Controlling Layers . . ... 809
Working with Layers in Imported 2D Data. . ................................ 809
Working with Layers on the Sheet Format .................................. 810
Adding Dimensions and Notesto Layers......................... ... ..., 811
Working with Componentson Layers................. ... oo, 811

Controlling Line Format .. ......... ... 813



CONTENTS | XXV

Using the Line Format Settings. . .............. ... ... . . oo, 814
Setting the End Cap Style ........ ... ... i 814
Setting the Line Thickness................ .. ... . i i 814
Settingthe Line Style ......... ... ... . 815
Changing the Color Display Mode. ............ ... ... ... oo, 815
Hiding and Showing Edges ........... ... ... .. i i 815
Tutorial: Using Drawing Display Tools. . ................. ... ... o oo, 816
The Bottom Line....... ... 818
Chapter 29 « Working with Tables and Drawings..................... 821
Driving the Bill of Materials . ............ ... .. .. i i 821
Examining the SolidWorks Table-Based BOM ............................... 822
Retiring an Excel-Based BOM............. ... i 829
Using Design Tables. . ......... oo 830
Placing Hole Tableson Drawings ............. ... ... o ... 832
Using Revision Tables . ............ ... . i i 834
Using General Tables. .......... ... . i 836
Working with TablesinModels . ............. ... ... o i 836
Tutorial: Using BOMS . ... e 837
Tutorial: Using Hole Tables. . . ......... ... i 841
Tutorial: Using Revision Tables . ............ ... ... o i ... 843
TheBottom Line. ... ... ... . .. 844
Chapter 30 + Creating AssemblyDrawings.......................... 845
Combining Parts and Assemblies on the Same Drawing. ........................ 845
Dimensioning Assembly Features ..................... ... ... . .. L 845
Assigning the Document Driving the Custom Properties ..................... 846
Using Multi-Page Templates. . ........... .. ... .. .. . . il 847
Using Views with Special Assembly Functions................................. 849
Using the Alternate Position View ............. ... ... .. .. oo, 849
Creating Views of an Exploded Assembly .................................. 850
Creating Section Views. ............... . 855
Broken-Out Section View. ....... ... ... ... i 858
Using Color in Assembly Drawing Views ................. ... ... ... ... 860
Setting Up Drawings of Large Assemblies. ............... ... ... ... ... ... 861
Using Detached Drawings. ........ ... 861
Working with Lightweight Drawings ............... ... .. ... ..o .. 863
Using SpeedPak with Drawings. ............. ... ... o .. 863
Using Draft Quality Views. ......... ... o i i 865
Tutorial: Creating a Simple Assembly Drawing ................................ 866
TheBottom Line. ... ... ... ... 869
Part V « Using Advanced and Specialized Techniques ......................... 871
Chapter 31 + Modeling Multibodies................................ 873
Using Powerful Tools Effectively................ ... ... o .. 874
Comparing Multibody Modeling with Assembly Modeling ................... 874

Using Multibody Techniques Appropriately ................................ 875



XXVI | CONTENTS

Understanding Multibody Techniques.................... ... ... ... ..., 876
Using Simple Methods to Create Multiple Bodies............................ 877
Creating Complex Shapes Across Bodies ................................... 879
Using Tool Bodies and Boolean Operations ................................. 881
Using Local Operations . ... 885
Patterning. ... 887
Simplifying Very Complex Parts .............. ... ... . o i 888
Bridging Between Solids ............ ... .. . i 889
Modeling for Undetermined Manufacturing Methods........................ 890
Applying the Feature Scope to Bodies.................... ... ... ... ..., 891
Managing Bodies with the Split Feature . ................. ... ... ... ... ... ... 892
Adding Bodies Using the Insert Part Feature................................ 894
Using Intersect to Modify Bodies................. ... ... .o i i 896

Managing Bodies . .......... . 897
Using Body Folders. ........... ... 897
Hiding or Showing Bodies. . ......... .. ... .. i i 899
Deleting Bodies . ............ 901
Renaming Bodies. ............. i 902

Tutorials: Working with Multibodies ..................... ... ... ... ... ... 902
Merging and Local Operations................ ... ... . ... 902
Splitting and Patterning Bodies ............... ... ... . ... oL 903

The Bottom Line....... ... 906

Chapter 32 « WorkingwithSurfaces .............c.civivieiinnnn. 907

Introducing Surfaces . .......... .. 907

Understanding Surfacing Terminology. ........... ... ... ... o oo, 908
Exploring the Knit Function ............. ... ... ... oo oo 908
Using the Trim Function ........... ... ... .. ... . i i 908
Using the Untrim Function . .............. .. .. o i i 909
Hybrid Modeling ............ o 909
Understanding Non-Uniform Rational BSpline ............................. 910
Using Developable Surfaces .......... ... .. ... . i i 910
Using Ruled Surfaces........... ... .. .. i 911
Defining Gaussian Curvature . ............ ..o, 91

Surfacing Tools . . ... 911
Using the Extruded Surface................. ... ..o i il 911
Using Boundary Surface ........... ... ... .. 913
Using the Offset Surface. . .......... ... ... . ... i i 914
Using Radiate Surface .............. ... ... . ... i 915
Using KnitSurface ......... ... i 917
Using Thicken Surface . ........ ... .. . i 918
Using Planar Surface ........... ... .. ... i i 918
Using Extend Surface........... ... . i i i i 918
Using Trim Surface . ............ i 919
Using FillSurface ............. . 920

Using MidSurface........... ..o i 922



CONTENTS | XXVII

UsingReplace Face........... ... i i 923
Using Ruled Surface........... ... ... i i 924
Using Intersect. ....... ... ... ... 925
Tutorial: Working with Surfaces................. ... ... ... oL 926
Using Cut With Surface .......... ... ... 926
Using Offset Surface............ ... i i 927
Using Fill Surface Blend. . ......... ... ... .. o o i 929
The Bottom Line....... ... 933
Chapter 33 + Employing Master Model Techniques ................... 935
Master Model Tools and Techniques.............. ... ... ... ..o .. 935
Using Pull Functions . ........... .. 937
Understanding the Insert Part Feature ............................ ... ... ... 937
Understanding the Insert Into New Part Feature............................. 940
Using Push Functions ............. ... .. i 940
Working with the Split Feature................ ... ... ... .. ... ... ..., 941
Working with the Save Bodies Feature ..................................... 942
Tutorial: Working with Master Model Techniques .............................. 943
The Bottom Line....... ... 947
Chapter 34 « Using SolidWorks Sheet Metal Tools.................... 949
Using the Base Flange Features .............. ... ... ... . . o i, 949
Using the Base Flange/Tab Feature ..................... ... ... ... ... ..., 950
Using the Sheet Metal Feature ................ ... ... ... . ... .o iii.. 951
Using the Flat Pattern Feature. ........... ... ... ... ... ... o .. 957
Using the Edge Flange Feature................ ... ... ... . ... ... ... 959
Using the Miter Flange Feature. ............... ... ... ... . ... ..., 963
Using the Hem Feature ......... ... ... ... . . i, 964
Using the Jog Feature........... ... .. ... . i i 965
Using the Sketched Bend Feature...................... ... ... ... ..., 967
Using the Closed Corner Feature .............. ... ... ... ... ..o .. 967
Using the Corner Relief Feature . .............. ... ... ... . ... oi.. 970
Mirroring and Patterning in SheetMetal .......................... ... ... ... 971
Forming Tool Feature........... ... ... i 973
Using the Lofted Bends Feature . ................. ... ... ... ... .. ... 977
Using the Unfold and Fold Features ....................................... 978
Using the Swept Flange Feature............... ... ... .. ... ... .. 979
Using the Gusset Feature.............. ... .. .. ... . o i 981
Using the Taband Slot Feature . ............... ... ... .. . .. 981
Making Sheet Metal Parts from Generic Models................................ 983
Using the Normal Cut Feature ............. ... . ... ... ... ... ... ..., 984
UsingtheRip Feature............ ... ... .. .. . i 986
Using the Sheet Metal Feature ................ ... ... ... . ... ... ... 987
Using the Flatten Bends Feature............... ... ... ... .. ... ... ....... 987
Using the Process Bends Feature .............. ... ... ... ... oiiii.. 987

Using the NoBends Feature ................ ... ... o i i, 988



XXVIII

CONTENTS

Using the Flat Pattern Feature. . .......... ... ... ... ... ... o .. 988
Using the Convert To Sheet Metal Feature . ................................. 988
Using Other Methods ............. ... . 989
Working with Imported Geometry..................... ... ... ... ... 989
Making Rolled Conical Parts. ................ ... i 990
Mixing Methods ............ .. 990
Using Multibody Techniques with SheetMetal. ................................ 991
UsingInsert Part........ ... ..o 991
Using Multiple Base Flanges. ............ ... ... i i, 992
Tutorial: Working with the Insert Bends Method for Sheet Metal Parts ............ 992
Tutorial: Using the Base Flange Sheet Metal Method . ........................... 995
TheBottom Line............ .. 999
Chapter 35 « Creating Sheet Metal Drawings....................... 1005
Making Sheet Metal Drawings. .............. ..o i 1005
Getting the Flat Pattern . .......... ... .. 1006
Understanding Flat Patterns and Configurations ........................... 1007
Showing Bend Linesand Bend Notes . .................. ... ... ... ..., 1008
Showing the Bounding Box for the Flat Pattern............................. 1010
Showing Bend AreasonthePart ............. ... ... ... ...l 1010
Making Drawings of Multibody Sheet Metal Parts. ............................ 1012
Displaying Bodies on the Sheet Metal Drawing............................. 1012
Using a Cut Listin a Sheet Metal Part.................. ... ... ... ... ... 1013
Managing Cut List Properties. ............ ... ... ... o i 1013
Placing the Cut Liston the Drawing ................. ... ... o .. 1014
Saving a Cut List Template .............. ... . i i 1015
The Bottom Line......... ... i 1015
Chapter 36 ¢ Creating Weldments and Weldment Drawings .......... 1017
Sketching in3D. .. ... .. 1017
Navigatingin3DSpace .................o i i 1018
Understanding Sketch Relations in 3D Sketches ............................ 1019
Creating PlanesinSpace ... 1020
Limiting Path Segments............ ... ... .. ... i 1021
Using Dimensions in 3D Sketches ..................... ... ... L 1021
Using the Weldment Tools ............ . ... . i i 1022
Using the Weldment Feature. ............ ... .. ... ... ..o iii.. 1022
Introducing the Structural Member Feature................................ 1023
Using the Trim/Extend Feature ............... ... ... . ... ... ... ... ... 1029
Usingthe End Cap Feature .............. ... .. ... .. . .. 1030
Working with the Gusset Feature...................... ... ... ... ... ... 1030
Using Nonstructural Components. . ............. ..., 1032
Using Sub-Weldments . . ........... . i 1032
Working with Cut Lists . . ....... ... 1033
Using Cut-List Properties ................. .. o i i i 1034
Excluding and Reordering Cut-ListItems. ........................ ... ... ... 1034

Using Weld Beads and Fillet Beads in Weldments and Assemblies ............ 1036



CONTENTS | XXIX

Creating Weldment Drawings ............... . o i, 1038
Tutorial: Working with Weldments . ............. ... ... .. ... . ... 1040
The Bottom Line . . ... ..o e e 1046

Chapter 37 « Using Imported Geometry and Direct-Editing

Techniques ....... ..ottt iiiiiiiiiiiriiinenrnneeeneannannnns 1049
Understanding the Basics of Imported Geometry.............................. 1049
Using SolidWorks 3D Interconnect. . ...................o o i, 1051
Gaining Experience with Imports. .. .......... ... ... ... .o 1052
Handling Import Errors. ........ ... 1057
Converting PointCloud Data . ........... .. ..o i i, 1060
Understanding the Traditional Role of Direct Editing Tools..................... 1060
Understanding the Strengths and Limitations of Direct
Editing Tools in SolidWorks. . ......... ... . i i i 1061
Using SolidWorks Direct Editing Tools. . ................. ... oo .. 1062
UsingMoveFace................. ... ... 1063
Combining Direct Editing with History ................ ... ... ... ... ... 1064
Combining Direct Editing with Imported Geometry ........................ 1067
Tutorial: Importing and Repairing Solid Geometry ......................... ... 1067
Tutorial: Flexand Freeform. ......... ... .. ... .. . i i 1069
TheBottom Line. ... ... ... 1072
Chapter 38 » Using PlasticFeatures............covivvienrnnncnnnns 1073
Using Plastic Features . .......... ... . i i 1073
Using the Mounting Boss. . ......... ... ... oo i i i 1074
Using the Snap Hook and Snap Hook Groove.............................. 1076
Using Lip/GIoove . ... 1078
UsingtheRib Feature.............. ... ... .. .. ... i, 1079
Using Draft. ... 1083
UsingIndent ....... ... .. .. 1087
Working with Shell . .......... . . 1088
Using the Vent Feature............. ... ... .. . .. i i 1091
Using Plastic Evaluation Tools. .............. .. . i i i, 1093
Using Draft Analysis ........... ... . i i i 1094
Using Thickness Analysis .......... ... .o i 1098
Undercut Analysis. ... 1100
Understanding the Undercut Analysis Workflow ........................... 1101
TheBottom Line.......... ... .. . 1102
Chapter39 « UsingMoldTools . .........ccoeitiiiiiennenennnnenens 1107
Working with the Mold Tools Process. . ........... ... ... ... .. 1107
Preparing the Plastic Part for Mold Tools . ............... ... ... ... ...... 1109
Inserting Mold Folders. ......... ... .. .. . i 1111
Parting Lines . ... ... 1113
Initiating the Shut-Off Surfaces. .............. ... ... ... o il 1115
Parting Surface ......... ... .. 1117

Tooling Split. . ... ... 1119



XXX |CONTENTS

Using the Core Feature............. ... ... .. .. i i i, 1121
Working Manually withMold Tools . ............. ... ... .o .. 1122
Passing Shut-Offs ............. ... . 1122
Creating Nonplanar Parting Surfaces .................... ... ... ... ..... 1123
TheBottom Line........ ... 1124
Appendixes. . .......c.iitiiiiiiiiii ittt ittt 1127
AppendixA « TheBottomLine.................ciiiiiiiieienn... 1127
Chapter 1: Introducing SolidWorks. . ......... .. ... ... .. oo 1127
Chapter 2: Navigating the SolidWorks Interface............................... 1127
Chapter 3: Working with Sketches and Reference Geometry .................... 1128
Chapter 4: Creating Simple Parts and Drawings. . ............................. 1129
Chapter 5: Using Visualization Techniques ................. ... ... ... .. ... ... 1130
Chapter 6: Getting More from Your Sketches. ........................... ... ... 1130
Chapter 7: Modeling with Primary Features .................................. 1131
Chapter 8: Selecting Secondary Features ..................................... 1132
Chapter 9: Patterning and Mirroring. . ............ ... ... ... i, 1133
Chapter 10: Using Equations .............. ... i, 1134
Chapter 11: Working with Part Configurations................................ 1135
Chapter 12: Editing, Evaluating, and Troubleshooting ......................... 1135
Chapter 13: Building Efficient Assemblies ............................ .. ... ... 1136
Chapter 14: Getting More fromMates. . .......... ... ... ... ... il 1137
Chapter 15: Patterning and Mirroring Components. ........................... 1138
Chapter 16: Working with Assembly Sketches and Layouts..................... 1139
Chapter 17: Using Assembly Tools .............. ... ..o ... 1140
Chapter 18: Using Libraries, Assembly Features, and Hole Wizard. .............. 1141
Chapter 19: Controlling Assembly Configurations and Display States............ 1142
Chapter 20: Modeling in Context. . . .......... ..., 1143
Chapter 21: Editing, Evaluating, and Troubleshooting Assemblies............... 1143
Chapter 22: Working with Large Scale Design. . ............................... 1144
Chapter 23: Animating with the MotionManager.............................. 1145
Chapter 24: Automating Drawings: The Basics..................... ... ... ... 1145
Chapter 25: Working with Drawing Views. ................ ... ... ... ... ... 1146
Chapter 26: Using Annotations and Symbols ................................. 1147
Chapter 27: Dimensioning and Tolerancing. .................................. 1148
Chapter 28: Using Layers, Line Fonts,and Colors ............................. 1149
Chapter 29: Working with Tables and Drawings. .............................. 1150
Chapter 30: Creating Assembly Drawings.................................... 1150
Chapter 31: Modeling Multibodies ................ ... ... ... ... .. i 1151
Chapter 32: Working with Surfaces.............. ... ... . ... ... ... ... 1152
Chapter 33: Employing Master Model Techniques............................. 1153
Chapter 34: Using SolidWorks Sheet Metal Tools . ............................. 1155
Chapter 35: Creating Sheet Metal Drawings ................. ... ... ... ... ... 1159
Chapter 36: Creating Weldments and Weldment Drawings ..................... 1160

Chapter 37: Using Imported Geometry and Direct-Editing Techniques ........... 1161



CONTENTS | XXXI

Chapter 38: Using Plastic Features .............. ... ... . ... ... ... ... 1162
Chapter 39: Using Mold Tools . .............. ... ... i, 1165
AppendixB « FindingHelp ............ ...ttt 1169
SolidWorks Help. . ... ... 1169
SolidWorks Web Help. ......... ... i 1169
GO NS . . ottt 1170
SaATC . . o 1170
SOLIAWOIks Website . . ..o e 1170
Graphics Cards . ... 1170
Customer Portal . ... ..o 1170
SolidWorks FOrums. . . ... oo 1171
KnowledgeBase .............. i 1171
Software Downloads . ....... ... 1171
Release NoOtes. . . ..ot 1171
What' s NeW . ..ot e 1172
Installation and Administration Guides . ............ ..ot 1172
CAD Admin Dashboard. . ...t i 1172
Online FOrumsS. . . ..ot e e 1172
Blogs . 1172
Borums . ... 1173
Appendix C « What’sontheWebsite ....................ocivuaae, 1175
System Requirements. . ......... ... ... ... . 1175
SOLAWOTrKS Versions . . . ..ottt e e e e 1175
Troubleshooting. ............. . 1176
CUSTOMET CaATe . . oottt e e e e e e e 1176



Introduction

SolidWorks is an immense topic, especially if you are new to the software. There is a lot to know
and a lot to write about. While I have made every effort to be complete in this book, I'm sure
there are some niche topics that have gone untreated. In this edition, I rely more on video
introductions for each chapter to demonstrate some of the basic concepts.

Who Should Read This Book

This book is primarily meant as an encyclopedic desk reference for SolidWorks Standard users
who want a more thorough understanding of the software and process than can be found in
other available documentation. As such, it is not necessarily intended to be a guide for beginners,
although it has elements of that. Nor is it necessarily intended as a classroom guide, but it could
be used for that as well. This book will take you into areas of technical application where training
classes don’t go—and into best practices you won’t find anywhere else.

What You Will Learn

To keep the size of the book down, I have tried to avoid topics found only in SolidWorks
Professional or Premium, although some discussion of these topics was unavoidable at times.

While the book does point out limitations, bugs, and conceptual errors in the software, in
every case this is meant to give the reader a more thorough understanding of the software and
how it is applied in the context of everyday design or engineering practice. I believe that you
don’t know how much you can do until you find the boundary—so I frequently push past the
limits of the software.

The overall goal of this book is not to fill your head with facts, but to help you think like the
software, so that you can use the tool as an intuitive extension of your own process. As your
modeling projects get more complex, you will need to have more troubleshooting and worka-
round skills available to you. Along with best practice recommendations, these are the most
compelling reasons to study this book.

This is not a book about machine design, nor industrial design, nor even engineering. This is a
book about how to use SolidWorks as a CAD design documentation tool. There is some assump-
tion that you are familiar with general design and engineering practice and terminology.

Thank you for your interest.
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What You Need

Make sure that your computer meets the minimum system requirements listed on the
SolidWorks website. If your computer doesn’t match up to these requirements, you may have a
problem using the contents of the download site.

You need to be somewhat familiar with engineering principles (a first-year college engineer-
ing curriculum would certainly suffice) and have some experience with engineering documenta-
tion practices. Spatial reasoning skills are very helpful to visualize some 3D concepts, and a basic
understanding of logic or programming will help you understand the typical workings of a
history-based modeler.

WINDOWS VERSIONS
These requirements apply to Windows 7 and Windows 10:

¢ Intel and AMD processors, single, dual, or quad cores

¢ 1 GBRAM minimum (2 GB recommended)

¢ Virtual memory twice the amount of RAM (recommended)
L 2

A certified OpenGL workstation graphics card and driver (Check the SolidWorks website
for details: www . solidworks.com.)

¢ A mouse or other pointing device
¢ Microsoft Internet Explorer 6 minimum (IE 7 recommended)
¢ A CD drive minimum (DVD drive recommended)

For more details about the system requirements for SolidWorks 2018 and a list of certified
graphics cards and drivers, visit www. solidworks.com.

SOLIDWORKS VERSIONS

Files created in SolidWorks 2018 are not compatible with older versions of SolidWorks. So, if you
have a version of SolidWorks older than 2018, you will have difficulty reading most of the
accompanying downloaded files. You may find some files that came from older versions in the
downloaded data, but this will happen only where the files have not been updated for new
versions. If you have any questions, you should contact your SolidWorks reseller. The author of
this book does not have the ability to save 2018 files to previous versions.

This book was written using the SolidWorks 2018 version software, and while some of it may
be applicable to previous versions, some of it may not be due to annual changes that happen in
the course of software development.

TROUBLESHOOTING

If you have difficulty installing or using any of the material from the download data, try the
following solutions:

¢ Turn off any antivirus software that you may have running. Installers sometimes mimic
virus activity and can make your computer incorrectly believe that it is being infected by
a virus. (Be sure to turn the antivirus software back on later.)
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¢ Close all running programs. The more programs you're running, the less memory is
available to other programs. Installers also typically update files and programs; if you
keep other programs running, installation may not work properly.

& See the ReadMe file. Refer to the ReadMe file located at the root of the download website
for the latest product information at the time of publication.

If you are having trouble viewing the downloaded videos, please install the TechSmith
video codec.

The Mastering Series

The Mastering series from Sybex provides outstanding instruction for readers with intermediate
and advanced skills, in the form of top-notch training and development for those already
working in their field, and clear, serious education for those aspiring to become pros. Every
Mastering book features the following:

¢ The Sybex “by professionals for professionals” commitment. Mastering authors are
themselves practitioners, with plenty of credentials in their areas of specialty.

¢ A practical perspective for a reader who already knows the basics—someone who needs
solutions, not a primer.

¢ Skill-based instruction, with chapters organized around real tasks rather than abstract
concepts or subjects.

¢ Self-review tests with “The Bottom Line” problems and questions, so you can be certain
you're equipped to do the job right.

What Is Covered in This Book

You will find enough information here that the book can grow with your SolidWorks needs.

I wrote the tutorials for most of the chapters with newer users in mind, because for them, it is
most helpful to see how things are done in SolidWorks step by step. The longer narrative
examples give more in-depth information about features and functions, as well as the results of
various settings and options.

This book includes many details that come from practical usage and is focused on the needs of
professional users, not on student learners. My preference is to teach concepts rather than button
pushes, because if you understand what is going on, you can find the button pushes for yourself.

This book is divided into five parts. You will find that some topics are visited multiple times,
such as sketching, mates, templates, and so on. When a topic is visited more than once, it is
because there are many aspects to that topic. One such example is sketching, which includes
simple sketches, sketch relations, sketch editing, troubleshooting, 3D sketches, shared sketches,
and more. Sketch information is found in at least 10 different chapters. It cannot be consolidated
because shared sketches are an advanced technique, while simple sketching is not.
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INTRODUCTION

Part I: Introducing SolidWorks Basics

This part explores the basic concepts and terminology used in SolidWorks. You need to read this
section if you are new to the software and especially if you are new to 3D modeling or parametric
history-based design.

Part II: Building Intelligence into Your Parts

This part takes a deeper look at creating parametric relations to automate changes.

Part III: Working with Assemblies

This part examines the tools available to users within SolidWorks assemblies. Assemblies enable
you to put parts together in different ways. You can create motion and animations, check for
interference and clearance, and look at the data in many different ways.

Part IV: Creating Drawings

This part goes through the tools and techniques for creating drawings from your SolidWorks
parts and assemblies. Drawings are the industry-standard way of communicating designs,
inspection requirements, and manufacturing processes. Part IV examines several types of
advanced techniques, such as surface modeling and multibody modeling. This is information
you won't find in other SolidWorks books, explained here by someone who uses the function-
ality daily.

Part V: Using Advanced and Specialized Techniques

Specialized functionality, such as sheet metal and plastics, requires detailed information. Part V
includes these topics because they are key to unlocking all the power available in SolidWorks.
Part V examines several types of advanced techniques, such as surface modeling and multibody
modeling. This part also contains information you won’t find in other SolidWorks books,
explained here by someone who uses the functionality daily.

Appendixes

The appendixes in this book contain information that was not appropriate for the main body of
the text, such as the contents of the download material and other sources of help.

NOTE The companion download site (www.wiley.com/go/mastersolid) is home to all the
demo files, samples, and resources mentioned in the book. See Appendix B, “Finding Help,” for more
details on the contents and how to access them.

How to Contact the Author

You might want to contact me for some reason. Maybe you found an error in the book, or you
have a suggestion about something that you think would improve it. It is always good to hear
what real users think about the material, whether you like it or think it could be improved.
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The best way to contact me is either through e-mail or through my blog. My e-mail address is
matt@dezignstuff.com. You will find my blog at www.dezignstuff.com. On the blog, you
can leave comments and read other things I have written about the SolidWorks software, CAD,
and engineering or computer topics in general. If you want to contact me for commercial help
with a modeling project, my e-mail address is the best place to start that type of conversation.

Thank you very much for buying and reading this book. I hope the ideas and information
within its pages help you accomplish your professional goals.

Wiley strives to keep you supplied with the latest tools and information you need for your
work. Please check their website at www .wiley.com/go/mastersolid, where we'll post the
download materials for each chapter, additional content, and updates that supplement this book
if the need arises.
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Introducing SolidWorks

In SolidWorks, you build 3D parts from a series of simple 2D sketches and features such as
extrude, revolve, fillets, cuts, and holes, among others. You can put the parts together into
assemblies. You can then create 2D drawings from the 3D parts and assemblies.

This chapter will familiarize you with some of the basic concepts employed by SolidWorks.

IN THIS CHAPTER, YOU WILL LEARN TO:

Install SolidWorks

Get started with SolidWorks

Identify different types of SolidWorks documents
Understand feature-based modeling

Understand history-based modeling

Sketch with parametrics

Control changes with design intent

Modify design intent

® & ¢ 6 6 0 0 o o

Work with links between documents

VIDEO

You can view videos for every chapter on the Wiley website and download sample files. View the
Chapter 1 Introduction video to get started.

Installing SolidWorks for the First Time

Some of you will have SolidWorks installed for you by people in your company or by SolidWorks
reseller experts, and some of you will need to perform the installation on your own. Regardless,
it is best to make sure that your hardware and software are compatible with the SolidWorks
system requirements, which are available on the SolidWorks website at www. solidworks.com/
sw/support/SystemRequirements.html.

Mastering SolidWorks, First Edition. Matt Lombard.
© 2019 John Wiley & Sons, Inc. Published 2019 by John Wiley & Sons, Inc.
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SolidWorks installs natively only on 64-bit operating systems. It is supported only for
Windows 7, 8.1, and 10. In all cases, the professional-level OS is recommended, as opposed to the
Home edition. Excel and Word 2016 are also recommended. Although it is possible to install and
run SolidWorks under emulators on Apple hardware, that configuration is not supported or
tested by SolidWorks Corporation or its resellers.

You can find graphics card requirements at the previously mentioned link for system require-
ments. The main concern with a graphics card for SolidWorks is that it must be compatible with
OpenGL and be SolidWorks certified. Hardware changes too rapidly for me to give specific
recommendations here.

In addition to having the correct hardware installed, you also must have a compatible driver
version installed. Again, refer to the SolidWorks system requirements website.

Alternatively, you might not want to get that involved at first. You can install the software
with all the defaults just to get started, using the first attempt as a practice installation, especially
if you intend to learn as much as you can about SolidWorks, and then come back and do a more
thorough job of implementing it later.

You should count on the installation requiring about 16 GB of space on your hard drive,
depending on the options you select to install. The locations of files on your computer will vary
by SolidWorks version, by your operating system, and by your own installation choices, but the
bulk of the files will be placed into two separate folders: the Program Files folder (C:\Program
Files\SolidWorks Corp\SolidWorks) and the Toolbox Data folder (C:\SolidWorks Data).

Before installing any software, be sure to exit out of all other software first, turn off antivirus
software, make sure you have enough hard drive space, and verify that the system meets the
requirements outlined on the SolidWorks System Requirements web page.

Installations generally begin from a download of an installer application named
SolidWorksSetup.exe, which is about 30 MB. You may need a login to access this area of the
site. Find the download area at http://www.solidworks.com/sw/support/downloads
. htm, shown in Figure 1.1.

Home > Support > Downloads

e Downloads

paispl e Download new versions, service packs, and add-ins.
Downloads
Select Version:
Installation FAGS

ardware & System
Requirements

SOLIDWORKS Certification

SOLIDWORKS Trainin: 3

Once you download and execute the installer, you will be prompted to unzip the installation
files, and the installation will begin, as shown in Figure 1.2.
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FIGURE 1.2
The SolidWorks 2018
Installation Manager

2018

Welcome
Serial Number
System Check
Summary
Download
Install

Finish

Cancel

UM SOUICWORKS 2018 SPO.1 Instslation Manage:

25 SOLIDWORKS

©)

Help

INSTALLING SOLIDWORKS FOR THE FIRST TIME

Welcome to the SOLIDWORKS Installation Manager
SOLIDWORKS 2018 SPO.1

Specily the type of instaliztion:

@ Inavidual (on this compuszr)
O Administrative image
O sarver products

) Dewrioad and Share all files. Create individual ingtalle or Bdmiristrative Images on iultiple machines with a single
dowrload.

(=)

Mext

The next screen asks for your serial number, which is a 24-character code. After the installa-
tion, you will be required to activate your SolidWorks license. Figure 1.3 shows the Activation
page of the installation process. If you have difficulty with this, you may want to contact your

support organization.

FIGURE 1.3

SolidWorks 2018
Activation

About...

@ SOLIDWORKS Product Activation >

2
PS SOLIDWORKS

Result

\0\ Activation/Reactivation Succeeded.

Currently activated products:

Product Activation Expires Maintenance Expir...
SOLIDWORKS Premium 9-25-2017 9-25-2017
SOLIDWORKS Simulation Pr... 9-25-2017 9-25-2017
SOLIDWORKS Electrical Pro... 9-25-2017 9-25-2017
SOLIDWORKS Plastics Premi... 9-25-2017 9-25-2017
SOLIDWORKS CAM Professi... 9-25-2017 9-25-2017
SOLIDWORKS MBD Standard  9-25-2017 9-25-2017
< >

Refresh

Join the SOLIDWORKS Community

R
Find answers. 5tay connected. Join now!

< Back | Finish | Help

When the installation is complete, reboot the system.
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FIGURE 1.4
Activation options on
the Help menu

INTRODUCING SOLIDWORKS

Starting SolidWorks for the First Time

SolidWorks has many tools that are available for beginning users when the software is installed.
A default installation presents you with several options when the software is started the first
time. This section includes a description of these options and how you can most benefit from
them. If you plan to go to formal SolidWorks reseller-based training classes, be sure to go
through some of the tutorials mentioned in this section first, so you will be prepared to ask
educated questions and have a leg up on the rest of the class. You will get more out of the
training with the instructor if you have already seen the material.

Examining the SolidWorks License Agreement

Becoming familiar with the license agreement can be useful, but the agreement does not have
any bearing on learning how to use the software other than the fact that it allows you to reacti-
vate as needed. This ability enables you to use your license on different computers—for example,
at work and at home. To use your license at home, make sure the software is installed at both
locations and both locations are connected to the Internet, and then activate it at work. When you
are done at work, deactivate the license and reactivate it at home using the same serial number. It
would be a good idea to consult your CAD administrator before you do this. You can access the
Activation options in the Help menu, as shown in Figure 1.4. Network licenses may work
differently. When you are done at home, you can deactivate the license at home and reactivate at
work. It is like a floating license, where the server is at a SolidWorks facility. Again, contact your
support organization with questions about any specific details.

£} Welcome to SOLIDWORKS Ctrl+F2 @
(3 SOLIDWORKS Help
SOLIDWORKS Tutorials

APl Help

Search 3
Release Motes

What's New 3

@ Introducing SOLIDWORKS (pdf)
Moving from 2D to 3D

Check for Updates...

Activate Licenses... I,\\)
Deactivate Licenses...

Show Licenses...

My Products...

About SOLIDWORKS...

Using the Help Menu

You can access the Help menu in two ways. A question mark in the upper right has a drop-down
arrow next to it that enables you to access all the Help options. Help is also on the flyout menu
next to the SolidWorks logo in the upper left. You will find that SolidWorks offers multiple ways



FIGURE 1.5
The Welcome to
SolidWorks screen Home Recent Learn Alerts

STARTING SOLIDWORKS FOR THE FIRST TIME

to access many commands. You should become comfortable with at least one method for

accessing the tools you need to use. It isn’t necessary to know all the ways unless you are
teaching others (or writing a book).

VIEWING THE WELCOME TO SOLIDWORKS DIALOG

The Welcome to SolidWorks screen, shown in Figure 1.5, is the first thing to greet you when you
open the software. This helps you open recent files, browse for existing data, or create a new
document. The Advanced button gives you access to all available templates (templates will be
covered later in this chapter), and you can look inside the folders for each of the recent docu-
ments by hovering the mouse cursor over the preview.

Welcome - SOLIDWORKS 2018 7 X

New

(T Part @ Assembly Drawing Advanced... ;‘1 Cpen

Recent Documents View all

£D ring3.5LDPRT Starship Enterpris... blended frame SL... bike assembly.5LD... batmabile SLDPRT

TL -
pue s e isiasc g 7
T g Ll

ay g

Recent Folders View all Resources

= Cerro Metals ~
- D:\Data'\parts'Cerro Metals I:?j? What's New B Beta Home
= old
- D:\Data'\partstimpact plastics\old

Eﬂ MySalidWorks a Beta Hot Issues
[F— Crenshaw
- D:\Data'\parts'\Crenshaw

Enterprise B2 Beta Forum [ Report 2 Beta Issue
- D:\Data'\parts\Enterprise
v

@ Arrow keys rotate the model. Ctrl «= Arrow Keys pan the model. Alt = Arrow Keys rotate the model clockwise and counterclockwise.

The tabs at the top of the dialog (Home, Recent, Learn, and Alerts) will reconfigure the
Welcome dialog to show various topics. The Learn tab has links to various training and tutorial
material, sample parts, and assemblies. The Alerts tab shows SolidWorks news such as the
release of a Beta or special notices about problems or fixes in the software.

Also notice at the bottom of the Welcome dialog is the Tip of the Day. You can cycle through
these tips when you have a few spare moments.

ACCESSING WHAT’S NEW

You can find the What’s New documentation in the Help menu, as shown in Figure 1.4. You can
also enable interactive What’s New options (Help > What’s New > Interactive). This adds a
question mark with an asterisk symbol next to menu items that are new and have special Help
file entries. You will find more information about setting up the SolidWorks interface in
Chapter 2, “Navigating the SolidWorks Interface.”
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D New...

FIGURE 1.6

Selecting a template in
the New SolidWorks
Document dialog

INTRODUCING SOLIDWORKS

ACCESSING OTHER RESOURCES

Between the Help and the Welcome dialogs, SolidWorks offers several options for help, including
tutorials, What’s New, and the SolidWorks forums.

Creating a New Document

To start a new SolidWorks document, click the New icon in the title bar of the SolidWorks
application. With standard functions such as creating a new document, SolidWorks works just
like a Microsoft Office application, and the icons even look the same.

SolidWorks has three basic types of documents: parts, assemblies, and drawings. Parts are the
basic 3D file type. You put parts together to create assemblies, and drawings are the 2D file type for
documenting parts and assemblies.

When you create a new SolidWorks document, you will see the screen shown in Figure 1.6. By
default, this dialog box contains templates for parts and assemblies. You can make your own
customized templates to add to them or share templates with other users on a network.
Templates have several already-established settings, most importantly units. You can change the
units of a document after it is created, but most people find it easier to start with the correct
units. You can mix units in parts, and used parts with different units in assemblies, but this can
get confusing when editing parts with mixed units in the context of an assembly.

Mew SOLIDWORKS Document *

=
Sl

Part Assembly Drawing

a 3 representation of a single design a 3D arrangement of parts and/or other | a 2D engineering drawing, typically of a
component assemblies part or assembly

Advanced oK Cancel Help

Templates also control the drafting standard used with the document. ANSI and ISO are the
two primary standards, although others are available. One option you need to be aware of with
the ISO standard is that some locations that use the ISO standard also use First Angle Projection,
while ANSI users and some ISO users use the Third Angle Projection system.
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IDENTIFYING SOLIDWORKS DOCUMENTS

The Drafting Standard setting is found under Tools > Options > Document Properties >
Drafting Standard, as shown in Figure 1.7. The projection angle can be specified both in drawings
and in parts/assemblies. You can find the drawing setting by clicking the right mouse button
(RMB), clicking on the Sheet entry in the FeatureManager on the left of the drawing document
window, and selecting Sheet Properties.

Overall drafting standard
1SO-MODIFIED

;--Annotations

. Borders Derived from: IS0

;--Dimensions

Centerlines/Center Marks

The projection type for 3D parts and assemblies becomes important when you set up view-
ports within the SolidWorks window. The setting for this is located under Tools > Options >
Display/Selection > Projection type (at the bottom of the list). This does not follow the drafting
standard selected for the default templates or the country in which the software is installed.

For more information on first- and third-angle projections, refer to this Wikipedia article:
http://en.wikipedia.org/wiki/Multiview_orthographic_projection.

Be sure to get the option correct. If someone else, such as a computer specialist who is not
familiar with mechanical drafting standards, initially sets up SolidWorks on your computer,
verify that the default templates use the correct standards, units, and projection method. The
projection angle setting is shown in Figure 1.8.

FIGURE 1.8
Projection Angle setting

Sheet Properties  Zone Parameters

Type of prajection
Name: | Sheet! Next view label: Hide/Show Tree Items...
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b =] Sheett
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% Display Grid

[#] Edit Sheet Format.
Add Sheet...

[y copy

¥ Delete

Properties...
Relations/Snaps Options..
Comment »
GoTo..

2 Zoom to Selection

Customize Menu

|

Identifying SolidWorks Documents

SolidWorks has three main data type files: parts, assemblies, and drawings; however, if you are
concerned with customizing and creating implementation standards, you may want to become
familiar with some additional supporting types. Table 1.1 outlines the document types.

9
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TABLE 1.1: Document Types
DESIGN DOCUMENTS DESCRIPTION
.sldasm SolidWorks assembly file type
.slddrw SolidWorks drawing file type
.sldprt SolidWorks part file type

Templates and Formats

.asmdot
.asmprp
.drwdot
.drwprp
journal.doc
.prtdot
.prtprp
.sldbombt
.sldtbt
.slddrt
.sldholtbt
.sldrevtbt
.sldwldtbt
x1s
Library Files
.sldblk
.sldlfp
Styles
.sldgtolfvt
.sldsffvt

.sldweldfvt

Description

Assembly template

Assembly custom properties tab template

Drawing template

Drawing custom properties tab template

Design journal template

Part template

Part custom properties tab template

BOM template (table-based)
General table template
Drawing sheet format

Hole table template
Revision table template
Weldment cutlist template
BOM template (Excel-based)
Description

Blocks

Library part file
Description

Geometric tolerance style
Surface finish style

Weld style
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TABLE 1.1

DESIGN DOCUMENTS

Symbol Files
gtol.sym
swlines.lin
Others

.btl
calloutformat.txt
.sldclr
.sldreg
.sldmat
.sldstd
.swb, .swp
Ltxt

.x1s

Document Types (CONTINUED)

DESCRIPTION

Description

A symbol file that enables you to create custom symbols

A line-style definition file that enables you to create new line styles

Description

Sheet metal bend table
Hole-callout format file
Color palette file
SolidWorks settings file
Material database
Drafting standard

Macros, macro features

Custom property file, sheet-metal-bend-line note file

Sheet metal gauge table

Unlike some other CAD programs, SolidWorks does not use separate file types for sheet metal
and weldment parts; they are all just *. sldprt. The features within the parts distinguish them as
either sheet metal or weldment parts.

Also unlike other CAD programs, SolidWorks’ templates have a special file type (for example,

part templates are *.prtdot) and are not just “start parts.”

Saving Your Setup

If you need to reinstall SolidWorks, move to another computer, or duplicate the setup for another
user, you need to copy the files you have used or customized. By default, all these files are
located in different folders within the SolidWorks installation directory. Chapter 2 deals with
interface settings and creating a Registry Settings file to copy to other computers or use

as a backup.

BEST PRACTICE

When you are performing complex implementations that include templates of various types of
tables or customized symbol files, it is especially important to have copies of any customized tem-
plates or library files in a location other than the default installation folder. Uninstalling SolidWorks
or installing a new version could wipe out all your hard work. Choose Tools > Options > File Location

to establish separate library folders on the local hard drive or on a network location.
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Using Templates

I'have included some of my part and assembly templates with the download materials for this
book. After you have downloaded the zip files for each chapter, extract and copy them to the
folder specified at Tools > Options > File Locations > Document Templates.

ON THE WEBSITE

Wiley has established a website for the material in this book. You can download files for each chapter
from www.wiley.com/go/mastersolid

When you begin to create a new document, and the New SolidWorks Document dialog box
gives you the option to select one of several files to start from, those files are templates. Think of
templates as “start parts” that contain all the document-specific settings for a part (Tools >
Options > Document Properties). The same concept applies to assemblies and drawings.
Templates generally do not have any geometry in them (although it is possible).

As shown in Figure 1.6, several tabs can be displayed on the Advanced interface. Each of
these tabs results from creating a folder in the template directory specified in the Options dialog
box (Tool > Options > File Locations > Document Templates). To switch from the Novice
interface to the Advanced interface, click the Advanced button. To switch from Advanced to
Novice, click the Novice button shown in Figure 1.9.

MULTIPLE DOCUMENT TEMPLATES

When starting a new document, you will be given many options if you have multiple templates
available. This offers an advantage in many situations, including the following:

¢ Standardization for a large number of users

Work produced in various units

Preset materials

Preset custom properties

Parts with special requirements, such as sheet metal or weldments
Parts and assemblies with standardized background colors

Drawings of various sizes with formats (borders) already applied

® ¢ 6 6 & o o

Drawings with special notes already on the sheet

Drawing templates and formats are so complex that I devote an entire chapter to them.
Chapter 24, “Automating Drawings: The Basics,” discusses the differences between drawing
templates and formats, and how to use them to your advantage. This chapter addresses part and
assembly templates.

Depending on your needs, it might be reasonable to have templates for metric parts and
assemblies and Imperial parts and assemblies, templates for steel and aluminum, and templates
for sheet metal parts and weldments, if you design these types of parts. If your firm has different
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FIGURE 1.9
’Hle NOViCe and Mew SOLIDWORKS Document x
Advanced interfaces for
the New SolidWorks
Document dialog box
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Part Assembly Drawing
a 3D representation of a single design a 3D arrangement of parts and/or other a 2D engineering drawing, typically of a
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Advanced oK Cancel Help

Mew SOLIDWORKS Document b
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part assem draw Preview
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customers with different requirements, you might consider using separate templates for each
customer. Over time, you will discover the types of templates you need, because you will find
yourself repeatedly making the same changes to new parts.

To create a template, open a document of the appropriate type (part, assembly, or drawing),
delete all features. (Although it is possible to use templates with pre-created geometry, it is
unusual.) Make the settings you want the template to have. For example, units are one of the

13
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most common reasons to make a separate template, although any Document Property setting is
fair game, from the dimensioning standard used to the image quality settings. You can find these
settings through the menus at Tools > Options> Document Properties.

Some document-specific settings do not appear in the Document Properties dialog box, such
as the names of standard planes or the use of axes as reference geometry. Still, these settings are
saved with the template. Settings that fall into this category are the View menu'’s entity-type
Visibility option and the Tools > Sketch Settings menu options.

Custom properties are another piece of the template puzzle. If you use or plan to use BOMs
(Bills of Materials), PDM (Product Data Management), or linked notes on drawings, you need to
take advantage of the automation options available with custom properties.

Two Default Template options are available: “Always use these default document templates”
and “Prompt user to select document template.” The Default Template options apply to situa-
tions when a template is required by an automatic feature in the software, such as an imported
part or a mirrored part. In this situation, depending on the option selected, the system automati-
cally uses the default template or the user is prompted to select a template.

PERFORMANCE

Allowing the software to apply the default template automatically can speed up the process dramati-
cally. This is especially true in the case of imported assemblies, which require you to select templates
manually for each imported part in the assembly if the “Prompt user to select document template”
option is selected.

SHARING TEMPLATES

If you are administering an installation of a large number of users, or even if just a couple of
users are working on similar designs, shared templates are necessary. If every user does what he
or she thinks is best, you may get an adverse combination of conflicting ideas, and the consist-
ency of the company’s documentation may suffer. Standardized templates cannot make users
model, assemble, and detail in exactly the same way, but they do help users start on the

same foot.

To share templates among several users, create a folder for templates on a commonly acces-
sible network location, preferably with read-only access for users and read-write permissions for
administrators. Then point each user’s File Locations and Default templates to that location.
Access problems due to multiple users accessing the same files do not arise in this situation,
because users copy templates to create new documents and do not use them directly.

CAUTION One of the downfalls of this arrangement is that if the network goes down, users no
longer have access to their templates. This can be averted by also putting copies of the templates on
the local computers; however, this has the tendency to undermine the goal of consistent documen-
tation. Users may tend to use and customize the local templates rather than use the standardized
network copies.
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Understanding Feature-Based Modeling

Before diving into building models with SolidWorks, you need to be familiar with some termi-
nology. Notice that I talk about modeling rather than drawing or even design. Whether you are
building an assembly line for automotive parts or designing decorative perfume bottles,
SolidWorks can help you visualize your geometrical production data in the most realistic way
possible without actually having it in your hand. This is more akin to making a physical model
in the shop than drawing on paper.

Feature-based modeling means that you build the model by creating 2D sketches and applying
processes (features) to create the 3D shape. For example, you can create a simple box by using the
Extrude process, and you can create a sphere using the Revolve process. However, you can make
a cylinder using either process, by revolving a rectangle or extruding a circle. Figure 1.10 shows
images of simple feature types along with the 2D sketches from which they were created.

FIGURE 1.10
Simple extruded and
revolved features

Many different feature types in SolidWorks enable you to create everything from the simplest
geometry shown in Figure 1.10 to more complex shapes. In general, when I talk about modeling
in this book, I am talking about solid modeling, although SolidWorks also has a complete
complement of surfacing tools. I discuss the distinction between solid and surface modeling in
Chapter 32, “Working with Surfaces.”

Table 1.2 lists some of the most common features in SolidWorks and classifies them according
to whether they always require a sketch, a sketch is optional, or they never require a sketch. As
an example of a sketch optional feature, a sweep can use a model edge as a sweep path.
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TABLE 1.2: Feature Types
SKETCH OPTIONAL (USES NO SKETCH
SKETCH REQUIRED FACES OR EDGES) (APPLIED FEATURES)
Extrude Loft Fillet
Revolve Sweep Chamfer
Rib Dome Draft
Hole Wizard Boundary Shell
Wrap Deform Flex

In addition to these features, other types of features create reference geometry, such as curves,
planes, axes, and surface features (Chapter 32); specialty features for techniques like sheet metal
(Chapter 34, “Using SolidWorks Sheet Metal Tools”); and plastics/mold tools (Chapter 38,
“Using Plastic Features,” and Chapter 39, “Using Mold Tools”).

Understanding History-Based Modeling

In addition to being feature-based, SolidWorks is also history-based. The process history is shown
in a panel to the left side of the SolidWorks window called the FeatureManager. The
FeatureManager keeps a list of the features in the order in which you have added them. It also
enables you to reorder items in the tree (in effect, to change history). Because of this, the order in

which

you perform operations is important. For example, consider Figure 1.11. This model was

created by the following process, left to right starting with the top row:

1.

N & un ks wN

8.

Create a sketch.

Extrude the sketch.

Create a second sketch.
Extrude the second sketch.
Create a third sketch.
Extrude Cut the third sketch.
Apply fillets.

Shell the model.

If the operations used in the previous part were slightly reordered (by putting the shell and
fillet features before Step 6), the resulting part would look slightly different, as shown in
Figure 1.12. You can find this part in the download materials for this chapter.
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Figure 1.13 shows a comparison of the FeatureManager design trees for the two different
feature orders. You can reorder features by dragging them up or down the tree. However,
relationships between features can prevent them from being reordered; for example, the fillets
are dependent on the second extruded feature and cannot be reordered before it. This is referred
to as a parent/child relationship.

Reordering and parent/child relationships are discussed in more detail in Chapter 12,
“Editing, Evaluating, and Troubleshooting.”

FIGURE 1.13
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The order of operations, or history, is important to the final state of the part. For example, if
you change the order so that the shell comes before the extruded cut, the geometry of the model
changes, removing the sleeve inside instead of the hole on top. You can try this for yourself by
opening the part indicated previously, dragging the Shelll feature in the FeatureManager and
dropping it just above the Cut-Extrudel feature.

NOTE You can drag only one item at a time in the FeatureManager. If you try to drag more than one,
only the last selected item is dragged. Therefore, you may drag the shell and then drag each of two
fillets, or you could just drag the cut feature down the tree. Alternatively, you can put the shell and
fillets in a folder and drag the folder to a new location. Reordering is limited by parent/child relation-
ships between dependent features.

You can read more about reordering folders in Chapter 12.

In some cases, reordering the features in the FeatureManager can have a result that does not
make any sense; for example, if the fillets are applied after the shell, they might break through to
the inside of the part. In these cases, SolidWorks gives an error that will help you fix the problem.

Features are really just like steps in building a part; the steps can add material, remove it, or
both. However, when you make a part on a mill or lathe, you are only removing material. Some
people choose to model following manufacturing methods, so they start from a piece of stock
and apply features that remove material, as you would on a mill. This approach works best for
machining, but doesn’t work well for molding, casting, sheet metal, or progressive dies. The
FeatureManager is like an instruction sheet to build the part. When you reorder and revise the
list of features, you change the order of operations and thus the final result. Some people look at
the FeatureManager as a recipe for cooking.
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Sketching with Parametrics

Sketching is the foundation that underlies the most common feature types. You will find that
sketching in parametric software is vastly different from drawing lines in 2D CAD.

Dictionary.com defines the word parameter as “one of a set of measurable factors . . . that
define a system and determine its behavior and [that] are varied in an experiment.” SolidWorks
sketches are parametric. What this means is that you can create sketches that change according to
certain rules and maintain relationships through those changes. Creating sketches and features
with intelligence is the basis of the concept of design intent, which I cover in more detail later in
this chapter.

In addition to 2D sketching, SolidWorks also makes 3D sketching possible. Of the two
methods, 2D sketches are by far more widely used. You create 2D sketches on a selected plane or
planar face and then use them to establish shapes for features such as Extrude, Revolve, and
others. Relations in 2D sketches often are created between sketch entities and other model edges
that may or may not be in the sketch plane. In situations where other entities are not in the sketch
plane, the out-of-plane entity is projected into the sketch plane in a direction that is normal to the
sketch plane. This does not happen for 3D sketches.

You can use 3D sketches for the Hole Wizard, routing, weldments, and complex shape
creation, among other applications.

For more information on 3D sketching, refer to Chapter 6, “Getting More from Your Sketches.”

For a simple example of working with sketch relations in a 2D sketch, consider the sketch
shown in Figure 1.14. The only relationships among the four lines are that they form a closed
loop that is touching end-to-end and one of the corners is coincident to the part origin. The small
square icon near the origin shows the symbol for a coincident sketch relation. These sketch
relations are persistent through changes and enable you to dynamically move sketch elements
with the cursor on the screen. The setting to enable or disable displaying the sketch relation
symbols is found at View > Sketch Relations.

FIGURE 1.14 a. b. c.
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If you drag any of the unconstrained corners (except for the corner that is coincident to the
origin), the two neighboring lines follow the dragged endpoint, as shown in Figure 1.14. Notice
the ghosted image left by the original position of the sketch. This is helpful when you're experi-
menting with changes to the sketch because you can see both the new and the old states of the
sketch. The setting to enable or disable this ghosted position is found at Tools > Options > Sketch
> Ghost Image On Drag.
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If you add a parallel relation between opposing lines, they now act differently, as shown in
Figure 1.14. You add a parallel relation by selecting the two lines (Ctrl + Select) to make parallel
and selecting Parallel from the context toolbar or the PropertyManager panel.

You can read more about the PropertyManager in Chapter 2.

Next, add a second parallel and a horizontal relation, as shown in Figure 1.14. If you are
following along by re-creating the sketch on your computer, you will notice that one line has
turned from blue to black.

The line colors represent sketch states. It may be impossible to see this in the black-and-white
printing of this book, but if you are following along on your own computer, you should see one
black line and three blue lines. Sketch states include Underdefined, Overdefined, Fully Defined,
Unsolvable, Zero Length, and Dangling, and they are described as follows:

Blue: Underdefined The sketch entity is not completely defined. You can drag a portion of it
to change size, position, or orientation.

Black: Fully Defined The sketch entity is fully defined by a combination of sketch relations
and dimensions. A sketch cannot be fully defined without being connected in some way to
something external to the sketch, such as the part origin or an edge. (The exception to this rule
is the use of the Fix constraint, which, although effective, is not a recommended practice.)

Red: Overdefined—Not Solved When a sketch entity has two or more relations and one of
them cannot be satisfied, the unsatisfied relation will be red. For example, if a line has both
Horizontal and Vertical relations, and the line is actually vertical, the Vertical relation will be
yellow (because it is conflicting but satisfied), and the Horizontal will be red (because it is
conflicting and not satisfied).

Yellow: Overdefined—Conflicts Solving the sketch relations would result in a zero-length
entity. For example, this can occur where an arc is tangent to a line, and the centerpoint of the
arc is also coincident to the line.

Brown: Dangling The relation has lost track of the entity to which it was connected.

Entities with different states can exist within a single sketch. In addition, endpoints of lines
can have a different state than the rest of the sketched entity. For example, a line that is sketched
horizontally from the origin has a coincident at one endpoint to the origin, and the line itself is
horizontal. As a result, the line and first endpoint are black, but the other endpoint is underde-
fined because the length of the line is not defined. Sketch states are indicated in the lower-right
corner of the graphics window and in the status bar. You can see that dragging one corner allows
only the lines to move in certain ways, as shown in Figure 1.14.

In addition to sketch relations, dimensions applied using the Smart Dimension tool are also
part of the parametric scheme. If you apply an angle dimension (by clicking the two angled lines
with the Smart Dimension tool) about the origin and try dragging again, as shown in Figure 1.14,
you see that the only aspect that is not locked down is the length of the sides. Notice also that
when the angle dimension is added, another line turns black.

Finally, adding length dimensions for the unequal sides completes the definition of the sketch,
as shown in Figure 1.14. At this point, all lines have turned black. This state is called “fully
defined.” Between the dimensions and sketch relations, there is enough information to re-create
this sketch exactly.
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BEST PRACTICE

It is widely considered best practice to fully define all sketches to control how the sketch reacts to
potential changes.

Parametric relations within a sketch control how the sketch reacts to changes from dimensions
or relations within the sketch or by some other factor from outside the sketch. Other factors can
drive the sketch as well, such as equations, other model geometry that is external to the sketch,
and even geometry from another part in an assembly, as you'll see later.

Understanding Design Intent

Design intent is a phrase that you will hear often among SolidWorks users. I like to think of it as
“design for change.” Design intent means that when you put the parametric sketch relations and
dimensions together with the feature intelligence, you can build models that react to change in
predictable ways. This gives you a great deal of control over changes.

An example of design intent could be a statement that describes general aspects that help
define the design of a part, such as “This part is symmetrical, with holes that line up with Part A
and thick enough to be flush with Part B.” From this description, and the surrounding parts, it is
possible to re-create the part in such a way that if Part A or Part B changes, the part being
described updates to match.

Some types of changes can cause features to fail or sketch relations to conflict. In most
situations, SolidWorks has ample tools for troubleshooting and editing that you can use to repair
or change the model. In these situations, it is often the design intent itself that is changing.

BEST PRACTICE

It is considered best practice to edit existing entities rather than delete. Deleting often causes prob-
lems with items that have relations to the entities deleted. Many users find it tempting to delete
anything that has an error on it, but you should avoid this practice.

Editing Design Intent

One of the most prominent aspects of design in general is change. I have often heard it said that
you may design something once, but you will change it a dozen times. You will find this to be
true with both sketching and 3D modeling. Design intent is sometimes thought of as a static
concept that controls changing geometry. However, design intent itself often changes, thus
requiring the way in which the model reacts to geometric changes to also change. Fortunately,
SolidWorks has many tools to help you deal with changing requirements.
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FIGURE 1.15
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Choosing Sketch Relations

The sketch relation symbols are the most helpful tools for visualizing design intent. You can
show or hide icons that represent the relations by choosing View Sketch Relations from the
Heads-Up View toolbar (or through the menus at View > Hide/Show > Sketch Relations). When
shown, these relations appear as an icon in a small colored box in the graphics area next to the
sketch entity. Clicking the icon highlights the sketch elements involved in that relation. Refer to
Figure 1.15 for examples of these relations.
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TIP The View Sketch Relations option is an excellent candidate for use with a hotkey, thereby ena-
bling you to easily toggle it on and off. For more information on creating and managing hotkeys, see
Chapter 2.

You can use the sketch relation icons on the screen to delete relations by selecting the icon in
the graphics area and pressing Delete on the keyboard. You also can use them to quickly deter-
mine the status of sketch relations by referring to the colors defined earlier.

Selecting Display/Delete Relations

The Display/Delete Relations tool enables you to list, sort, delete, and repair sketch relations.
You can find the Display/Delete Relations tool on the Sketch toolbar. The sketch status colors
defined earlier also apply here, with the relations appearing in the appropriate color. (Relations
are not shown in blue or black, only the colors that show errors, such as red, yellow, and brown.)
This tool also enables you to group relations by several categories:

&  All In This Sketch
¢ Dangling
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In the lower Entities panel of the Display/Delete Relations PropertyManager, shown in
Figure 1.16, you can replace one entity with another or repair dangling relations.

FIGURE 1.16
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You can read more about repairing dangling entities in Chapter 6.

Using Suppressed Sketch Relations

Suppressing a sketch relation means that the relation is turned off and not used to compute the

position of sketch entities. Suppressed relations generally are used in conjunction with configura-

tions. You can also suppress relations temporarily to resolve problems.
Configurations are discussed in detail in Chapter 11, “Working with Part Configurations.”
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Working with Associativity

In SolidWorks, associativity refers to links between documents, such as a part that has an associa-
tive link to a drawing. If the part changes, the drawing updates as well. Bidirectional associativity
means that the part can be changed from the part or the drawing document window. One of the
implications of this is that you do not edit a SolidWorks drawing by simply moving lines on

the drawing; you must change the 3D model, which causes all drawing views of the part or
assembly to update correctly.

Other associative links include using inserted parts (also called base or derived parts), where
one part is inserted as the first feature in another part. This might be the case when you build a
casting. If the part is designed in its “as cast” state, it is then inserted into another part where
machining operations are performed by cut features and the part is transformed into its “as
machined” state. This technique is also used for plastic parts where a single shape spans multiple
plastic pieces. A “master part” is created and split into multiple parts. An example would be a
mouse cover and buttons.

One of the most important aspects of associativity is file management. Associated files stay
connected by filenames. If a document name is changed and one of the associated files is not
updated appropriately, the association between the files can become broken. For this reason, you
should use either SolidWorks or SolidWorks Explorer to change the names of associated files.

BEST PRACTICE

It is considered best practice to use SolidWorks or SolidWorks Explorer to rename associated parts.
Avoid using Windows Explorer.

The Bottom Line

Easy access to your tools cuts just seconds out of your work time every day, but a good
habit will cut minutes, and several good habits can cut hours.

Master It After SolidWorks has been installed as shown in this chapter, find the desktop
icon, and put it on your taskbar or other easy-to-access interface element.

File organization is one of the keys to a successful SolidWorks implementation. While I
don’t expect you to have everything figured out at this stage in your learning, you need to
start thinking about how to manage your SolidWorks libraries of templates and key
features as well as your project data.

Master It Make sure you know where the settings in Tools > Options are located for
identifying the locations for templates, and change this location if necessary.

One of the key concepts of managing SolidWorks is associativity. Data created in one file
can be shown in another file. For example, part data is shown in both assemblies
and drawings.

Master It Open a SolidWorks drawing (*.slddrw) and drag a SolidWorks part
(*.sldprt) onto it. Make a change to the part and watch it update on the drawing.



Navigating the
SolidWorks Interface

The SolidWorks interface offers a wide range of tools. You'll find more than one way to do almost
everything. There is no single best way to use the interface; this book generally shows the most
standardized and quickest methods.

In this chapter, I start by displaying the entire default interface, but in the rest of the book,
I will show only a reduced interface, mainly to save space and keep the focus on the graph-
ics window.

After you have mastered the various interface elements and customized your SolidWorks
installation, working with the software will become much more efficient and satisfying.

IN THIS CHAPTER, YOU WILL LEARN TO:

¢ Recognize elements of the SolidWorks interface
¢ Find what you need in the interface

¢ Customize the interface to work for you

Identifying Elements of the SolidWorks Interface

The major elements of the SolidWorks interface are the graphics window, where all the
geometry is shown; the FeatureManager, which is the list of all the features in the part; the
PropertyManager, where most of the data input happens; and the CommandManager and
toolbars, where you access most of the commands in the software.

Each interface element identified in Figure 2.1 is explained in detail in this chapter.

You might want to bookmark the next page and refer to Figure 2.1 often, because much of the
interface discussion refers to elements illustrated in this figure. You'll never see all the interface
elements shown in Figure 2.1 on the screen at the same time; this image has been composited for
illustration purposes. It shows the default interface with a couple of exceptions. First, I pinned
the title bar menu in place. Second, I detached the PropertyManager.

Using the CommandManager and Toolbars

In some respects, the CommandManager resembles the Microsoft (MS) Ribbon interface, but it is
not a strict implementation, because SolidWorks wanted to add more customizability. In this
section, I show you how to make the CommandManager work for you and how to use regular or
flyout toolbars to replace it effectively.

Mastering SolidWorks, First Edition. Matt Lombard.
© 2019 John Wiley & Sons, Inc. Published 2019 by John Wiley & Sons, Inc.
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EXPLORING THE COMMANDMANAGER

The CommandManager is an area of the interface that you can use to flip between sets of related
commands. The main purpose of the CommandManager is to give you easy access to commands
without cluttering the entire screen with toolbars.

The CommandManager accomplishes this by providing small tabs under the left end of
the toolbar area to enable you to switch the collection of tools that appears. Figure 2.2 shows the
CommandManager in Customize mode, showing all the tabs available in a default setup. To get
the CommandManager into Customize mode, right-click one of the CommandManager tabs and
select Customize CommandManager.

NOTE To access the pull-down menus in a default setup, place the cursor over the SolidWorks logo
or the small flyout triangle to the right of it in the upper-left corner of the SolidWorks window.
Figure 2.2 shows the flyout for pull-down menus pinned in place. To keep the menu in that position,
click the pushpin on the right end of the flyout menu bar.
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Customizing the CommandManager

The best way to get the most efficiency from the SolidWorks interface is to customize it. Notice
the last tab along the bottom of the CommandManager on the right. If you want to add another
tab, you can right-click this tab and select the tab you want to add. You also can select to add a
blank tab and then rename it and populate it with individual buttons. Figure 2.3 shows a detail
of the Add Tab menu options that opens after you right-click the right-most tab.
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To add individual buttons to the CommandManager, follow these steps:
1. Choose Tools » Customize from the menu bar.
2. When the Customize dialog box opens, find the button you want to add.

3. Click the Commands tab in the Customize dialog box, and then switch the
CommandManager to the tab to which you want to add the button.

4. Drag the button from the Customize dialog box to the CommandManager.

You can remove buttons from the CommandManager by dragging them into the blank graphics
window area.

Docking the CommandManager

In SolidWorks, you can undock the CommandManager and leave it undocked, pull it to a second
monitor, or dock it vertically to the left or right. To undock it, click and drag on any tab of the
CommandManager. To redock an undocked CommandManager double-click the title area. To
change its docking location, drag it onto one of the docking stations around the screen. Figure 2.4
shows the CommandManager undocked. You can also double-click on the command manager
title in order to dock it back in the last parking position.

FIGURE 2.4
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Using Auto Collapse

The small box with the arrows in it in the upper-right corner of the undocked CommandManager
and the undocked PropertyManager is the Auto Collapse option. When the option is active, the
PropertyManager expands and collapses automatically when your mouse goes over it. This can
be very handy because it saves lots of space on the screen, but at the same time, it requires
additional mouse movement to open it up. This is the common trade-off in this interface: You can
trade screen space for additional mouse movement or clicks.

Mixing the CommandManager with Toolbars

To put a toolbar inline with the CommandManager, drag the toolbar close to the right end of the
CommandManager. A space on that row or column opens up. The amount of space that opens up
depends on the CommandManager tab with the longest set of icons, even if that tab is

not showing.

Basing Tabs on Document Types

SolidWorks remembers which tabs to show on a per-document-type basis. This means that when
you are working on a part document, you have one set of tabs. When you switch to an assembly
document, you see a different set of tabs. The same goes for drawings. Notice that in Figure 2.3,
in the right mouse button (RMB) menu, the Copy Tab To Assemblies option and the Copy Tab

To Drawings option appear. These options make it easier to set up customizations that apply for
all document types.

Changing the Appearance of the CommandManager

You can turn off the text in one of two ways. The easiest way to do this is to right-click in the
CommandManager and deselect the Use Large Buttons With Text option, as shown in Figure 2.5.
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I will use the interface with the hidden text for the rest of the book, primarily to save space on
the printed page. Remember that if you need help with the name of an icon, you can hover the
cursor over the icon to see a tool tip that tells you what it is.

You can scroll through the tabs of the CommandManager by pressing Ctrl+PageUp or
Ctrl+PageDown. These key combinations can be controlled at Tools > Customize > Keyboard.

The most streamlined and space-efficient way to set up the CommandManager is to remove
the text. Notice that the CommandManager without text takes up the same amount of height as a
normal toolbar, with the added room for the tabs at the bottom. The text can be useful for new
users or features that you do not commonly use.
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The final setting for the CommandManager’s appearance is the size of the icons. You have
control over the size of the icon images in the CommandManager. You can find this setting in the
Options flyout on the Title Bar toolbar shown in Figure 2.6. The difference between large and
small icons is shown in the lower part of the figure.
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k Eﬁ Medium

% Large

This setting applies to all the toolbar icons except the menu bar, RMB menu, and context bar
icons. The setting may not take full effect until you restart SolidWorks. Large icons can be useful
on displays with very high resolution; in particular, on laptops where the screen itself may be
small but the resolution is very high. All the screenshots in this book are taken with the Large
Icons option turned on for improved visibility.

Recognizing the Limitations of the CommandManager

If you undock the CommandManager, you cannot reorient the tabs horizontally. They remain
vertical. In addition, you cannot place multiple rows of toolbars on the same row as a
CommandManager using large buttons with text. You cannot dock the CommandManager to
the bottom of the SolidWorks window. Another minor limitation is that although SolidWorks
allows you to place toolbars at the right end of the CommandManager and above the
CommandManager when the CommandManager is docked at the top, it does not allow you to
place them to the left of the CommandManager or below it.

USING TOOLBARS

Interface setup is frequently about compromise or balancing conflicting concerns. In the case of
the CommandManager, the compromise is between screen space, mouse travel, and clicks. You
may find yourself clicking frequently back and forth between the Sketch and Features tabs. For
this reason, you may find it valuable to put the Sketch toolbar vertically on the right side of the
graphics window and remove it from the CommandManager. This enables you to see the Sketch
and Features toolbars at the same time and greatly reduces clicking back and forth between the
CommandManager tabs.

The SolidWorks interface performs best with some customization. No two people set it up
exactly the same, but everyone needs some adjustment because he or she might be working on
specialized functionality (such as molds or surfacing) or might work with limited functionality
(such as predominantly revolved features). Of course, customization can accommodate personal
preferences—for example, if one user prefers to use hotkeys and another uses menus, gestures, or
the S key.
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To enable or disable a toolbar, you can right-click in a toolbar area and choose the toolbar you
are interested in enabling from a list of all the toolbars in SolidWorks. Another way to do this is
to use the Customize dialog box by choosing Tools > Customize, or the Customize option near
the bottom of the RMB toolbar list. Yet another way is to choose View > Toolbars.

Exploring the Heads-Up View Toolbar

The Heads-Up View toolbar appears along the middle of the top edge of the graphics window.
Figure 2.7 shows the default arrangement of the Heads-Up View toolbar, and it is shown in
relation to the rest of the interface in Figure 2.1.

FIGURE 2.7
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You can customize the Heads-Up View toolbar by using the Toolbars dialog box (Tools >
Customize » Toolbars). Customization includes turning the Heads-Up View toolbar on or off and
adding or removing buttons. If you have multiple document windows or multiple view ports
showing, the Heads-Up View toolbar shows only in the active window or view port. This toolbar
often overlaps with other interface elements when the active window is small.

Exploring the Title Bar Toolbar and Menu

The Title Bar toolbar is found just to the right of the SolidWorks logo on the title bar in the top-left
corner of the SolidWorks window. By default, it contains most of the elements of the standard
toolbar, and it is available even when no documents are open. It uses mostly flyout toolbar icons,
so again it follows the trend of saving space at the expense of an extra click. This toolbar can be
customized in the same way as other toolbars in the Customize dialog box in the Commands tab.
This toolbar cannot be turned off, but you can remove all the icons from it.

NOTE You can run the SolidWorks interface from just the CommandManager without any additional
toolbars. You can do the same with just the Title Bar toolbar, customizing it with all flyout toolbars.
The main advantages of the Title Bar toolbar are that it is visible when no documents are open and
that it utilizes otherwise wasted space in the title bar. You might set up the interface for a 12-inch
normal-aspect-display laptop very differently from that of a desktop unit with a 24-inch-wide screen.

There is also a Title Bar menu, which is hidden by default. The SolidWorks logo in the upper
left of the SolidWorks window or the small triangle next to the logo serve as a flyout to expand
the main SolidWorks menus. You can pin the menus in place using the pushpin.
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Notice that on low-resolution or non-maximized SolidWorks windows, you can run into some
space problems if the Menu Bar menu is pinned open. You need to examine customizations to the
SolidWorks interface with display size in mind. You might consider having different sets of
settings for using a laptop at a docking station with a large monitor, using the laptop with a small
monitor, and using the computer with a low-resolution digital projector.

A setting exists to help you control the display for these situations. Figure 2.8 shows the
View » Workspace menu. This gives you the options of Default, Widescreen, and Dual Monitor.
With dual monitors, you can put some elements of the interface on the second monitor to save
graphics space. You will also see a Touch Mode option in the View menu, which will help you set
up the display for touch screens and tablets.

FIGURE 2.8
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Looking at the Flyout Toolbar Buttons

SolidWorks saves space by putting several related icons on flyout toolbars. For example, the
Rectangle tool has a button for each of the several different ways to make a rectangle, and they
are all on the rectangle flyout. To see all available flyouts, choose Tools > Customize >
Commands > Flyouts.

Flyouts primarily save toolbar space when several tools are closely related. SolidWorks has set
up flyouts in two configurations: flyouts that always maintain the same image for the front
button image (such as the Smart Dimension flyout) and flyouts that use the last-used button
image (such as the Rectangle flyout).

Exploring the Context Toolbars

Context toolbars are toolbars that appear in the graphics window and in the FeatureManager
when you right-click or left-click something. When you right-click, a context toolbar appears at
the top of the RMB menu and shows the functions that SolidWorks deems the most commonly
used functions. The advantage of this block of tools is that because they are more commonly used,
you should be familiar with the icons, so they don’t need supporting text titles, as do the less
commonly used tools on the RMB menu. Figure 2.9 shows the RMB menu with context bar.
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When you left-click an item, the context toolbar appears by itself; the rest of the RMB menu
does not appear. If you do not recognize an icon on the context toolbar, you can refer to its tool
tip. Context toolbars are editable in two ways. First, you can turn them off and restore the RMB
menu to its complete configuration. To turn off the context toolbars, click the context toolbar and
choose Tools > Customize. Use the options on the right side of the main Toolbars tab. (refer to
upper right corner of Figure 2.10) Second, you can add or remove icons on specific context
toolbars by right-clicking the toolbar itself and selecting Customize.

The purpose of the context toolbars is to save space by condensing some commands into a
toolbar without text instead of a menu with icons and text. The left-click and right-click context
toolbars are the same, but they work differently. The left-click context toolbar fades as you move
the cursor away from it and becomes darker as you move the cursor toward it. After it fades
completely, you cannot get it back without reselecting the item.

Exploring the Shortcut (S) Toolbar

The Shortcut toolbar is also known as the S toolbar because, by default, you access it by pressing
the S key. You can customize this toolbar so it has different content for sketches, parts, assem-
blies, and drawings. To customize the S toolbar, right-click it when it is active and click
Customize from the RMB menu.

Users claim to have customized the S toolbar to such an extent that they have been able to
remove the CommandManager and all other toolbars from their interface or if the Shortcut
Toolbar is used in conjunction with well-customized Context Toolbars. This is possibly true if
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you use a limited number of sketch entities, sketch relations, and feature types, or if you make
extensive use of flyouts on the S toolbar. However, if you work with a wide range of tools (say,
surfacing, sheet metal, and plastic parts), you may need some additional toolbar space. It is
completely believable to have access to most of the software’s functions with the S toolbar and
either the Menu Bar toolbar or the CommandManager. CommandManager by far gives you the
most flexibility, but it also requires the most space.

The S key shortcut may conflict with another keyboard customization. To change the S toolbar
key to another character or to reassign it, follow the directions for creating and maintaining
hotkeys later in this chapter in the section on customization. It is referenced as the shortcut bar in
the Keyboard list (Tools > Customize > Keyboard).

UsiING TooL Tiprs

Tool tips come in two varieties: large and small. Large tool tips show the names of the tools and
available shortcut keys, along with brief descriptions of what they do. Small tool tips show only
the tools” names and shortcut keys. To change the tool tip display from large to small, or to deselect
the tool tip display altogether, choose Tools > Customize. The options for sizing tool tips and
showing tool tips appear in the upper-right corner. In addition to the tool tip balloons, tips also
appear in the status bar at the bottom of the screen when the cursor is over an icon. Figure 2.10
provides the options for tooltips and shows a comparison between large, medium, and icons.

FIGURE 2.10
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NOTE The Customize option (Tools > Customize) is inactive unless a SolidWorks document is open.
To access the Customize dialog box, first open a SolidWorks part, assembly, or drawing, and then
choose Tools > Customize from the menu. Customize is different from the Customize Menu option
found in all SolidWorks menus. The Customize Menu option is discussed later in this chapter.

In addition to the tool tips, this area of the Customize dialog also controls icon size and the
setting to show or hide context toolbars.
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MANAGING TOOLBARS

After all that, if you still feel you need to work with standard toolbars, it is easy to move, select
and deselect, and add icons to toolbars. It is important to remember that different document
types retain different toolbar settings; for example, the toolbars that you see with a part open are
different from the toolbars that you see for drawings. For this reason, when you change from a
part document to a drawing document, you may see your display adjust because the changing
toolbars increase or decrease the amount of space that is required.

BEST PRACTICE

A best practice is to set up the toolbars for each document type so they take up similar amounts of
space—for example, two rows on top and one column to the right. This way, when changing between
document types, the graphics area does not need to resize.

Moving Toolbars

To move a toolbar, you can click with the cursor at the dotted bar on the left-most or top edge of
the toolbar. Figure 2.11 shows the dotted bar on the top edge of a toolbar. When the cursor
changes to a four-way arrow, you can drag the toolbar where you want it. Toolbars dock either
vertically or horizontally. You can resize undocked toolbars so they have rows and columns. This
arrangement is typically used with the Selection Filter toolbar, which is often left undocked and
compressed into a block that is three or four columns wide.

FIGURE2.11 [
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Using Flyout Toolbars

You can use any toolbar as a flyout toolbar. Figure 2.12 shows the list of all flyout toolbars; it
is the same as the list of all toolbars. To use a toolbar as a flyout, select it from the flyout
toolbars list and drag it onto an existing toolbar. It displays with an arrow to the right.
Clicking the arrow causes all the tools to scroll out temporarily until you click a toolbar icon
or anything else.
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FIGURE 2.12
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To add icons to a flyout toolbar, temporarily show the regular toolbar that corresponds to the
flyout toolbar and add icons to the regular toolbar. When you are finished adding or removing
icons, turn off the regular toolbar; the changes will be applied to the flyout. Some flyout toolbars
are not available, such as the Rectangle flyout, but you can use this technique on toolbars that are
used as flyouts, such as the Reference Geometry toolbar.

TIP If youwant to create a separate toolbar, you can commandeer an existing one for your own
purposes. For example, because I do not use the Tools toolbar, I have removed all the regular icons
from it and replaced them with relevant flyout toolbars, which I do use extensively. This enables
me to consolidate space and not have unused icons on my toolbars. Alternatively, creating a custom
CommandManager tab and putting on it what you like is much easier.

Working in Various Screen Configurations

Full Screen mode enables you to toggle quickly to the display so that only the graphics window
and the Task pane appear. The FeatureManager, menus, toolbars, and status bar are all hidden.
Alternatively, you can hide just the FeatureManager or the toolbars.

In Full Screen mode, you can still access the menus by clicking with the cursor along the top
border of the window:

¢ F8toggles the DisplayPane.
¢ F9 toggles the FeatureManager.

*

F10 toggles the toolbars.
¢ Fl1 toggles Full Screen mode.

Under View > Workspace, you find other screen setups, including Widescreen and
Dual Monitors. Widescreen puts the CommandManager to the left of the FeatureManager,
and Dual Monitors puts the CommandManager and PropertyManager on the second screen.
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Controlling Menus
Everyone has his or her own style of working. For example, some people like to use menus, and
others do not. Some like to use hotkeys, and others like the mouse.

Most users avoid menus because they seem like an old way of working. However, some
commands, such as Modify Section View, are available only through the drop-down menus.
Also, SolidWorks users who use a wide range of features wind up using the menus more often
than users who use a more limited set of tools.

The most frequently used menu items are in the View, Insert, and Tools menus. All the menus
shown in this section have all the possible options shown. Customizing menus is rarely done,
although it is possible. To customize a menu, activate the menu and select Customize Menu from
the bottom of the menu, as shown in Figure 2.13.
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You use the View menu primarily for turning visibility on or off for entity types such as
planes, sketches, or temporary axes. You can also do this by using hotkeys or via the Heads-Up
View toolbar.

The Insert menu is used mostly for creating feature types for which you do not have a toolbar
icon on the screen. For example, although the Move Face tool is on the Mold Tools toolbar, you
can also find the Move Face tool on the Direct Editing toolbar. Move Face has many uses aside
from mold design. You can find the Move Face tool by choosing Insert > Face.

You can customize menus by adding or omitting items. By using the Customize Menu option
at the bottom of any menu—including shortcut (RMB) menus—you can remove items from any
menu by clearing the check boxes next to tools you do not use. To bring back the removed items,
you can go back to Customize Menu or choose Tools > Customize > Options and click the Reset
to Defaults buttons for menu and shortcut customization.

While omitting items may not sound like much of a benefit, some of these menus are so
long that they may not fit on your monitor—even a large monitor—and they may include tools
that you never use. So, sometimes trimming down a menu to make it fit the interface better is a
good choice for your particular situation. You may also find administrative reasons to remove
certain commands from the available list (to prevent users from adding certain features to
the tree).

NOTE Be careful not to confuse this Customize Menu selection with the Customize Menu selection
on the Tools menu. Figure 2.13 shows the Tools menu being customized. In addition, I do not recom-
mend removing items from the menus. At some point, someone may need one of those items and no
one will remember where it was or how to get it back.
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FIGURE 2.14
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INTERPRETING THE USE OF THE WORD “SHORTCUT” IN SOLIDWORKS

Between the SolidWorks and Microsoft interfaces, the word shortcut is used in several overlapping
and confusing ways. The following list describes where SolidWorks and Microsoft users might encoun-
ter the word shortcut as a formal name for interface functionality and how they might understand it.

& A Windows shortcut is a link to another file or folder. Most users still refer to this link as a
shortcut or desktop shortcut.

¢ Shortcuts (as identified in the SolidWorks Help under Shortcut > Keys) are either accelerator
keys or keyboard shortcuts. Users refer to accelerator keys as Alt keys and to keyboard shortcuts
as hotkeys.

¢ SolidWorks shortcut menus are commonly called the right mouse button (RMB) menus. They
have detached toolbars called context bars for both right-click and left-click options. These are
commonly known as the RMB bar and the LMB bar.

¢ Shortcut tabs (found as the “shortcut” entry in the SolidWorks Help) presumably refer to
DriveWorksXpress functionality, although there is no direct mention of that in the Help entry.

¢ Shortcut bars are commonly known as the S key toolbar.

If you use the alternative terminology offered here, it will be clear to all users what you are
talking about.

Changing Cursors

SolidWorks cursors are context-sensitive and change their appearance and function depending
on the situation. Sketching cursors display a pencil and the type of sketch entity that you are
presently sketching. Sketch cursors also display some dimensional information about the entity
that you are sketching, such as its length or radius. Sketch cursor feedback is necessary for fast
and accurate sketching.

To learn more about sketch cursor feedback, see Chapter 3, “Working with Sketches and
Reference Geometry.”

The select cursor changes depending on the item over which it is positioned. Cursor symbols
also help remind you when selection filters are active. Figure 2.14 shows various cursors and
their significance.

N

Working with Models in the FeatureManager
and PropertyManager Windows

The FeatureManager and PropertyManager are windows in the interface where you will spend
much of your time. You can manipulate the content inside the windows in various ways.
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USING THE FEATUREMANAGER

The FeatureManager window is the panel to the left of the screen; it shows the features
describing how the part was built. SolidWorks users spend a fair amount of time using the
FeatureManager to edit or inspect models. You can use the tree (as it is known informally) to see
items in the order in which they were created or to search for specific items. You can put parts or
features in folders for organization. Using the Display pane, you can turn visibility on or off for
bodies, parts, reference geometry, and other items. You can use it to display names, descriptions,
and other metadata.

Figure 2.15 names the various parts of the FeatureManager interface.
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Figure 2.16 again shows the FeatureManager for a simple model, this time using the options
for Dynamic Reference Visualization (DRV). Parent features are typically above the selected
feature, and are indicated by the blue DRV arrows. Child features are typically below the selected
feature and are indicated by purple DRV arrows. (Child features can sometimes be found below
the selected feature due to SolidWorks method of putting sketches below the feature. Using the
shortcut Ctrl+T will switch the FeatureManager to a more literal representation of the feature
order where all child features come after the parents.) You will learn more about this in
Chapter 12, “Editing, Evaluating, and Troubleshooting.”
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The DRV enables you to instantly understand the parent/child relations between the various
features in the part. The setting to enable or disable DRV is at View > User Interface, as shown in
the image to the right in Figure 2.16.

A splitter bar at the top of the FeatureManager (see Figure 2.15) enables you to split the
FeatureManager window into two windows. This enables you to display the FeatureManager
and another window, such as the PropertyManager (refer to Figure 2.17). The tab on the right of
the FeatureManager (or the F9 key) can collapse the FeatureManager to save space.

Looking at the Display Pane

You can open the Display pane flyout from the FeatureManager by using the arrow at the
top-right corner of the FeatureManager. The Display pane helps you to visualize where appear-
ances (colors), display styles, or hidden bodies have been applied in a part document and
additional functions in an assembly document. The Display pane is helpful when you're looking
for colors that are applied to the model at some level other than the part level.

Appearances are covered in more detail in Chapter 5, “Using Visualization Techniques.”

Looking at the Rollback and Freeze Bars

The Rollback bar at the bottom of the FeatureManager enables you to see the part in various
states of history. Features can be added while the rollback bar is at any location. The model also
can be saved while rolled back.
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A bar at the top of the FeatureManager is called the Freeze bar (refer to Figure 2.15), and it
locks the features that are above it from being rebuilt or edited. To enable it, go to Tools >
Options > General. You can position it just like the Rollback bar.

FIGURE 2.17
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Looking at the FeatureManager Filter

One of the most useful elements of the FeatureManager is the FeatureManager filter. The filter
resides at the top of the FeatureManager. If you type text in the filter, SolidWorks searches
feature names, descriptions, comments, tags, and dimension names for text matching the
string, and it shows only matching features in the window. This also works in assemblies,
where you can filter for part names or document properties. The filter is very useful for

quickly finding parts, features, mates, or anything else that shows up in the part or assembly
FeatureManager.
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Looking at Folders

The FeatureManager allows a couple of different types of folders. One type enables you to group
features together, which is especially useful when you have long feature trees and you want to
put all the fillets together into one folder. It is also useful in assemblies when you want to group
certain types of parts together, such as fasteners.

Another type of folder is the special-use folders at the top of the FeatureManager for things
such as solid bodies, surface bodies, sensors, and Favorites. You can add features to the Favorites
folders by right-clicking the feature and selecting Add to Favorites.

These special-use folders are not all turned on by default. To turn them on or off (or allow
them to be turned on only if they have content), go to Tools > Options > FeatureManager, where
you will find a list of tree items, including these special-use folders. Figure 2.18 shows a
FeatureManager with several kinds of folders in use.
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USING THE PROPERTYMANAGER

The PropertyManager is where you set most of the feature parameters and where you edit the
properties of selected items such as sketch elements. You can manually switch to the
PropertyManager using the tabs on the top of the Display pane or allow it to pop up automati-
cally when your input is needed.

One of the benefits of putting all the data entry into the PropertyManager is that it saves lots
of space on the screen. On the other hand, you will often need to make a selection from the
FeatureManager at the same time the PropertyManager pops up and takes its place. You can
disable this automatic pop-up behavior by choosing Tools > Options > System Options >
General and selecting the Auto-show PropertyManager setting.

My favorite option for dealing with the PropertyManager is to detach it from the
FeatureManager so I can see the two side by side instead of one or the other. To detach the
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PropertyManager, drag its icon from the tabs out into the graphics area and release. You can see
the detached PropertyManager in Figure 2.1. After the PropertyManager is detached, you can
move it to a second monitor, float it within the SolidWorks window, dock it, or reattach it. To put
it back in its place under the FeatureManager, just drag it back on top of the FeatureManager
using one of the docking station symbols on the screen, allow it to snap into place, and release it.
You can also use the splitter bars (shown in Figure 2.1 in the upper-left corner) to put
the FeatureManager on top and the PropertyManager beneath, or you can use the flyout
FeatureManager. When creating or editing a feature, you can access the flyout FeatureManager
by double-clicking the name of the feature at the top of the PropertyManager. The flyout
FeatureManager is displayed just to the right of the regular FeatureManager, in the main
graphics window; it’s transparent to enable you to see the model through it. The various ways
of combining the FeatureManager and PropertyManager are shown in Figure 2.19.

INTRODUCING THE DISPLAYMANAGER

The DisplayManager helps you understand the various display-related items applied to your
part or assembly. This includes lights, scenes, backgrounds, appearances, colors, textures, and
decals. Figure 2.20 shows the DisplayManager with the Appearances active. Chapter 5 discusses
the DisplayManager in more depth.

Getting Around the Task Pane

By default, the Task pane sits to the right of the SolidWorks screen, although you can undock it
entirely. If you want to keep it open, click the pushpin in the upper-right corner of the pane. The
Task pane is shown in Figure 2.21. If you cannot see the Task pane, it may be turned off. You can
turn it and other interface elements on or off using the View menu (refer to Figure 2.16).

The Task pane is the home for several panels:

Home Tab: This tab enables access to the Welcome screen as well as several miscellaneous
SolidWorks tools. You can also access the Subscription Services from here.

Design Library: This includes locally stored libraries, Toolbox, and 3D Content Central. It also
contains “SolidWorks Content,” which can be downloaded directly from the Task pane.

File Explorer: You can use this Windows Explorer interface to browse for files.

View Palette: This palette enables you to visually select views and drag them onto a
drawing sheet.

Appearances, Scenes, and Decals: This panel enables you to select appearances and scenes
for your SolidWorks documents. SolidWorks has also moved decals into the SolidWorks
Standard level of the software instead of being part of the rendering software.

Custom Properties: The Custom Property tab in the Task pane enables you to create a custom
interface that goes inside this Task pane tab, which will help you enter custom property data
quickly, easily, and accurately.

SolidWorks Forum: This tab shows some of the latest comments on the SolidWorks forums.
Clicking a link in this panel launches a web browser window for more convenient access.

Recovered Documents: After a crash, auto-recovered documents are listed in this special-
purpose Task pane tab.



44

CHAPTER 2 NAVIGATING THE SOLIDWORKS INTERFACE

FIGURE 2.19
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FIGURE 2.20

The DisplayManager
helps you sort through
everything that affects
how the model looks.

FIGURE 2.21
The Task pane, Home tab
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Getting Familiar with the Status Bar

The status bar nonintrusively communicates SolidWorks information back to users, and it
contains some interactive options. It is located at the bottom of the screen, and you can enable it

from the View menu. Figure 2.22 shows the status bar in action.

FIGURE 2.22
The status bar showing
sketch information

W] Model | 3D Views | Animationl |

‘SDLIDWORKS Premium 2018 x64 Edition
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Fully Defined _ Editing Sketch2
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SolidWorks Search

options

FIGURE 2.23 Search Commands |}~ H
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The status bar can display the following information, indicators, and icons:
Progress as parts, assemblies, or drawings load
Change units

Tool tips feedback for commands
Measurement results

The sketch status for an active sketch
In-context editing

Suspend automatic rebuilds

Quick Tips toggle

Tags data-entry window toggle

The sheet scale for drawings

The cursor position for drawings and sketches

Whether you are editing the sheet, sheet format, or view of a drawing

® 6 6 6 O 6 O 6 0 O 0

Window expander when SolidWorks is not maximized

ASSIGNING TAGS

Tags work like document keywords. Tags can be searched using either SolidWorks Explorer or
the FeatureManager Filter. You can assign tags by clicking the tag icon in the lower-right corner
of the SolidWorks status bar. (Refer to Figure 2.1.)

Using SolidWorks Search

You can find SolidWorks Search in the upper-right corner of the SolidWorks application window,
on the title bar, as shown in Figure 2.23. This is different from the FeatureManager Filter, which
enables you to search within a part, assembly, or drawing for feature names or other

types of data.

n

E4 Manufacturers
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SolidWorks Search enables you to search the SolidWorks Help, Knowledge Base, commands,
or community forums for information (some of these require an Internet connection and login)
and to look for SolidWorks models on your local or network drives.

SEARCHING FOR FILES

The file searches include 3D ContentCentral, SolidWorks Explorer, and SolidWorks PDM,, if it is
installed.

To configure where SolidWorks is going to search for files, you can use the options at Tools >
Options > File Locations > Search Paths. Remember that SolidWorks follows search rules that
force it to look in directories that may not be obvious to you, including recent folders where you
have saved documents and other directories.

You also can select custom properties to search from the drop-down list.

Making the Interface Work for You

As engineers and designers, we all like to tinker with things to optimize efficiency and to apply
our personal stamp. When the SolidWorks software is installed, the interface is functional, but
not optimal. Earlier in this chapter, I discussed managing and customizing toolbars and menus.
In the remainder of this chapter, I will focus more on customizing the interface and suggest some
strategies that you might use to help customize your work environment.

Customizing Colors

Before you change the standard colors in the SolidWorks interface, you need to be aware of a few
things. The first is that SolidWorks does not automatically alter text color to contrast with your
background. As a result, if you set the background to black and the text is black, you won’t be
able to see the text. This may seem obvious to some people, but AutoCAD automatically changes
text color to contrast with the view port background, so AutoCAD users may take this function-
ality for granted.

Also, be aware that the colors in the SolidWorks interface have been chosen carefully to offer
good contrast between elements that may be adjacent or superimposed on one another. In most
cases, colorblindness has been factored in to the selections, so you probably won't see blue and
green right next to one another where it matters in the interface.

EXPLORING DEFAULT SELECTION COLORS

All the interface colors are controlled in the Systems Options Colors dialog box. You can access
the dialog box by choosing Tools > Options > Colors, as shown in Figure 2.24.

NOTE Systems Options includes a search box. It has hundreds of settings, and even if you know them
well, finding what you are looking for is sometimes difficult.

Notice that you can set a color scheme. If you want to change the colors used in the interface,
I recommend that you save the settings as a color scheme so the scheme can be re-created easily
later or copied to another computer. Color schemes are stored in the Windows Registry, not as
separate files. To transfer color settings to another computer, you need to either use the Copy
Settings Wizard or manually copy data from the Windows Registry.
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FIGURE 2.24
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Before making changes, you might consider saving your initial settings as a separate scheme
so you can get back to them if necessary.

CAUTION Making changes to the Windows Registry can adversely affect software installation and
hardware performance. You should not attempt changes to the Registry unless you know exactly what
you are doing.

SELECTING BACKGROUND OPTIONS WISELY

You should avoid some colors for the background, or you should make some changes if you
choose these colors. Black is used with fully defined sketches, dimensions, FeatureManager text,
and annotations. Blue can mask the underdefined sketch color and some dimensions. Bright
green can cause problems with seeing selected items. Bright red, aside from being a terrible color
to stare at all day, also does not contrast well with some of the red highlights and error colors.
Even gray masks reference dimensions.

You might think that no matter which color background you select, aside from the default,
something will become difficult to see. For this reason, many users choose a gradient or image
background, which enables them to pick colors where items are always visible on one half of the
screen. Staring at a white screen all day can be uncomfortable for your eyes, so pick colors that
enable you to see everything with “reasonable” contrast, yet are not glaringly bright. Very high
contrast is hard on the eyes, and low contrast may make it difficult to distinguish items on
the screen.
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You have to consider the purpose of the background. Some people doing presentations may
want the background to be attractive while otherwise staying out of the way. Others may need
the background only to contrast with whatever is in front of it in a way that does not strain the
eyes. For writing a book, the background generally needs to be white to match the page. No one
scheme will suit all needs.

In addition to colors and gradients, you can use an image as the graphics window back-
ground. This gives you a wider range of customization capabilities, and several sample images
are already available in the default settings. Also, be aware that document scene backgrounds are
document-specific but can be overridden by system options.

RealView also adds some capabilities with scenes. Scenes can be applied from the
Appearances, Scenes, And Decals tab on the Task pane. Most of the display settings work in
conjunction with RealView, which is an advanced display mode. Depending on your graphics
card, your computer may or may not be capable of using RealView. SolidWorks offers three
different types of scenes: Basic, Studio, and Presentation. Of these, I find the Studio scenes to be
the best when I need a reflective floor with shadows; otherwise, I stick with the Basic scenes.

I find it distracting to use either reflections or shadows in models while working. However,
adding a nice, shiny RealView appearance to the part is often useful, especially for visualizing
curvature on curvy parts.

I describe RealView, along with scenes, in more detail in Chapter 5.

Customizing Strategies
You can easily customize many aspects of the SolidWorks interface, including the following;:

Toolbars

Menus

Background colors or images
Task pane location

Hotkeys

Macros

* ¢ 6 ¢ o o

Custom application programming

Whether you should customize each of these items depends partially on how much time and
energy you have to spend, how much you work with others, whether you share your worksta-
tion with other users, and how much money you are ready to dedicate in the case of custom
programming.

CONSIDERING HOTKEY APPROACHES

Any command that you use more than a few times an hour is worth assigning to a hotkey. I like
to use alliteration when assigning keys to help with my faulty memory. The most frequently

used commands are assigned single-letter hotkeys, and the less frequently used commands are
assigned combinations. Thus, Tools Options is linked to O, Measure to M, Select Vertex to Shift+V,
and Curve Projected to Ctrl+]. (Ctrl+P is the Windows standard for the Print command.) Some of
the settings I like to use conflict with the default settings. SolidWorks has a nice mechanism to
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FIGURE 2.25
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deal with entering conflicts—it will warn you of the conflict, and you can choose to proceed with
the change or not. Other people like to group keys into easy-to-reach combinations; this is why
the Q, W, A, S, Z, and X keys are often assigned first for right-handed mouse users.

ORGANIZING HOTKEYS

Hotkeys are assigned and organized in the Keyboard dialog box (Tools > Customize >
Keyboard), as shown in Figure 2.25. This interface enables you to see all the hotkeys (called
shortcuts in the list) easily. If you try to enter an existing hotkey, SolidWorks issues a prompt,
telling you that the key is assigned to another command and its name. The prompt asks whether
you want to clear the other instance of the hotkey and make the new one active. You can print or
copy to the Clipboard a list of commands that use hotkeys.

Because the list of commands is so long, a Search function is available, and a drop-down
arrow makes visible only the commands from a selected menu. The list of commands
is organized by menu name, and the menus are listed as they occur in the interface.
Fortunately, you can use the Keyboard tab to sort and list menus, commands, or hotkeys in
alphabetical order just by clicking the corresponding column header. This is a highly usable
interface and one of my favorite interface changes in the last several releases.
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Hotkeys for menu items are listed on the right side of the regular drop-down menus. They
serve more as learning aids than interface elements.

I'have included a spreadsheet of the default hotkeys in SolidWorks 2018 with the download
materials for Chapter 2. You can save the list of settings by using the Copy List button in the
dialog shown in Figure 2.25. If you do a lot of customizations, it might be handy to print them
out and tape them to the side of your monitor. It is a little pointless to have to refer to a chart to
remember shortcuts, but you might think of it more as a training aid or a means to allow other
people to use your workstation effectively.

USING MOUSE GESTURES

You can customize and use a mouse-gestures interface, shown in Figure 2.26. To make the
interface appear, just drag the RMB slightly, about % inch. After you get used to the interface, a
drag of about % inch in a single motion activates the commands.

FIGURE 2.26 o
The mouse—gestures g @
interface
N
& 3
=t

NOTE [ have found that this interface works best when you have memorized the commands available
at various positions around the donut. You can set it to use 2, 4, 8, or 12 divisions. Accuracy is more
difficult with the larger number of divisions.

You can establish the donut in four or eight segments; it comes set to four by default. You can
also do the customization in the Customize dialog box (Tools > Customize) using the Mouse
Gestures tab. The advantage of this interface is that it is very easy to invoke. I like the way you
can use the default setup to control views. The mouse moving in a particular direction is easily
associated with a view direction, so it should be easy to remember.

Mouse gestures will probably not replace hotkeys or the S toolbar, but they do add effective
quick access for a few functions.

USING THE KEYBOARD

Moving between the mouse and the keyboard can be bothersome and time-consuming.
In addition to the hotkey approach, you can use another keyboard method to save time.
Many users become adept at using the Alt-key combinations to invoke menu items. Most
menu items in Windows applications contain a single underlined letter.

To access a top-level menu, you can hold down the Alt key, press the underlined letter for
that menu, and then just press an underlined letter in the menu to access specific commands.
This decidedly old-school technique enables you to navigate most of the interface without using

51
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FIGURE 2.27
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the mouse. For example, to exit SolidWorks, instead of using the mouse to click the red X in the
upper-right corner, you could press Alt+F, X. In Figure 2.27, you can see that the F in File is
underlined, as is the X in Exit.
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You may potentially run into conflicts when using Alt keys for menu functions. A combina-
tion of Alt plus another keyboard key is valid for use as a hotkey combination. If you use any
Alt-hotkey combinations, it is likely that you have seen a conflict like this. In cases of conflict, the
hotkey combination seems to gain priority over the Alt-key accelerator.

MINIMIZING ICONS

In order to maximize valuable space on the monitor, many SolidWorks users strive to minimize
the number of toolbar icons on the screen or confine them to two rows of toolbars. You can do
this by using the CommandManager, flyout toolbars, the S toolbar, right-click and left-click
toolbars, and hotkeys, and by removing unused icons, as well as the other techniques dis-
cussed here.

Having an uncluttered workspace is definitely a plus, but having easy access to commands is
the real purpose of an interface in the first place. You need to strike a balance between too much
and not enough. The more kinds of work you do in SolidWorks, the more tools you will need to
have available. If you create only relatively simple, machined parts and drawings, you will need
fewer tools available than someone who creates complex plastic part assemblies with rendering
and animation.

CONTEMPLATING DEVICE APPROACHES

If you have never used a 3D mouse or equivalent view-manipulation device, you should
consider it. They are wonderful devices and do far more than just spin the view. Most of the
devices also have several programmable buttons that you can link to menu items. They can
move drawing views, move parts within assemblies, and even manipulate selected objects in
other Office applications and Web browsers. You can, from time to time, find these devices on
auction sites. Be careful, however, since the older devices use serial ports rather than USB
connectors.
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Mice are the standard input device, and many of them are recommended for CAD work, but
you might also consider a trackball. I've been using a Kensington Slimblade trackball for several
years in CAD and normal office computing, and it takes up a lot less space on the desk. It does
take some time to get used to it. It is wired, but it doesn’t move around.

USING TOUCH AND MULTI-TOUCH SUPPORT

I have written portions of this book on a tablet PC. A tablet might not be ideal for long periods of
SolidWorks usage, but I use it regularly for presentations and even modeling when I really want
to get the feel of drawing a line by hand. The stylus is not quite as intuitive as a pencil, but it is
less of an impediment to the tactile feel of actual drawings than a clunky mouse. Tablets are a
great option when used in combination with the touch functions in SolidWorks, such as

mouse gestures.

The mouse-gestures functionality is considered a tool well-suited to a tablet interface, where
flicking the stylus is easier than mouse clicking. This is a single-touch technique, because the
stylus typically adds only a single point of contact with the screen.

SolidWorks 2018 has added a new Touch mode, enabled via View > Touch Mode. Touch mode
changes the size of interface elements to make them easier to select, and it also adds a Touch
Mode toolbar, as shown in Figure 2.28. The tools on the toolbar are Escape, Shortcut to the S
menu, Multi-select (like pressing Ctrl), Delete, and Lock 3D Rotate, to prevent view rotations
while sketching.

FIGURE 2.28
The Touch Mode toolbar

o X 2 & O

Multi-touch devices are becoming more widely available in CAD-worthy configurations,
including the Microsoft Surface Studio, a full-size touch display that can be set up horizontally
like an old drafting board or used vertically like a large monitor. In preparation for this future
functionality that seems ideally suited to visual applications such as CAD and 3D, SolidWorks
has added functionality to take advantage of these tools. Multi-touch Action Mappings, as the
SolidWorks Help refers to them, are intuitive two-finger motions that enable you to control
the view for actions such as these:

¢ Zoom in or out

¢ Rotate
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1N

Pan
Roll

Zoom to fit
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Right-click

Accessing the Pen and Touch Interfaces

The Pen tool is found on the Sketch Ink toolbar. It enables you to create freeform strokes as a
feature within a sketch. Pen is used in conjunction with the Pen Sketch and Touch tools on the
Sketch toolbar.

This topic will be covered in more depth in Chapter 6, “Getting More from Your Sketches.”

ACCESSING MACROS

A macro is a short snippet of programming code that has a particular function. Most macros are
small and intended for simple tasks that are repeated many times, such as changing selected
dimensions to four decimal places or zooming the screen so it is sized 1:1 (actual size). Macros
may be recorded, be written from scratch, or be a combination where you record a particular
action for use as a starting point and then embellish it manually from there. Recorded macros
may not always record the parts of the action that you want to make into a macro, but you can
edit them manually to include anything that you can program with the SolidWorks API (applica-
tion programming interface), which is included with the base SolidWorks package at no
extra cost.

To access macros by using hotkeys, follow these steps:

1. Make a folder in your SolidWorks installation directory called “macros.”
Copy macros into this folder.
Start (or restart) SolidWorks.

Choose Tools > Customize > Keyboard.

vk W N

Scroll to the bottom of the list under the Macros category, and assign hotkeys as you
would for standard SolidWorks commands.

Whether you are skilled at writing or recording macros, or you are just using macros collected
from other people, they can be huge time-savers and offer functionality that you would not
otherwise be able to access. You might want to consider joining the SolidWorks Community to
share macros and other work with other users. The SolidWorks Community can be accessed
through the Task pane within the SolidWorks software or via the SolidWorks website.

SAVING CUSTOM INTERFACE SETTINGS

After you have set up your menus and toolbars, worked out all the custom colors, figured out
your hotkey usage, and connected your macros, you won’t want to lose these settings when you
reinstall the software or move to a different computer. Another user may want to share your
settings, or you may want to transfer them to your home computer (for modeling the new deck
or the doghouse, of course). Fortunately, these settings are very portable.
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You can use the Copy Settings Wizard to save these settings to a file. Access the wizard by
choosing Start > SolidWorks 2018 Tools > Copy Settings Wizard. This creates a file with a
sldreg file extension. You can restore settings by double-clicking this file on a computer that has
SolidWorks installed on it.

NOTE You may need to have administrator access to your computer to apply a SolidWorks Registry
file. Changing Registry files is kind of dangerous, and I don’t really encourage novices to do it unless
they have access to someone who understands the Windows Registry.

The SolidWorks settings are actually Windows Registry settings. The file that is saved by the
wizard is just a Registry file that has a different extension to prevent it from being applied too
easily. Saved Windows Registry files have a reg file extension, and you can integrate them into
the Registry by simply double-clicking them. If you are not familiar with the Windows Registry,
you should not make direct changes, because even small changes can cause serious problems
with your operating system, installed software, or even hardware. The settings that are saved by
the Copy Settings Wizard are safe to transfer between computers. In order for the Copy Settings
Wizard to work, you need to have Administrator-level access to your computer. The Copy
Settings Wizard is shown in Figure 2.29.

FIGURE 2.29
The Copy Settings &

Wizard

Welcome to the SOLIDWORKS Copy Settings Wizard

This wizard allows you to save or restore customization settings for
SOLIDWORKS toolbars, shortcuts, menus, and system preferences.
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Restore Settings -
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—

p
25 SOLIDWORKS

Mext > Cancel

Working with Multiple Document Windows

You may sometimes have the luxury of working on a single part at a time, but more often, you
will find yourself with several documents open at once. This is a common situation for most
users. Fortunately, SolidWorks has several methods for dealing with “information overload” to
help you sort through it all.
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GETTING THE MOST FROM THE OPEN COMMAND

¥ The Open dialog box presents some options that you will learn more about in later chapters.
B Figure 2.30 shows this interface.
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You can use the Open dialog box just as you would use an open Windows Explorer window.
That means you can copy, paste, rename, delete, and move files while you are deciding which
one to open. You can also show a preview window and control the size of the icons. The
SolidWorks-specific controls you may use most are the Quick Filter controls to narrow the
display to just the types of files you're seeking. The icon to the far right of the Quick Filter list
shows only top-level assemblies (assemblies that are not a subassembly in another assembly).

If you have other types of files to open, you can use the Custom button for the traditional
SolidWorks file type list.

Also notice the Mode button. This button allows you to open a part in Resolved (normal,
editable) mode or Quick View (view only). Configurations and Display State buttons are topics
covered in later chapters—they allow you to more quickly access the information you are
looking for rather than having to open the file and then switch to a different configuration.

MANAGING OPEN FILES

Pressing the combination Ctrl+Tab brings up the Open Documents window, shown in

Figure 2.31. To keep the window open, continue to hold down the Ctrl key. Press Tab again to
cycle through the open documents. Use the mouse to click an X in any of the thumbnails to close
that document. You also can click a link to show that document in its own folder. To close the
preview without changing documents, you can press Esc; however, Ctrl+Esc opens the Windows
Start menu.

MANAGING RECENT DOCUMENTS

The list of recently used documents is available from the File menu or by pressing the R hotkey.
This is actually just a tab in the Welcome dialog, which is also available by pressing Ctrl+F2. The
Recent file list can also be accessed using File > Open Recent, which gives a text-based list.
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FIGURE 2.31
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The documents within the window can be opened or pinned in place so they always remain on
the Recent Documents list. Figure 2.32 shows this dialog box.

FIGURE 2.32
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The Folders option at the top gives you a view of the paths to all of the recent documents, and
the Browse button takes you to a Windows Explorer view of the folder.

If you hover over an icon in the Documents list, a small double arrow appears in the lower-
right corner of the icon. Clicking on that double arrow displays certain information and allows
you to open that document in particular configurations, particular display states, open as
read-only, or access the references. This is shown in Figure 2.33. A lot of capability is packed into
this Welcome box.
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FIGURE 2.33
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MANAGING WINDOWS

Like most Windows applications, SolidWorks can arrange the open document windows in one of

several ways that are available through the Window menu:

New Window: Opens a new window of the active document. Dynamic highlights and
selections in one window appear in both.

Cascade: This is most useful for accessing documents that are to be edited one-by-one.
Tile Horizontally: This is most useful for comparing wide and short parts side-by-side.

Tile Vertically: This is most useful for tall, narrow parts or documents where you want to
compare items in the FeatureManager.

Arrange Icons: When windows are minimized to icons, this menu selection arranges the icons

neatly, starting in the lower-left corner of the window.

Close All: Closes all open windows. This option may prompt you to save modified
documents.

SPANNING MULTIPLE MONITORS

SolidWorks has tools to help you manage the display across multiple monitors. Figure 2.34
shows the document and application window control buttons in the upper-right corner of the
SolidWorks window. In addition to the usual Minimize, Maximize, and Close, the application
window controls add the Span Displays tool, which makes the SolidWorks window use both
displays in a dual display arrangement.
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The document window controls add Tile Left and Tile Right, which force the current docu-
ment window onto the left or right monitor, respectively. When accessing the Tile Left/Right
icons on a single monitor, the documents will be sent to the left or right half of the screen.
Multiple monitors work best if they have the same vertical resolution; for example, a 1920 x 1200
wide screen and a 1600 x 1200 normal aspect-ratio monitor would work well side by side, but
mixing with a 1024 x 768 screen would not. When monitors of different vertical resolutions are
used, SolidWorks sizes to the lowest resolution monitor (the second number listed is the vertical
resolution).

The Bottom Line

Learn the different parts. The SolidWorks interface has many elements because SolidWorks
has so much functionality. You can access most elements multiple ways, which can be
liberating because it offers options, but it can also add to the confusion because there is so
much to know. You do not need to know every way to do everything; you only need to know
the best way for you.

Master It Identify each area around the SolidWorks window.

Customization is key. Customization opportunities in SolidWorks are vast. Everyone has
different tastes and preferences when it comes to running the interface. Some prefer the
keyboard, some the mouse. Some prefer the touch interface. There are different strategies that
depend on your specific situation—for example, saving space, saving mouse travel, or saving
mouse/keyboard clicks. SolidWorks has touch interface options, as well as various accessibil-
ity tools intended to accommodate special needs, such as different input devices or color
blindness.

Master It Create some simple keyboard shortcuts (hotkeys) for the functions you think
you will use the most.

Manipulate multiple windows. Manipulating multiple windows is important in all
computer use, but especially in CAD, where you work with enormous amounts of data and
numbers of documents that surpass other types of programs.

Master It Open several sample documents from the Wiley download data and practice
manipulating the windows.



Working with Sketches
and Reference Geometry

The first step to learning how to create models in SolidWorks is to learn how to sketch. If you are
coming from another history-based modeling program, many of your skills are transferable to
SolidWorks. If you have never used CAD before, think of the sketch-feature relationship as
creating a simplified 2D drawing that represents a portion of the part that you can make with
some sort of process such as extruding or revolving.

So far in this book, you have looked mainly at concepts, settings, and setup, which are
necessary but mundane. In this chapter, you'll begin to learn how to control parametric relation-
ships in sketches. Then in later chapters, you'll begin to build models—simple at first, but
gaining in complexity and always demonstrating new techniques and features that build your
modeling vocabulary. Beyond this, you'll use the parts to create assemblies and drawings.

This chapter deals entirely with sketches in parts. However, you can apply many of the topics
covered here to sketches in assemblies and drawings. Some related topics, such as layout
sketches, have functionality that is exclusive to assemblies, and these topics will be covered in
later chapters.

IN THIS CHAPTER, YOU WILL LEARN TO:

Begin a sketch

Distinguish sketch entities
Create relationships in sketches
Examine sketch settings

Use sketch blocks in parts, assemblies, and drawings

* & 6 0 o o

Create and use reference geometry

Creating a New Part

Before you can create a sketch, you must create a new part. To create a new part, you must follow
these two simple steps:

1. Click the New tool.
2. Select a part template from the list. The part template will have the units and drafting

standards already set.

Mastering SolidWorks, First Edition. Matt Lombard.
© 2019 John Wiley & Sons, Inc. Published 2019 by John Wiley & Sons, Inc.
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Each new part will start with some basic items. The items you need to focus on about right
now are the base planes and the origin (shown in Figure 3.1 in the FeatureManager of a brand
new blank part made from a template). The planes can be named anything you want: X, Y, and Z;
Front, Top, and Right; Larry, Moe, and Curly; or whatever. The naming scheme is determined by
the person who saved the template.

FIGURE 3.1 @, Part2 (Default<<Default>_Display State 1
The FeatureManager of History
anew part Sensors

4 Annotations
"IE Material <not specified>
|E| Front Plane
|E| Top Plane
|E| Right Plane

I_. Qrigin

Chapter 1, “Introducing SolidWorks,” has more detailed information on part templates and
setting up SolidWorks to use existing templates. Several templates are included with the down-
loadable materials for this book.

Creating a Sketch

Best practice for sketching in SolidWorks dictates that you should keep a few things in mind
while creating and editing sketches:

¢ Sketches need to be clean and precise, with no gaps or overlaps and no stray
sketch entities.

It is best to keep each sketch simple. Complex sketches tend to fail or cause problems later.

You should create sketches with the general “design intent” (for example, a horizontal
rectangle) and then add the details later (for example, precise dimensions).

¢ Itis best if you can pick up the desired automatic relationships as you sketch rather than
waiting to create them manually later. At the same time, you need to be able to avoid
extraneous and unwanted automatic relationships you may get from careless sketching.

¢ The use of reference geometry can save you from unwanted parent/child relationships
between features.

SolidWorks allows several workflows you can use to create a sketch. To try to simplify it,
think of it this way. You have the Sketch tool that opens a sketch, and you have tools such as
Line, Arc, Circle, and so on. You also have planes and planar faces, straight line segments, and
straight edges. To create a new sketch, you have to make two selections. One selection must be a
tool that tells SolidWorks you want to make a sketch, such as the Sketch tool, or Line, Arc, Circle,
etc. The second selection has to be where you want the sketch to be located, such as a plane, a
planar face, or an edge on which a perpendicular plane will be created.
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Here’s one way to create a new sketch:

1. Click the Sketch tool. Notice the prompts in the FeatureManager area.
2. Click the Front plane in the FeatureManager.

Here’s another way:

1. Right-click on a plane (either in the FeatureManager or in the graphics window if they are
shown). As an alternative, you can click a plane to call the context-sensitive toolbar.

2. Select Sketch from the context bar (on top of the RMB menu).
Here is yet another way:

1. Click the Line tool. Notice the FeatureManager disappears and the PropertyManager
shows up in its place. The flyout FeatureManager has actually moved over into the
graphics window and has collapsed.

+ @ part efault 2. Click the down arrow next to the Partl symbol.

.p-l
| 1
-

3. Click a plane in the tree.

Clicking a straight edge creates a plane perpendicular to the end of the edge closest to
where you clicked. The plane will show up in the FeatureManager automatically. (This is
an obscure trick that a lot of existing users have forgotten.)

When you create a sketch, several tools become available, specifically all the sketch entities
and tools. Open sketches and selection filters are two very common sources of frustration for
new users. If you are having difficulty selecting items that you want because the software won't
allow you to select specific items or because items are grayed out, you could have an open
sketch. Several indicators will let you know when you are in Sketch mode:

¢ The title bar of the SolidWorks window displays the text “Sketch X of Part Y.”
¢ The lower-right corner of the status bar displays the text “Editing Sketch X.”

¢ The Confirmation Corner displays a Sketch icon in the upper-right corner of the graph-
ics window.

The Sketch toolbar button displays the text “Exit Sketch.”
The red sketch origin is displayed.
If you are using the grid, is displayed only in Sketch mode.

While most users find the sketch grid annoying or distracting, some new users use it as a
reminder that they are in Sketch mode. If you tend to forget or would like a visual cue, the sketch
grid is a useful option. You can find the settings for displaying the grid in Sketch mode at Tools >
Options > Document Properties > Grid/Snap.

A sketch can be edited only when it is open (unless Instant 3D is off—I recommend you turn it
off, except when you intend to use it). You can have only one sketch open at a time. SolidWorks
uses many indicators to show the state of a sketch, including the Confirmation Corner and
the taskbar.
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FIGURE 3.2
Options with the Line / v E M

flyout toolbar / Linel"\’ E

Just as you can create sketches in several ways, you can also open existing sketches
several ways:

¢ Right-click a sketch in the FeatureManager or graphics window and select Sketch.

¢ Select a sketch from the FeatureManager or graphics window, and click the Sketch icon on
the Sketch toolbar.

Left-click a sketch or feature and click the Sketch icon from the context toolbar.

Double-click a sketch with the Instant 3D tool active.

TIP The 3D view can be at any angle while you are sketching. If you prefer to always show the sketch
in the plane of the display, use the setting at Tools > Options > Sketch > Auto-rotate View Normal To
Sketch Plane On Sketch Creation And Sketch Edit.

Identifying Sketch Entities

SolidWorks sketching tools include many types of entities. Some you will use all the time, and
others you may never use, even if you spend years working with the software. In this section, I
offer tips for using each entity.

Using the Sketch Toolbar

In the following section, I first identify the default buttons on the Sketch toolbar, followed by the
rest of the entities that you can access by choosing Tools > Customize > Commands > Sketch.
Take a minute and hover your cursor over the buttons on the Sketch toolbar. Let the tooltips
come up. When a button has a triangle to the right of it, the triangle is a flyout button that
provides access to additional tools. For example the Line flyout allows you to also select the
centerline (also used as construction line) and the midpoint line. As shown in Figure 3.2.

.l -
~ Centerline

\ Midpoint Line

TIP Ipersonally like to turn off the Sketch toolbar in the CommandManager and use a separate
Sketch toolbar vertically on the right side. This is because switching back and forth between Sketch
and Features in the CommandManager becomes a little tedious. I find it more efficient to have both
toolbars showing at the same time.

The Sketch tool opens and closes sketches. You may notice that the name of the button
changes depending on whether the sketch is open or closed. If you preselect a plane or planar
face and then click the Sketch button, SolidWorks opens a new sketch on the plane or face. If you
preselect a sketch before clicking the Sketch button, SolidWorks opens this sketch. If you pre-
select an edge or curve feature before clicking the Sketch button, SolidWorks automatically
makes a plane perpendicular to the nearest end of the curve. If you do not use preselection and
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click the Sketch tool with nothing selected, SolidWorks prompts you to select a plane or planar
face on which you want to put a new sketch, or an existing sketch to edit.

The 3D Sketch tool opens and closes 3D sketches with no preselection required. 3D Sketch is
covered in more detail in Chapter 6, “Getting More from Your Sketches.”

The Smart Dimension tool can create all types of dimensions used in SolidWorks, such as
horizontal, vertical, aligned, radial, diameter, angle, and arc length. You can create dimensions
several ways, as shown in Figure 3.3. The dimensions shown were created by selecting the line
itself and moving the cursor to different locations to get horizontal, vertical, or aligned
dimensions

We will return to smart dimensions later in this chapter.

The Line tool creates straight lines using one of two methods. You should practice these two
methods to determine which one you prefer. If you have used other CAD products, you probably
already have a preference.

Click+click: This method is used for drawing multiple connected end-to-end lines. Click and
release the left mouse button to start the line; each click and release ends the previous line
and starts a new one. Double-click (to cancel the first click point but remain in the Line
command), press Esc (to exit the Line command altogether), or deselect the Line tool to end.

Click-and-drag: This method is used to draw individual or unconnected lines. Click, drag,
and drop. The first click initiates the line, and the drop ends it.

TIP Some functions, such as Enable On-Screen Numeric Input, seem to function better with
Click+click than with click-and-drag.

Alternative methods exist for drawing lines that include horizontal, vertical, angle, and
infinite lines. The interface for these options appears in the PropertyManager, as shown in
Figure 3.3.

FIGURE 3.3
. -
The Insert Line \
PropertyManager
interface /" Insert Line @ 77 47
v X \
Message L
Edit the settings of the next new line or )
sketch a new line.
Orientation ~ | .
@As sketched \
(O Harizontal :
() Vertical [ g -8
OAngIe
Modify
Options Ll
- *
|:| For construction J x ’ 13
[ infinite length Di@sketcni | Distance (Enter a value or start with = to create an equation)
. R 64.09125555mm Ik = J
[ Midpoint line

Horizontal, Vertical: These settings require you to select a starting point and an ending
vertical or horizontal position. I see no compelling reason to use this setting instead of the
regular Line command. It is useful in a strictly 2D world, but I can’t see what I would use
it for here.
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Angle: This setting enables you to specify an angle and drag a line at this angle. Again, I can
find no compelling reason to use this tool.

Infinite Length: SolidWorks parts have a working space limited to 1000 meters on a side,
centered on the origin. Infinite lines extend well beyond this, although you cannot draw or
dimension a regular line outside of this box. This feature would be most useful if you are
working with parts with vastly divergent scales of features (some very large, some

very small).

TIP The Add Dimensions option exists in several sketch-entity PropertyManagers and adds Smart
Dimensions to newly sketched entities. The option appears in the sketch-entity PropertyManager
only if the setting at Tools > Options > Sketch > Enable On-Screen Numeric Input On Entity
Creation is selected.

The On-Screen Numeric Input option is not the same as the Input Dimension Value function; in

fact, it overrides that option. You cannot input dimension values when using the Add Dimensions in
conjunction with click-and-drag sketching. It appears to be intended for Click+click sketching only, so
that you can enter values between clicks.

D When you select the Corner Rectangle tool, you can create a rectangle by clicking one corner
and dragging to the diagonal corner. This action creates four lines with Horizontal and Vertical

sketch relations, as appropriate. The Corner Rectangle is also available as a flyout icon with a
Corner Rectangle, Center Rectangle, 3 Point Corner Rectangle (rectangle at an angle), 3 Point
Center Rectangle, and Parallelogram. Figure 3.4 shows the flyout and flyout icons, as well as the
PropertyManager for the Rectangle, which also enables you to switch types of rectangles easily.
Remember that the shortcut shown on the right cycles through all of the rectangle options in the
PropertyManager.

If you have activated any of the items under the Rectangle flyout, you can press the A key
to cycle through the rest of the items. If you have already started sketching the rectangle but
haven’t yet finished, pressing the A key will cancel out of the current rectangle and cycle to
the next type. This may be faster than actually using the flyout; just click the first icon and
cycle to the one you want. The cursor icon changes to show which type of rectangle it will
presently sketch.

Notice the Add Dimensions check box in the PropertyManager. Selecting this box while
creating a rectangle causes the software to add dimensions aligned with the sides of the rectan-
gle. This option is also available for lines, arcs, and circles.

Note that if you use this option in conjunction with the Enable On-Screen Numeric Input On
Entity Creation setting, found at Tools > Options > Sketch, it makes creating sketch entities to the
correct size immediately much easier.

H The Parallelogram tool is used to draw a parallelogram (adjacent sides are not perpendicular,
and opposite sides are parallel). Click one corner of the parallelogram, and then click the
second and third corners. It works like the 3 Point Rectangle except that adjacent sides are not
perpendicular.



FIGURE 3.4
The Rectangle flyout
with associated icons

& NOTE The Shaded Sketch Contours option is turned on by default. This option adds shading to any
sketch area where entities enclose an area end-to-end. The lines or arcs (or whatever) have to touch
at their end points and not cross in the middle of the line. Circles enclose an area and are therefore
shaded. This option is partly a diagnostic tool and is useful for one-click selection of the contour enti-
ties. You will also find it useful when you want to use a subset of a sketch to create a single feature.
(Note that you cannot create multiple features using contours from one large sketch.) You can turn
off the option from the Sketch toolbar or through the menus at Tools > Sketch Settings > Shaded
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Sketch Contours.

@ The Circle tool creates a circle using one of two methods, which are available from either the

flyout icon or the Circle PropertyManager:

Center Creation: Click the center of the circle and drag the radius. The Circle
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PropertyManager calls this function center creation.
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Perimeter Creation: To create a circle using this technique, you must select the Perimeter
Creation option from the Circle PropertyManager window after clicking the Circle tool. There
is also a separate Perimeter Creation toolbar button and a menu selection for Tools > Sketch
Entities > Perimeter Circle. This creates only tangent relations with other entities in the
current sketch; if you are building a circle from model edges or entities in other sketches, you
need to apply the relations manually. SolidWorks calls these functions perimeter creation.

FIGURE 3.5
Creating a circle

Tangent to Two Entities: Start the circle with the cursor near one line in the sketch.

A Tangent symbol appears by the cursor with a yellow background. Click and drag the
diameter to the second tangent entity, where a similar cursor symbol should appear.
Release the mouse button and right-click the green checkmark icon. This process is shown

in Figure 3.5.

Tangent to Three Entities: Use the same process used for Tangent to Two Entities, but
omit the right-click of the green checkmark icon. After dropping on the second tangent,
drag again to the third tangent entity.

() circle

d

Circle Type

Parameters

@

Ds
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exactly like those for the Center-Radius circle.

When you select the Centerpoint Arc tool, you can create arc by clicking the center, dragging
the radius, and then clicking and dragging the included angle of the arc. The first two steps are
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—D The Tangent Arc tool creates an arc tangent to an existing sketch entity. Depending on how
you move the cursor away from the end of the existing sketch entity, the arc can be tangent,
reverse tangent, or perpendicular, as shown in Figure 3.6.

FIGURE 3.6 +
Using the Tangent perpendicular

Arc feature
original line \\
—_ / +
reverse tangent </ \
+

Another way to create a tangent arc (called auto-transitioning) is to start drawing a line

from the end of another sketch entity, and while holding down the left mouse button, press the
A key; or return the cursor to the starting point and drag it out again. This second method can
be difficult to master, but it saves time compared to any of the techniques for switching
sketch tools.

) The 3 Point Arc tool creates an arc by first establishing endpoints and then establishing the
included arc, as shown in Figure 3.7. Again, this tool also works using the Click+click or click-
and-drag methods.

tangent

FIGURE 3.7 L A=F0°R =15.78
Creating a /_R
three-point arc s o - R
e ememmsmemeemmemeseme e L=37.28 \‘\“ C||ckdrag
>
click - drag DR e

The Sketch Fillet tool creates a sketch fillet in two ways. Either you can select the endpoint
where the sketch entities intersect, or you can select the lines themselves, selecting the portion
that you want to keep. Figure 3.8 illustrates both techniques.

ﬁ The Sketch Chamfer tool is on the same flyout as the Sketch Fillet by default. Sketch Chamfer
does not have a list selection box the way that fillet does, and it does not use a preview like
the fillet.

_J
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FIGURE 3.8

Creating a sketch fillet

/ )
) select
select lines —>» result

SKETCH FILLETS

Although the Sketch Fillet tool is easy to use and may align with your way of working in a 2D pro-
gram, it is not considered best practice to use sketch fillets extensively. Some of the reasons for
this include:

*

*

L 2

*

Large changes in the size or shape of the rest of the sketch can cause the feature built from the
sketch to fail.

SolidWorks (and other parametric programs as well) often has difficulty solving tangent arcs in
some situations. You may see fillets flip tangency or go around 270 degrees instead of just
90 degrees. Using many fillets in a sketch can often cause trouble.

If you want to remove the fillets temporarily, there is no good way to do this if you have used
sketch fillets.

Sometimes feature order requires that other features, such as draft, come before the fillet,
which is difficult to do if they are part of the sketch.

Sometimes a 2D fillet simply cannot create the required 3D geometry.

Fillet features are the preferred method for creating rounds and fillets. The same can be said for
chamfers. Still, sometimes you need to use tangent arcs in sketches. You will have to decide which
way works best for you in each situation.

& The Centerline tool follows the same methods as regular lines and is called a construction line
@’ in some cases. Other construction entities, such as construction circles, are not available directly,
but you can create them by selecting the For Construction option in the PropertyManager for
any entity.
[U The Spline tool draws a freeform curve. Splines may form either a single closed loop or an

open loop. In either case, the spline is not allowed to cross itself. You can draw a spline by
clicking each location where you want to add a control point. Figure 3.9 identifies the elements of
a spline. The detail image shows the structure of a spline handle.

Splines are used mainly for freeform complex shapes in 2D and 3D sketches, although you can
also use them for anything in which you would use other sketch elements. If you need more
information on splines and complex shape modeling, refer to the SolidWorks Surfacing and
Complex Shape Modeling Bible (Wiley, 2008).
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FIGURE 3.9
The structure of a spline
and spline handles
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The Point tool creates a sketch point. Aside from limited cases of lofting to a point or using a
point as a constraint sketch in a Fill feature, sketch points are usually used for reference, in
patterns, or for the location of the centerpoint of Hole Wizard features.

You can also use the sketch point as a virtual sharp. If two sketch entities do not actually
intersect because of a fillet or chamfer, selecting the two entities and clicking the Point tool
creates a point at the location where they would intersect if they were extended. This is useful for
dimensioning to the sharp. Virtual sharp display is controlled by a Document Property setting.

The 3D Sketch Plane tool creates a plane in a 3D sketch. I discuss 3D sketches in more detail in
Chapter 6. By sketching on planes within a 3D sketch, you get most of the benefits and usage of
2D sketches, and you do not have to deal with history between sketches. Before committing too
much work to this course, you should look into some of the shortcomings of 3D planes. The
planes are treated just like any other entity in the 3D sketch, which means you can assign sketch
relations to them, but it also means that they can move around within the sketch the way sketch
entities do.

J:L The Add Relation tool displays a PropertyManager window that enables you to apply sketch

relations. This interface appears to be obsolete, because it is easier to simply select sketch items
and apply relations via the context toolbar or in the PropertyManager window that appears
automatically when you select them; however, there are some subtle workflow-related reasons
for using this tool.

Using the Add Relations dialog box has two advantages over simply selecting sketch entities
and adding relations. When the Add Relation PropertyManager is active, you do not need to use
the Ctrl key to select multiple entities. You also do not need to clear a selection before making a
new selection for the next relation. These two reasons sound minor, but if you have a large
number of sketch relations to apply, the workflow goes much more smoothly using this tool than
the default method.

The Display/Delete Relations tool enables you to look through the relations in a sketch and
sort them according to several categories. From this window, you can delete or suppress relations
and replace entities in relations.
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FIGURE 3.10 [T offset Entities
The Offset

Entities interface

The Quick Snaps flyout enables you to quickly filter types of entities that sketch elements will
snap to when you move or create them. To access the tools, click the drop-down arrow to the
right of the toolbar button.

The Mirror Entities tool mirrors selected sketch entities about a single selected centerline and
applies a Symmetric sketch relation. In addition, a Dynamic Mirror function is described later in
this chapter.

The Convert Entities tool converts edges, curves, and sketch elements from other sketches into
entities in the current sketch. When edges are not parallel to the sketch plane, the Convert
Entities feature projects them into the sketch plane. Some elements may be impossible to
convert—for example, a helix, which would produce a projection that overlaps itself. Sketch
entities created using Convert Entities get an On-Edge sketch relation.

The Offset Entities command works like the Convert Entities feature, except that it offsets the
sketch to one side or the other of the projection of the original edge, sketch, or curve, and Offset
Entities doesn’t have a selection box. Figure 3.10 shows the PropertyManager interface for
this command.

®

v X ™

Parameters Ca

@
Add dimensions
I:‘Re\rerse
Select chain
[ Bi-directional
Cap ends

Lines
Construction geometry:

I:‘Base geometry
I:‘Offset geometry

The options available in the Offset Entities interface are as follows:

Add Dimensions: This option constrains offset sketch entities. Instead of the On-Edge
relations, Offset Entities creates an Offset sketch relation that cannot be re-created manually.

Reverse: This option changes the direction of the offset.
Select Chain: This option selects continuous end-to-end sketch entities.
Bi-directional: This option offsets to both sides simultaneously.

Cap Ends: This is available only when you have selected the Bi-directional option. Capping
the ends with arcs is an easy way to create a slot from a sketch of the centerline. This function
works with all sketch entities; it is not limited to straight slots. Figure 3.11 shows examples of
the Cap ends option.

Construction Geometry: This option enables you to select which geometry (if any) you
would like to make into construction geometry—the original selection, or the entities that
are offset.
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FIGURE 3.11
The Offset
Entities interface

CAUTION The Offset Entities command may fail if the offset distance is greater than the smallest
radius of curvature and you are attempting to offset to the inside of the arc.

In addition to the bidirectional offset with capped ends, SolidWorks also has slot sketch
entities for straight and curved slots, which are covered later in this chapter. Composite slots
(made of a combination of straight and curved sections) still require the offset method.
% The Trim tool is actually several functions rolled into one, including extending and deleting
sketch entities. Figure 3.12 shows the PropertyManager interface for this function.

FIGURE 3.12 9% Trim @
The Trim interface

v
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cursor across the entities, or pick on an
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Power Trim: This trims by dragging a cursor trail over multiple entities. The entities that you
drag the cursor over are trimmed back to (or extend up to, when using the Shift key) the next
intersecting sketch entity. Each time you trim an entity, a red box remains until you trim the
next entity. If you backtrack with the cursor and touch the red box, this trim is undone. This
option is best used when you need to trim a large number of entities that are easy to hit with a
moving cursor. Figure 3.13 shows the Power Trim feature in action. You can also use Power
Trim to extend sketch entities along their paths by dragging the endpoints. Regular dragging
can also change the position or orientation of the rest of the entity, but by using the Power
Trim feature, you affect only the length.

FIGURE 3.13
Power Trim in action

\
-

Corner: This trims or extends two selected entities to their next intersection. When you

use the Corner option to trim, the selected portion of the sketch entities is kept, and anything
on the other side of the corner is discarded. Figure 3.14 shows two ways that the Corner
option can work.

FIGURE 3.14
Using the Corner option

/
U

Trim Away Inside: This trims away selected entities inside a selected boundary. The bound-
ary may consist of a pair of sketch entities or a model face (edges of the face are used as the
boundary). Only entities that cross both selected boundaries (or cross the closed loop of the
face boundary twice) can be trimmed. This option does not trim a closed loop such as a circle,
an ellipse, or a closed spline.
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Trim Away Outside: This functions exactly like the Trim Away Inside option, except that
sketch entities outside of the boundary are discarded. The Trim Away Inside and Trim Away
Outside options are illustrated in Figure 3.15.

-
j%\F/ \ .

Trim To Closest: This is the default setting. Clicking a sketch entity:

FIGURE 3.15

Using the Trim Away
Inside and Trim Away
Outside options

Trims it back to the next entity if there is only one crossing entity.

¢ Trims between two crossing entities if there is more than one.
¢ Deletes the entity if there are no crossing entities.
¢ Inall cases, the selected section of the entity is removed. The Trim To Closest option

can also extend when you drag one entity to another; if an intersection is possible, the
first entity is extended to the second entity. Figure 3.16 illustrates how the Trim To
Closest option functions.

FIGURE 3.16
Using Trim To
Closest to extend

The Construction Geometry tool toggles between regular sketch entities and construction
entities. Construction sketch entities are not used to create solid or surface faces directly; they are
used only for reference—for example, revolve centerlines, extrude and pattern directions, and so
forth. Be careful with the icon for this function, because it looks almost identical to the No Solve
Move icon, especially as printed here in grayscale.
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E] The Stretch sketch tool is intended for use in sketches where there are enough dimensions to

i make a particular change difficult by changing dimensions only. Stretch enables you to specify a
change that will change several dimensions simultaneously. Figure 3.17 shows the sketch being
stretched. Notice one of the lines is not selected at the top, so the top vertical line becomes angled
and loses its vertical relation.

FIGURE 3.17 [L: stretch
Using the Stretch
sketch tool
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TIP The main ideas to remember with the Stretch tool are that it is used to stretch dimensioned lines
and that you need to select the lines that will lengthen or shorten as well as the lines that will move.
Because of this, selecting entities for Stretch is best done with the right-to-left window selection or
the lasso, which also selects any items that the selection box crosses. (Left-to-right window selection
selects only items that are completely within the selection box.)

20 The Move, Rotate, Copy, and Scale sketch tools operate on selections within a sketch. You can
'O use these tools with pre- or post-selection methods. These tools delete existing sketch relations

when necessary to accomplish the task. For example, if you want to move a rectangle connected
En to the origin, the Move tool deletes the coincident relation between the sketch endpoint and the
|—:| origin. If you want to rotate a rectangle, the Rotate tool deletes all the horizontal and vertical

relations on the entities being rotated. This operation may result in a completely underdefined
sketch. SolidWorks does not warn you that sketch relations are being deleted.

If you use the Scale tool on a fully defined sketch, SolidWorks scales the position of the
selected entities, deleting sketch relations if necessary to do so, but no dimensions are scaled
or deleted.

CAUTION Be careful when using these sketch tools. They can delete sketch relations without warn-
ing. Some of the tools have a check box for Keep Relations.

These sketch tools were originally put in the software to avoid some of the complexities and
limitations of the Modify Sketch tool, which can also move, copy, rotate, and scale sketches.
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Figure 3.18 shows the simple interface for the Move Entities command. Select the entities to
move in the upper box and the method to move them from the Parameters box.

FIGURE 3.18 20 pove
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Entities interface

@

Entities to Move Ca

A0

Keep relations

Parameters Ca

OFrom.-"To
®xy

AX | 0.00mm

AY | 0.00mm

The Select tool is usually used to turn off the previous command and return the cursor to its
default state. It is not found on toolbars in the default interface.

The Grid/Snap tool is used to open the Grid/Snap section of Tools > Options > Document
Properties.

The Polygon tool creates a regular n-sided polygon in the same way as a circle. Click the
center and drag the radius. You need to set the number of sides in the PropertyManager before
clicking in the graphics window.

An ellipse is created by clicking the center, dragging one axis, and then dragging the
other axis.

A partial ellipse is created by clicking the center, dragging one axis, dragging the other axis,
and then clicking and dragging the included angle of the partial ellipse. The Partial Ellipse
feature works like the Centerpoint Arc command.

A parabola is created by clicking the location for the focus and then dragging the position of
the apex. You then click and drag the included angle of the parabola. This is a rarely used sketch
entity and is often difficult to control with sketch relations or dimensions.

A conic is a special curve that is used to create smooth shapes that are limited to convexity on
one side. A spline can have a point of inflection, but a conic cannot. It is similar to a partial
ellipse, but it has an additional point called a top vertex in the PropertyManager. To create a
conic, place the two end points, then place the top vertex, and finally place the shoulder. (See
Figure 3.19.) If you are familiar with systems that use a rho (p) value, you can specify the value in
the PropertyManager.

@ The Spline On Surface tool is used in 3D sketches to draw a freeform spline on any 3D surface.

The Spline On Surface feature can cross face boundaries as long as the faces are at least tangent
(ideally curvature continuous) across the edge. Spline On Surface can be used to trim surfaces or
create split lines.

N Oy

> C
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FIGURE 3.19
Drawing a conic
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A The Sketch Text tool creates editable text in sketches using TrueType fonts installed in your
Windows Fonts folder. Some fonts produce sketches that are unusable for solid features, due
to violating sketch rules with overlapping or zero thickness. You need to be careful which
fonts you select, but I have had success with a wide variety of fonts I have found on the
Internet. Sketch Text may be dissolved into lines and arcs so that you can edit them manually.
Dissolve is available on the RMB menu. Figure 3.20 points out the key elements of the Sketch
Text interface.
For some machine scribing functions, you will want single line or stick fonts. In SolidWorks,

the default for that functionality would be OLF SimpleSansOC.

NOTE Note that the Link To Property icon enables you to link sketch text to a custom property or to
a configuration-specific custom property. Using configurations and properties to drive sketch text can
be a valuable function.

E% The Intersection Curve tool creates sketch entities in 2D sketches, where the sketch plane
intersects selected faces. In 3D sketches, the Intersection Curve sketch tool creates sketch entities
where any types of selected faces intersect. This can be an extremely useful tool in many
situations.
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The Face Curves tool applies the underlying U-V isoparameter mesh to a selected face. It is
most commonly used as an evaluation tool for complex surfaces, but you can also use it to create
curves to rebuild faces. Accepting the results by clicking OK creates a separate 3D sketch for each

spline (unless you have a 3D sketch open before clicking Face Curves, in which case you get a
single 3D sketch with all of the curves). Figure 3.21 shows the original surface and the results of

using face curves on a complex lofted surface.

FIGURE 3.21

Using face curves on a

complex surface

The Extend tool extends a sketch entity up to its next intersection with another sketch entity.

This is not to be confused with the Extend for surface entities. The Power Trim tool mentioned
earlier can be used to extend if you hold down the Shift key while dragging the cursor over
sketch entities to be extended.
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(/

The Split Entities tool splits a sketch entity into two segments, automatically adding appropri-
ate sketch relations and automatically adding colinear, coradial, or tangent relations for lines,
arcs, and splines. You can also delete it later to rejoin the entity back into a single segment. You
should be aware that the rejoining works only if there is a colinear relation between line seg-
ments, a coradial relation between arcs, or a tangent or Equal Curvature relation between splines.
If you split the entity and delete these relations, they cannot be rejoined. Closed-loop entities
require at least two split points.

The Dynamic Mirror command can be used when you preselect a centerline and Dynamic
Mirror is turned on. Any new sketch entity that you draw is automatically mirrored to the other
side of the centerline. The ends of the mirror line have hatch marks on them to remind you that
you have mirroring turned on. A word of caution: If a line is drawn normal to the centerline with
the endpoint on the centerline, it will just be doubled in size.

The Segment tool either places equally spaced sketch points along an existing sketch
entity or breaks the entity up into a number of equal length segments. It acts as a pattern
along a curve. The resulting segment is editable, so you can delete or add points, and they
will autospace dynamically. This is an excellent tool for the Hole Wizard or for Sketch
Driven Patterns.

The Linear Sketch Pattern tool creates a one- or two-directional pattern of sketch entities. You
can define spacing and angles.

The Circular Sketch Pattern tool creates a circular pattern of sketch entities.

BEST PRACTICE

You should use sketch patterns as little as possible. For many of the same reasons that fillet fea-
tures are preferred over sketch fillets, pattern features are preferred over sketch patterns. Sketch
patterns are not as editable or as flexible as feature patterns. They solve slowly, especially when
you pattern many entities. Best practice is to avoid sketch patterns unless there is no alternative.

The Make Path function is intended to help create machine-design motion in sketches, in
particular, cam-type motion. Although it is helpful, you do not need to make a block of the cam
first. You can then right-click the block and select Make Path. A tangent relation to a path enables
a follower to roll around the entire perimeter.

The Modify Sketch tool is one of the few remaining dialog box interfaces in the software
that doesn’t use the PropertyManager. It enables you to move, rotate, and scale the sketch, as
well as mirror about a horizontal or vertical axis or about both axes simultaneously. Figure 3.22
shows the interface, which consists of a dialog box, a special origin-like symbol, and a context-
sensitive cursor.

Both the left and right mouse buttons have special functions, which change when the cursor is
moved over the three knots on the special Modify Sketch origin. The RMB enables you to mirror
or rotate the sketch, and the left mouse button (LMB) enables you to move the origin or move
the sketch.

This function has some limitations when you use it with sketches that have external relations.
Certain functions may be disabled or a warning message may appear, saying that you need to
remove external relations to get a particular function to work correctly. It is best used for control-
ling the orientation of Derived Sketches that by default cannot have internal relations.

The No Solve Move option enables the moving of sketch entities without solving any
relations in the sketch. If you select this option and you move an entity with relations that
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would otherwise not allow it to be dragged (such as a collinear relation), you are prompted with
a choice to delete the existing relation and continue or copy the entity without the relation.

A sketch picture is a picture that is placed in the sketch, lies on the sketch plane, and is listed in
the FeatureManager indented under the sketch as a child. The sketch picture may be suppressed
independently from the rest of the sketch, and when the sketch is hidden, the picture is not
visible. You can easily move, resize, and rotate sketch pictures, as well as apply a transparent
background color to them. Sketch pictures are usually used for tracing over or as a planar decal
without the need for rendering.

The Equation Driven Curve tool creates a sketch spline driven by either an explicit or a
parametric equation, as shown in Figure 3.23. An explicit equation is in the form y = f(x), while
a parametric equation uses multiple equations driven by a common parameter value of the
form, such as

x = cos(t)
y = sin(t)
0>t>pi

where t is a number in radians.

The result is a proportional spline in a sketch, not a curve feature as the name suggests. You
can drag the spline itself, or its endpoints, in 2D or 3D, and SolidWorks calculates the new
transformation. To reposition a sketch, use sketch relations and dimensions.

If you start an equation-driven curve in a 2D sketch, you get the form for a 2D curve equation.
If you start in a 3D sketch, you get the form for a 3D curve. After these splines are created, you
cannot remove the relation to the equation and manually edit the spline; they are tied to the
equation until you delete the entire spline.

One way to get around this limitation would be to create an equation-driven curve in one
sketch and then open another sketch and use Convert Entities to copy the spline, delete the On
Edge relation, and use Simplify Spline to add control points to it. This is a technique commonly
used with other types of curves; it does not enable you to update the overall size or shape of the
spline through the equation, but you can manually adjust sections of a curve originally created
from equations. Examples of where this might be useful would be a lead-in or lead-out on a cut
thread, a special attachment loop in the middle of a spring, or a flare around the edge of a lens or
reflector dish for mounting.

81



82 |CHAPTER3 WORKING WITH SKETCHES AND REFERENCE GEOMETRY
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The Straight Slot and Curved Slot tools draw slots of a given width and length with full
rounds on the ends. All the Slot sketch entities can be seen in the PropertyManager shown in

Figure 3.24. If you need to draw a composite slot or a slot with multiple entities, you need to use
the bidirectional sketch offset with capped ends mentioned earlier.

FIGURE 3.24
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Driving Sketches with Smart Dimensions

All dimensions in SolidWorks sketches can be created with a single tool, the Smart Dimension.
Dimensions are half of what you can use to drive changes in sketches with precision, the other
half being sketch relations.

The Smart Dimension tool can be used to create length, point to point, aligned, angular, radial,
diameter, arc length dimensions, and even reference (nondriving) dimensions.

By default, SolidWorks installs with a setting called Instant2D activated. Instant2D is rela-
tively new and has some advantages and disadvantages. One of the advantages is that it enables
you to drag dimensions by the handle as shown in Figure 3.25. One disadvantage is that it
disables the Modify box, shown in Figure 3.26.

Dragging a dimension

FIGURE 3.25 *

with Instant2D activated

63.87
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SolidWorks sometimes forces you to use new functionality by activating it by default, instead
of allowing you to decide. This is done in order for you to quickly discover new functionality.
Then if you like the new functionality, you keep it; if not, you can turn it off. The downside can
be a bit of initial confusion. I think in the case of Instant2D, they should allow users to turn it on
if they want. The new setting adds ease-of-use at the expense of precision dimensions. If you
wanted to drag type precision, you wouldn’t have put a dimension on it. You can turn off
Instant2D by deselecting the Instant2D tool on the Sketch CommandManager tab. The rest of the
book will assume that this option is turned off.

When you place a dimension you just created, SolidWorks automatically puts you into the
Modify box, which enables you to edit the dimension in several ways. You can disable this option
by removing the check from the setting at Tools > Options > General > Input Dimension Value.
With that setting off, when you place the dimension, it will not display the Modify box.

You can change Smart Dimension values in several ways using the Modify box, shown in
Figure 3.25. The most direct method is to key in a value such as 4.052. The software assumes
document units unless you key in something specific. You can also key in an expression, even
with mixed units, such as 8.5 mm/2+.125 or 25.4+.625 in. You can also key in negative dimen-
sions, which function the same as the Change Dimension Direction button in the Modify box.

To the right of the drop-down arrow is a pair of up and down spin arrows that enable you
to change the value in the Modify box by a set increment amount. You set the increment in
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Using the Modify

FIGURE 3.26 *
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Tools > Options > System Options > Spin Box Increments. You can also store multiple incre-
ment values within the Increment Value icon on the Modify box.

The final way to change the value in the Modify box is by using the wheel underneath the
value field. The wheel uses the default increment value. Pressing Ctrl while using the wheel
multiplies the increment by 10, and pressing Alt while using the wheel divides the increment by
10. Once you have created the dimension and determined that you do not need the Modify box
again, you can click on an existing dimension, and the Modify box will reappear with the value
of the new selected dimension. Sketch dimensions can be displayed in dual units (for example,
inch and millimeter), using the Dual Dimension panel of the Dimension PropertyManager.
Here’s a look at the Dimension Properties interface (Figure 3.27).

Radial: You create the dimension by selecting an arc and placing the dimension. If you want a
radial dimension of a complete circle, you must right-click the dimension after you create it,
select Display Options, and select the Display As Radius/Display As Diameter toggle.
Alternatively, you could use the Radius or Diameter leader display options on the Leaders tab
of the Dimension PropertyManager.

Diameter: You can create the dimension by selecting a complete circle and placing the
dimension. If you want a diameter dimension for an arc, use the RMB menu or Dimension
Properties dialog box and select the Diameter Dimension option.

NOTE Along with the Radial and Diameter dimensions, you may also want to dimension between
arcs or circles, from tangent or nearest points. To do this, press the Shift key and select the Smart
Dimension tool to select the arcs near the tangent points. Alternatively, to change a dimension from
a center-to-center dimension to a max-to-max dimension, you can drag dimension attachment points

to tangent points or use the dimension properties.
Angle: You can create the angle dimension in two ways. If the angle to be driven is between

two straight lines, simply select the two straight lines and place the dimension. If you are
creating an included angle dimension for an arc where there are not necessarily any straight
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lines drawn, then make the Smart Dimension tool active, select the vertex of the angle, and
then select the two outlying points, as shown in Figure 3.28. You can also create an angle
dimension between a line and an orthogonal direction. To do this, with the Smart Dimension
tool active, click on the line, and then click on the end point of a line. Four orthogonal arrows
will appear. Click one of these arrows as a direction to complete the angle dimension.

FIGURE 3.28
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Arc Length: You can create the dimension by selecting an arc and its endpoints with the Smart
Dimension tool. This displays the actual linear length of the arc.
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Using Tools on the Dimensions/Relations Toolbar

The Dimensions/Relations toolbar has a few tools that you have already seen; but as the name
suggests, it also contains tools that help you to either create or investigate dimensions and sketch
relations. Figure 3.29 shows the default toolbar; but in the following pages, you’ll look at all the
tools available at Tools » Customize » Commands > Dimensions/Relations. These tools are
available on the Dimensions/Relations toolbar:

FIGURE 3.29
The Dimensions/
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Smart Dimension: Lets you dimension the sketch entity and combines several dimensioning
methods into a single tool, such as horizontal, vertical, aligned, radial, diameter, and so on.

Auto Insert Dimension: Automatically adds dimensions appropriate for selected
sketch entities.

Horizontal Dimension: Applies a dimension to a sketch entity that drives the horizontal
distance between the selected points or parallel lines.

Vertical Dimension: Works like a horizontal dimension but vertically.

Baseline Dimensions: Creates dimensions in drawing documents only. The Baseline Dimensions
tool is different from most of the dimension tools that you find on the Dimensions/Relations
toolbar in that it can create driven dimensions on view geometry or driving dimensions on
sketch geometry in a drawing, but the dimensions cannot be used on sketch geometry in parts.
Baseline dimensions originate from a single reference; then as you select additional references,
their dimensions are stacked, as shown in Figure 3.30.

OO O

Ordinate Dimensions: Drives dimensions where a set of ordinate dimensions originate from
a common zero point. To use these dimensions, simply click a zero location, place the zero
dimension, and then click additional points. The dimensions are placed and are automatically
aligned to the rest of the dimensions.



DRIVING SKETCHES WITH SMART DIMENSIONS | 87

NOTE If aline is not selected as the zero reference entity, the Ordinate Dimension feature defaults to
a horizontal ordinate.

¢ You can remove ordinate dimensions from the common alignment by right-clicking the
dimension and selecting Break Alignment. Ordinate dimensions jog automatically if
SolidWorks senses that the dimensions are getting too close to one another. You can also
jog them manually. After you create the Ordinate Dimension set, you can add to it by
accessing the Add To Ordinate command through the RMB menu. All the options for
ordinate dimensions are shown in Figure 3.31.

¢ Not all the listed options are available in the model sketch environment; some are avail-
able only in drawings.

FIGURE 3.31
Options for base-
line dimension

Dimension (D7@Sketch1@Part1.5LDPRT)
Link Values
Reverse Direction
Driven

Mark For Drawing

Add To Ordinate

Display Optil}\?s 3 log
Break Alignment Re-Jog Ordinate
Show Alignment Show Parentheses
Annotations 3 Show as Inspection
T
wﬁ' A chamfer dimension is another type of dimension that is only driven and only applied in

drawing documents. It works by first selecting the chamfered edge and then selecting the angle
reference edge.

However, there is a Sketch Chamfer tool that adds dimensions to the chamfer in the sketch
when the chamfer is created.
C The Automatic Relations toggle enables and disables the automatic creation of sketch relations

while sketching. This toggle is also available through Tools > Sketch Settings > Automatic

Relations. Automatic relations help you to create intelligent sketches with less manual interven-
tion. Although using them takes a little practice, it is well worth the effort.

CAUTION Aswith any automatic function, there are times when automatic relations will do things
that you do not expect or want. While you are sketching, I recommend that you watch the cursor and
the relations that it automatically applies.

While sketching, symbols appear on the cursor to show that a relation will automatically be
created. These symbols have a yellow background and apply horizontal, vertical, coincident,
tangent, parallel, and perpendicular relations. Figure 3.32 shows two situations where automatic
relations are applied: a horizontal and a tangent relation.

C Fully Define Sketch is a tool that can add relations and dimensions to lock down any open
degrees of freedom in a sketch when the option for All Entitities In Sketch is enabled. This sounds
like a better idea than it is. Although you can control how the sketch and even portions of the
sketch are defined, this tool is used mainly to overcome a fear of underdefined sketches. Sketches
that are just randomly fully defined are worse to work with than undefined sketches. You are
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FIGURE 3.32
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better off to fully define a sketch manually. Although it may seem odd for someone in my position
to say this, you are better off with a fully undefined sketch than a large sketch that is fully defined
with random dimensions in it. (See Figure 3.33.) Troubleshooting something that goes wrong with
a very large sketch can take a lot of time, while a fully undefined sketch can never go wrong
unless you move it with the cursor. If your sketch is large, consider breaking it up in multiple
features. If it has a lot of small entities, try using sketch relations, which are more flexible than

dimensions.
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INFERENCING IN SKETCH

J:L The Add Relations tool is for those times when you have to manually add relations to sketch
elements. It is generally better to use the Automatic Sketch Relations tool; but when you're
editing, this is not always possible. (See Figure 3.34.) Select the sketch entity and pick

the relation.

FIGURE 3.34
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Automatic Relations is a setting that is turned on by default. When you are sketching, it
displays relations that are suggested by the sketch (such as tangent or coincident) as small yellow
icons attached to the cursor (inferences are separate and are covered in the next section of this
chapter) and adds those relations to the current sketch entity. Some relations displayed as small
icons on the cursor do not have the yellow background, and they are not added as relations to
the sketch. Figure 3.32 shows examples of automatic relations being added as sketch entities
are created.

The Scan Equal tool searches an active drawing sketch for entities of equal length or radius. It
will then set Equal sketch relations for those entities.

Again, the Isolate Changed Dimensions tool is used only in drawings. This identifies any
dimensions that have changed since the drawing was last saved. This will be covered in a
later chapter.

Inferencing in Sketch

Inferencing refers to the blue dotted lines that display in Sketch mode when the cursor aligns with
endpoints, centerpoints, or the origin. Inferencing creates sketch relations only when the symbol
shown on the sketch cursor has a yellow background.
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When the cursor displays a small sketch-relation symbol with a yellow background, an
automatic relation will be applied. If the relation symbol has a white background, the relation is
inferenced, but not applied, as an actual sketch relation. The symbols with the blue background
are relations that have been applied to existing sketch entities. Be aware that differences in
versions and differences in color schemes can cause these colors to be different on your system.
(The color may be green in SolidWorks 2008 or later. The symbols look the same, regardless of
background color.)

Table 3.1 shows the symbols for the various inferences, automatic relation cursors, and
applied sketch relations. The difference among the three types is simply the background colors:
white, yellow, and blue, respectively.

TABLE 3.1: Symbols and Their Meanings
SYMBOL MEANING SYMBOL MEANING SYMBOL MEANING
o, Along X . Along Y 2 Along Z
ﬂ At Intersection . Coincident . Collinear
of Two Faces

. Concentric . Coradial . Equal

. Equal Curvature . Fix . Horizontal

ﬂ Intersection . Midpoint III] Offset
. On Edge . On Surface . Parallel

. Perpendicular . Pierce Symmetric
. Tangent . Vertical : Display/

Lo Display/Delete. Delete Relations

E Fully Define Sketch

Exploring Sketch Settings

In addition to sketch tools, sketch settings also control sketches. Sketch settings are found in two
locations. The first location is at Tools > Options > Sketch. In this chapter, I cover the settings
found at the second location, Tools > Sketch Settings, shown in Figure 3.35. These settings mainly
affect sketch relations.

Automatic Relations: As described earlier, it is on by default. It adds relations to newly
sketched entities.

Automatic Solve: It is also turned on by default. As you make changes to a sketch by adding
relations or changing dimensions, SolidWorks automatically and immediately updates the
sketch to reflect the changes. When the Automatic Solve setting is turned off, these changes
are deferred until you exit the sketch or turn the Automatic Solve setting back on. The setting
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FIGURE 3.35
Tools > Sketch Settings

Automatic Relations
Automatic Solve

Enable Snapping
Shaded Sketch Contours

No Solve Move

Detach Segment on Drag
Override Dims on Drag/Move

Pen Settings 3

Customize Menu

can be useful to prevent intermediate solutions (for example, when half of the changes are
made) that may cause problems with the sketch. It can also be useful when you are confident
that the outcome will be correct. It is a rarely used option, and you could probably exist just
fine without even knowing this option was there at all.

If you import a large drawing from the DXF or DWG format, these drawings import as sketch
entities into either a SolidWorks sketch or a drawing. SolidWorks may automatically turn off
the Automatic Solve setting for performance (speed) reasons on files of this type.

Enable Snapping: It is also turned on by default. It enables the cursor to snap to the end-
points of existing sketch entities to help you make cleaner sketches. When you turn this
setting off, Automatic Relations is also disabled (although the icon for the setting remains
depressed; Automatic Relations are not created). Holding down the Ctrl key while sketching
disables snapping. Holding down the Ctrl key while dragging sketch entities functions like
copying sketch geometry. No Solve Move is discussed in the Sketch toolbar section.

Shaded Sketch Contours: As described earlier, it is turned on by default. It adds shading
inside of enclosed sketch areas. It enables one-click selection of all entities in the contour and
moving of the contour just by dragging the shaded area.

No Solve Move: It is also turned off by default. This rarely used option is mainly useful
when moving entities within a large sketch where there are a lot of existing relations that
prevent moving.

Detach Segment On Drag: This setting is also turned off by default. When you turn it on,
the Detach Segment on Drag feature enables you to pull a single sketch element away from a
chain of elements. For example, if you had a rectangle and you wanted to detach one of the
lines from the rest of the rectangle without using this setting, you would have to draw extra
geometry and then trim and delete lines in order to release the endpoints.

Override Dims On Drag: This setting is off by default. When you turn it on, it enables you to
drag fully defined sketch geometry, and the dimensions update to match the dragged size.
This is another setting that you should use sparingly. It can be useful for doing concept work,
but you should leave it off when working with production data for obvious reasons.

Pen Settings: These are covered later in this chapter in the section “Sketching with Touch
Interface.”

NOTE Combining Override Dims On Drag with Instant3D can be very handy for concept work, ena-
bling you to drag sketches, model faces, and edges easily.
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Using Sketch Blocks

Sketch blocks are collections of sketch entities that can be treated as a single entity and can be
reused within a single document or shared between documents. You can use sketch blocks in
parts, assemblies, and drawings. To create a sketch block, select a group of sketch entities and
click the Make Block button on the Blocks toolbar, or select Tools > Blocks > Make. Preselection is
not necessary; you also can select the entities after you invoke the command.

Blocks may be internal to a particular document, or they may be saved as an external file. The
externally saved block may be linked to each document where it is used so that if the block is
changed, it updates in the documents where it is used.

You can use blocks in conjunction with the Make Path function mentioned earlier in this
chapter to create functional layouts for mechanisms. You also can use blocks in an assembly to
build parts in context.

Refer to Chapter 16, “Working with Assembly Sketches and Layouts,” for a more in-depth
examination of the assemblies aspects of blocks in SolidWorks and to Chapter 26, “Using
Annotations and Symbols,” for the use of blocks in 2D drawings.

These tools are available on the Blocks toolbar:

Make Block: Creates a sketch block from selected sketch entities. You can position a manipu-
lator to denote the insertion point for the block. Blocks may attach at any entity endpoint, but
the insertion point follows the cursor.

Edit Block: Enables you to edit an existing block as if it were a regular sketch.

Insert Block: Enables you to select from a list of open blocks or browse to a location where
blocks are stored. You can edit the insertion point by using the Edit Block function.

Add/Remove: Enables you to add or remove sketch entities from the block without deleting
them from the sketch while editing a block.

Rebuild Block: Allows changes to a block to be reflected in any external relations without
exiting the block. For example, if you have a block in a sketch and a sketch line is coincident to
one of the endpoints in the block, you may edit the block such that the referenced endpoint
moves. As a result, the line in the sketch will not move until you exit the block or use the
Rebuild Block function.

Save Block/Save Sketch As Block: Saves a selected block to an external file (with the
* . s1db1lk extension) or saves the selected sketch as a block.

Explode Block: Removes all the sketch entities from a block and brings them into the cur-
rent sketch.

Belt/Chain: Enables you to make a belt or chain around a set of pulleys. Each pulley must
be a block. After activating the command (by right-clicking a sketch or block), you can select
each pulley and use the arrow on the pulley to switch the side of the pulley to which the
belt goes. You can also compensate for the thickness of the belt (this is important when both
sides of the belt are in contact with pulleys) and drive the pulley arrangement using the
length of the belt.
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Working with Reference Geometry

Reference geometry in SolidWorks is used to help establish locations for geometry that you can’t
physically touch, such as planes, axes, coordinate systems, and points. (See Figure 3.36.) You
often use reference geometry to establish a characteristic of the finished solid model before the
model is created or to include an item that you may want to mate another part to in an assembly
later. Mate references are also classified as reference geometry and are dealt with in the assem-
bly chapters.

FIGURE 3.36
The Reference Reference Geometry n

Geometry toolbar p S
g r e SEd

The importance of working with reference geometry becomes obvious in situations where you
need to create geometry that doesn’t line up with the standard planes. You might use planes to
represent faces and axes to represent the centers of holes. Axes are often used to establish a
direction, such as in plastic parts where, because of draft, you never truly have any vertical
edges; an axis is frequently used to establish the direction of pull for the mold.

Coordinate systems come in handy, especially when translating a part from one system to
another for the purpose of machining or some type of analysis. SolidWorks users usually model
in such a way that the modeling work is made simpler by the choice of how the part origin is
positioned relative to features of the part; however, rapid prototyping, machining, mold build-
ing, and sheet metal manufacturing applications may have different requirements. As a part
modeler, you cannot account for the needs of all downstream applications with your initial
choice of origin placement, but you can always create a reference coordinate system for those
downstream applications to use. Coordinate systems are fantastic as input for mates (especially
for defining smart mates). They have the same functionality as origins, offering the option to
define the location and the orientation with only one mate.

Creating Planes

Planes are the most commonly used type of reference geometry because they are used for
sketching and cutting, as extrude end conditions, and more. The Plane PropertyManager is
shown in Figure 3.37. You start by selecting model items (faces, edges, points, vertices, or other
sketch or reference geometry) that you want to have some relationship to the new plane. The
new plane uses constraints like sketch relations from the selected references. For example, in
Figure 3.37, the new plane is tangent to the selected First Reference cylindrical face and at an
angle to the selected Second Reference of a plane.

The good news about this method is that there are a lot more options for creating planes than
in the previous method; the bad news is that the options are not all spelled out anywhere. You
have to make a selection before it shows you the available constraints. You may need to experi-
ment with this interface to see what works best for the type of modeling you do.

One of the options in the Plane PropertyManager is Flip Normal. This option has little applica-
tion until you start getting into heavy parametric editing. Keep the existence of this option in the
back of your head, because you will someday run into a situation where you make a change and a
sketch or feature flips in an unexpected way. That will be the time to use this option.
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FIGURE 3.37
Creating a new plane

and constraints

- + € Chapter 3 Reference Geo.. & &
gERE B
f ¢ selocti ok Sensors
rom a set of selections 1 Plone ®| * [ Avmetatons
53 v [E) Equations
- —
5 Material <not specifi..
Message - [ Frontxr
Fully defined [[TTend]
First Reference ~ (1] RightvZ
[ pig
0 [Jrecears L, oigin
b @D Revoloet
(& rangent b Extruded
[ Flip offset b Extrude?
Second Reference ~ ' @ Eitruded
Tt B CirPattemn]
[ I b (@ DeleteFace!
X Parallel 1] Planet
| | perpendicular B suraceCut
b Etruded
A, | Coincident
v Rt
[ 7o00deg = b ] Extruded
] Flip offset v ] Etrudes
AL } v Extrude?
&0 — T3l wlirrort
b [ Extrudes
=| Mid Plane b ) Extruded
Third Reference - v (& 1/BNPT Tapped Hole1
© [ Fillets
Options ~ [P Filler2
I Fiip normal (D Fillets
D i

A newer function of the Plane feature is that it will allow you to make a plane parallel to the
display at a selected point. This is a somewhat hidden functionality. To enable it, you have to
start the Plane command; and select a point, origin, or vertex; and then click the Parallel To
Screen option.

TIP Because most planes are created from an existing plane or planar face, you should customize the
context toolbar to include the Plane command. Then, when you select a face from the graphic area,
you will find the Plane command next to your cursor.

Working with Axes

You can use axes to create pivot points in a part where you do not have any hole-type geometry
for mating with other parts. You can also use them as a direction of pull for plastic parts or
molds. Axes are frequently used to establish direction for rotation, draft, or a number of other
things. Figure 3.38 shows that the first three features in a plastic part are axes established from
the standard planes.

Consider using axes set up in this way as standard features in your template files (X-, Y-, and
Z-direction axes). They can be effective in assemblies for moving parts in orthogonal directions
and in parts for pattern or draft directions.

Using Coordinate Systems

Coordinate systems in SolidWorks are primarily used for import and export, but they also can
be used for mates, mass properties, and other purposes. Coordinate systems are usually
positioned by selecting a point or a set of edges to determine direction. Figure 3.39 shows the
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PropertyManager for assigning a coordinate system, along with the Export Options dialog box,
which you can access from the Save As dialog box when the Files of Type dropdown is set to an
export format.

To use the coordinate system when saving as a translated file type such as IGES or Parasolid,
click the Options button (in the Save As dialog box, after setting the translation file type). At the
bottom of the Export Options dialog box, a selection box for the Output coordinate system appears.

To use the coordinate system with mass properties, choose Tools > Evaluate > Mass Properties
from the menu, and then select the Output coordinate system, as shown in Figure 3.40.

FIGURE 3.40
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Using Points as Reference Geometry

The Point reference geometry feature is infrequently used; however, in some situations, nothing
else does the job quite as well. This is not the same as a sketch point and does not require a
sketch to be open. It is just a reference point that you can place in space. Figure 3.41 shows the
PropertyManager for the Point reference geometry feature. An excellent use of this capability is
to mark the center of a face.

The reference point and the sketch point are somewhat different in that you can use sketch
points in 2D or 3D sketches, and they can be dragged or driven by dimensions and sketch relations.

Sketching with Touch Interface

Sketching with the touch interface is limited to hardware specifically developed for that purpose.
You can use small Wacom tablets for the touch input, but I'm referring to large touch monitors in
this case. In some cases, the touch display is able to distinguish between the use of a pen (stylus) for
input and your finger. Typically, fingers are used for manipulating the view, rotation, and zoom.
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The pen is used for tasks that require more precision, such as selecting interface elements

and sketching.

You can find special settings for Touch interface in Tools > Options > Touch, as shown in

Figure 3.42.

FIGURE 3.42
The settings for
Touch interface

System Options - Touch

System Options Document Properties

General
Drawings

- Display Style

Area Hatch/Fill

- Perfermance
Colors
Sketch

- Relations/Snaps
Display
Selection
Performance
Assemblies
External References
Default Templates
File Locations
FestureManager
Spin Box Increments
View
Backup/Recover
Touch

Touch Mode
Change where touch menus appear on the screen by indicating which hand you use for writing.
(@) Right Hand
Menus appear on the left side of the window.

() Left Hand
Menus appear on the right side of the window,

Beyond the settings, SolidWorks also makes available a Sketch Ink toolbar specifically for use
with the pen. This is automatically available on the CommandManager of a touch-enabled
device. The Sketch Ink toolbar is shown in Figure 3.43.

The Pen tool enables you to change color and width of what is shown on the screen. If you
have Auto Sketch Entities turned on, it will take your pen sketch and convert it into lines or arcs,
and add an entry called Pen Sketch under the regular sketch feature in the FeatureManager. If
Auto Sketch Entities is not turned on, then you will get on the screen whatever squiggle you
entered with your pen. The Pen Sketch and squiggle are shown in Figure 3.44.
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FIGURE 3.43
The Sketch Ink tab of the
CommandManager

FIGURE 3.44
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the screen
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Tutorial: Learning to Use Sketch Relations

This tutorial makes sure that you get to know all the major functions in SolidWorks sketches.

Almost every part that you build will start with a sketch, so this is a skill worth mastering.
Follow these steps to learn about sketch relations:
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ON THE WEBSITE

The BibleInchTemplate.prtdot template used in this tutorial is in the Chapter 3 folder in the
materials you can download for this chapter from the Wiley website.

. Create a folder on your hard drive called D:\Library\BibleTemplates. You can put it

where you like, but I recommend a nonsystem drive in a location where it is unlikely to be
overwritten or lost.

. Go to Tools > Options > File Locations and add a path to the Document Templates list for

the location of the templates folder you just created.

. Click the New icon. In the New SolidWorks Document dialog box, make sure you see the

Advanced interface. (The button in the lower-left corner should say Novice. If the button
is labeled Advanced, click it to open the Advanced interface.) Click the tab in the interface
that has the name of the new templates folder you just created.

Open a new part using the template you just set up.

5. If the planes are showing in the graphics window, turn them off. Go to View > Hide/

Show > Planes. This turns off all planes. If you want to turn off a single plane, right-click
the plane in the graphics window or in the FeatureManager, and select Hide.

Select the Front plane in the FeatureManager, and click the Sketch button on the Sketch tab
of the CommandManager (or right-click the plane and select Insert Sketch). Click the Line
tool from the Sketch tab of the CommandManager.

7. Move the cursor near the origin untill the yellow Coincident symbol appears.

8. Draw a line horizontal from the origin. Remember that you can sketch the line in two

10.

ways: Click+click or click-and-drag. Make sure that the line snaps to the horizontal and
that there is a yellow Horizontal relation symbol. The PropertyManager for the line should
show that the line has a Horizontal relation. Also notice that the line is black, but the free
endpoint is blue (after you press Esc to clear the tool). This means that the line is fully
defined except for its length. You can test this by dragging the blue endpoint.

. Click the Smart Dimension tool on the Sketch toolbar; use it to click the line that you just

drew, and place the dimension. If you are prompted for a dimension, type 1.000. If not,
then double-click the dimension; the Modify dialog box will appear, enabling you to
change the dimension. The setting to prompt for a dimension is found at Tools > Options
> General, Input Dimension Value.

Draw two more lines to create a right triangle to look like Figure 3.45. If the sketch
relations symbols do not show in the display, turn them on by clicking View > Sketch
Relations. You may want to set up a hotkey for this, because sketch relations are useful
but often get in the way. When you enclose the triangular area, SolidWorks will shade
the triangle if the Shade Sketch Contours is active. This tool is by default on the right
end of the Sketch CommandManager tab.
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FIGURE 3.45
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Drag the blue endpoint of the triangle. Dragging endpoints is the most direct way to
change the geometry. Dragging the line directly will also work by causing the angle of the
line to change. The sketch leaves a ghost when dragging so that you can see where you
started. Note that the setting for leaving a ghost when dragging a sketch is found at Tools
> Options > Sketch, Ghost Image On Drag.

Click the Smart Dimension tool, and then click the horizontal line and the angled line. This
produces an angle dimension. Place the angle dimension and give it a value of 30 degrees.

Click the Sketch Fillet tool, set the radius value to 0.10 inches, and click each of the three
corner points. Press OK in the PropertyManager, OK in the RMB menu, or Enter on the
keyboard to accept the preview of the fillet. SolidWorks creates a virtual sharp at the ends
of the horizontal line to preserve the connection points for the 1.00 dimension. Figure 3.46
shows the sketch at this point. You may now want to turn off the Sketch Relations display
because the screen is getting pretty busy. You can find this setting at View > Hide/Show >
Sketch Relations, or use the Heads Up View toolbar for quicker access.

Draw a line starting from the midpoint of the angled line. The midpoint should highlight
when you move the cursor close to it. Draw the line perpendicular to the angled line. A
dotted yellow line appears, showing where the perpendicular lies. When you follow this
line, the yellow perpendicular symbol appears on the cursor. Make this line approximately
0.12 inches long. Feedback on the cursor also shows the length of the line as you draw it.

Draw two more lines ending at the endpoint of the sketch fillet, as shown in Figure 3.47.
Use the Inferencing lines to line up the second angled line with the end of the arc.

. Click the Trim tool from the Sketch toolbar. Make sure that the Trim option is set to

Closest. Click the angled line of the triangle between the two lines sketched in step 15.
This trims out that section and makes the sketch a single closed loop. A warning may
appear because you have a midpoint relation to the line being trimmed; you no longer
want this relation, but you want the lines to intersect at their endpoints. Select Yes at
the prompt.

Add a sketch relation. Click on one of the two parallel lines and then Ctrl+click on the
other. Now click Equal in the PropertyManager to make these two lines equal length.
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Add some lines.
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<\ 18. Add smart dimensions. Click the Smart Dimension tool and add an aligned dimension to
one of the lines just set as Equal. Make this line 0.125 inches. This turns one line black, so
add a dimension to the black line to make it 0.25 inches. The result is a fully defined sketch,
as shown in Figure 3.48.

FIGURE 3.48
A fully defined sketch )\
30.00°
i _/ \
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D 19. Save the part with the name Sketch Relations Tutoriall.sldprt. Close the part.

Tutorial: Using Blocks and Belts

Sometimes I am amazed at the things that can be done in SolidWorks, even with fairly simple
tools. This is one of those times. If you design machines, this tutorial has some extra meaning for
you. Blocks and Belts are a valuable toolset for various situations. Follow these steps to learn
about using Blocks and Belts.

[ New.. 1. Open a new part with inches as the units.

C 2. Draw and dimension a sketch on the Front plane connected to the origin as shown in
Figure 3.49. Exit the sketch and rename it Layout Sketch, either by clicking twice (slow
double-click) on the name of the sketch in the FeatureManager or by selecting it and
pressing F2.

FIGURE 3.49
The layout sketch
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. Exit the sketch by clicking the Confirmation Corner Exit Sketch symbol in the upper-right

corner of the graphics window (not the red X).

Open a second sketch on the Front plane and draw a circle with a 6-inch diameter
centered on the origin. This needs to be a second sketch, not just reopening the first sketch.

5. Inside the circle, draw a Centerpoint rectangle centered on the origin.

Select two adjacent sides of the rectangle and make an Equal sketch relation between
them. This makes the rectangle into a square, but still doesn’t define its size.

. Click the Smart Dimension tool and apply a 1.000-inch dimension to one side of the

square. Turn off the Smart Dimension tool by clicking it again on the toolbar or
pressing Esc.

If the Blocks toolbar is not active, activate it and then select Make Block. You also can
access this command through Tools > Block > Make.

. Window select the circle and the square by clicking and dragging a box that includes all

the items in the sketch. The PropertyManager to the left displays a circle and six lines that
are to be made into a block. SolidWorks by default forces you into using the Lasso
selection. You can switch to Box selection in the Tools menu, or in Tools > Options >
Selection, Box. This would be a good tool to put on a hotkey.

Expand the Insertion Point panel in the PropertyManager. This causes a blue manipulator
origin to appear in the graphics window. Click this origin and drag it onto the center of
the circle. Then click the green checkmark icon to exit the Make Block dialog box, as
shown in Figure 3.50.
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[ Layout Sketch Block
Drag Manipulator on-screen to position
insertion point.

The items in the block now turn gray. Click anywhere on the block and drag it out of the
way. Then drag the center of the circle and drop it on the part origin.

Click the Insert Block tool on the Blocks toolbar. There should be only a single block
named Block1 in the Open Blocks box. Place the block on the opposite sharp corner of the
layout sketch.
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13. Create another block that is identical to the first one, except with a diameter of 3 inches
instead of 6 inches. You can do this by selecting the first block, clicking Edit Block from the
toolbar, and copying (Window select and Ctrl+C). Then exit the Edit Block and paste
(Ctrl+V) in the regular sketch. Make sure to also change the insertion point for this second
block to the center of the circle

14. Insert a second instance of this second block, and make sure that both of them have the
center of the circle at the two remaining intersection points of the four-sided shape of
the layout sketch. At this point, your sketch should look like Figure 3.51.

FIGURE 3.51
Block placement

@)

= 15. Click the Belt/Chain tool on the Blocks toolbar. Select the blocks in counterclockwise

(Ve order, starting at the top pulley so that they go in the Belt Members selection box, as
shown in Figure 3.52. On the last pulley, you will have to click the Flip Bent Side arrow to
get the belt to go the correct way around the pulley. If this doesn’t work for you, clear the
selection box and try to select the pulleys in a different order. Press F on the keyboard to
get the display to Zoom to Fit.

16. Make sure that the Engage Belt option is selected. This will enable you to make the pulleys
move in the same way that they would in a real belt-driven mechanism. This will help you
calculate the required length of the belt.

17. Click the Use Belt Thickness option and assign 0.25 inches for the thickness. The belt
should be offset from the pulleys.

18. Click the green checkmark icon.

19. Click and drag one of the corners of the square in a pulley. All the pulleys should turn as if
they were real mechanisms. The ratios are also observed because the small pulleys rotate
faster than the large ones.

D 20. Save this part as Blocks and Belts Tutorial.sldprt. Exit the part.



FIGURE 3.52
Belt placement
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Tutorial: Creating Reference Geometry

This tutorial steps you through creating reference geometry on an existing part in preparation for
locating 3D features.

ON THE WEBSITE

The Chapter 3 Reference Geometry- start.SLDPRT file used in this tutorial is in the Chapter 3
folder in the data downloaded from the Wiley website.

. Open the file from the download materials in the Chapter 3 folder called Chapter 3

Reference Geometry - start.sldprt.

In the FeatureManager filter, type planel. Double-click Planel in the FeatureManager.
Double-click the 3.25-inch dimension on the screen and change it to 3.35 inches. Click the
rebuild symbol (traffic light) and watch the update. This plane locates the mounting base
of the part. Click the green check mark to accept the change and exit the Modify box.

. Click the Axis toolbar button from the Reference Geometry flyout menu (on the Features

tab of the CommandManager in a default install).

Select the inside face of a hole on the part, as shown in Figure 3.53. This creates an axis on
the centerline of the hole. You should note that temporary axes are automatically created
for all cylindrical faces, but making a true axis feature helps this one stand out as different
from the other holes on the part.

The selection of the Cylindrical /Conical Face option is automatically activated by your
selection of the cylindrical face of the hole. Accept the result with the green check mark
when the selections and settings are complete.
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5. Click the Plane toolbar button from the Reference Geometry flyout on the Features tab of
'. the CommandManager.

6. Select the large cylindrical face of the part as the First Reference and the axis you just
created as the Second Reference. (Go to View > Hide/Show > Axes if you cannot see the
axis.) Make sure the First Reference uses the Tangent constraint and the Second Reference
uses the Coincident constraint. This makes a plane tangent to the main cylinder in the part
that goes through the patterned hole, as shown in Figure 3.54.
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Click the green check mark to accept the result.
C 7. Open a new sketch on the new plane.

8. Click the View » Hide/Show menu and activate the Temporary Axes option. You should
K now see blue axes (without names) appear along the centerlines of every conical or
cylindrical face on the model (except for faces created by fillet or chamfer features).

@ @ NOTE The View Orientation toolbar appears when you press the spacebar; it is also available from
the Heads Up View toolbar. You can also use Ctrl+spacebar to access the View Selector cube. If the
view is already normal to the selected plane and you double-click Normal To, the view switches to 180
degrees opposite. The setting to auto-rotate the view normal to the sketch plane when a new sketch is
opened is located at Tools > Options > Sketch.

9. Select the sketch plane either from the graphics window or the FeatureManager. Press the
spacebar on the keyboard and double-click Normal To. You can click the pushpin to keep
this box available. There are other ways to access this command, but this is the method
that works regardless of your interface setup.

i,

E 10. Use the Centerpoint Rectangle to create a rectangle centered around the temporary axis of
the large cylindrical face. Make sure that the centerpoint, which is the first click you make,
picks up a coincident automatic relation with the temporary axis. Make sure the second
click to place the corner of the rectangle does not pick up any automatic relations. This is
shown in Figure 3.55.

FIGURE 3.55
Creating a rectangle
centered on the
temporary axis

|
%= 1871,y = 1,499

You can tell if any relations have been applied if you go to the View > Hide/Show menu
and activate Sketch Relations. Make sure the centerpoint has a coincident relation and that
none of the corners has any relations.

NOTE The temporary axis is not on the same plane as the sketch plane, so if the view is not normal
to the sketch plane, picking up an automatic relation between the centerpoint of the rectangle and the
temporary axis will be difficult.
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<\ 11. Use the Smart Dimension tool to apply dimensions, as shown in Figure 3.56. Note that the
3.450-inch dimension goes to the part origin on the left. You can select this from either
the graphics window or the FeatureManager.

FIGURE 3.56
Creating a rectangle
centered on the
temporary axis
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BEST PRACTICE

It is best practice to dimension or create sketch relations to items that have the fewest other rela-
tions. You should try to use the part origin and standard planes when possible. Dimensioning to
reference geometry is better than dimensioning to model edges, although this is not always possi-
ble. Use the Dynamic Reference Visualization under View > User Interface to get visual cues regard-
ing parent/child links.

ZE]

ﬁ 12. Click the Extrude toolbar button on the Features tab of the CommandManager. Rotate the
model (by dragging with the mouse wheel depressed) slightly so you can see the side of
the extrusion preview, as shown in Figure 3.57.

You may have to adjust the direction of the extrude using the icon with the arrows just
below the Direction1 heading in the Boss-Extrude PropertyManager.



THE BOTTOM LINE

FIGURE 3.57
Creating the extrusion

13. Use the Up To Next end condition, which makes the extruded solid go up to the next solid
that it encounters.

14. Use the View menu to turn off the display of Axes, Temporary Axes, and Planes.

The Bottom Line

Create new sketches and edit existing ones. In SolidWorks, each sketch is named and must
be on a plane or planar face. You can edit only one sketch at a time, and there are things you
cannot do while in a sketch.

Master It Practice creating new sketches and using the various sketch entities on the
Sketch toolbar to familiarize yourself with the range of tools that are available and how
they work.

Create new reference geometry and use the planes to create new sketches. As you get
deeper into this book, you will learn more uses for the Reference Geometry tools. For now, the
primary function is to establish planes for sketches without relying on adding relationships to
solid geometry.
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Master It Practice moving or redefining planes to see how the change affects the
resulting 3D geometry. Also build your skills by creating planes using the available
options. If you can imagine a way to define a plane, use the three selection boxes and
available constraints to see how many different types you can create.

Use a range of sketch entities. While you can often get by using just lines and arcs, there are
times when more advanced sketch entities are more appropriate. Ellipses, parabolas, conics,
splines, even slots, polygons, and sketch text are all valid sketch entities that are very useful in
certain situations.

Master It Practice using some of the more advanced sketch entities on the Sketch toolbar.



Creating Simple Parts
and Drawings

Good modeling practice is based on robust design intent. This just means that you should try to
build parts that can adapt easily to changes. This section of the book begins with things you need
to know in order to make good models—models that react predictably in drawings and that
update properly with changes. A robust design intent will make downstream operations easier.
Creating simple parts will help you understand the techniques used in more complex
modeling projects. Learning on simple tools and then expanding your skills will help you
understand best-practice issues, which will make you a better contributor to a team environment.

IN THIS CHAPTER, YOU WILL LEARN TO:

Establish design intent
Build a simple part

Create a simple assembly tutorial

* & o o

Make a simple drawing tutorial

Discovering Design Intent

By knowing the right information about the part’s function before you start modeling or design-
ing, you can create a model that will be easier to edit, easier to properly place into an assembly,
easier to detail in drawings, and easier for other SolidWorks users to understand when someone
else has to work on your models. Design intent is a statement of how the part functions, the major
features of the part, and how the model reacts to modeling changes.

It may help if you try to put the design intent into words to help you focus on what is
important in the design. An example of a statement of design intent is “This part is symmetric
about two planes, is used to support a 1.00 inch (diametral pitch) diameter shaft with a constant
downward load of 150 pounds using a bronze bushing, and is bolted to a plate below it.” This
does not give you enough information to design the part, but it does give you information about
two surfaces that are important (a hole for the bushing and the bottom that touches the mounting
plate), as well as some general size and load requirements.

Mastering SolidWorks, First Edition. Matt Lombard.
© 2019 John Wiley & Sons, Inc. Published 2019 by John Wiley & Sons, Inc.
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Using Symmetry
Symmetry is an important aspect of design intent. Taking advantage of symmetry can signifi-
cantly reduce the time needed to model the part. Symmetry can exist on several levels:

Sketch symmetry

Individual feature symmetry

Whole-part symmetry

Axial symmetry (a revolved part)

“Almost” symmetry (the whole part is symmetrical, except for a few features)

Left and right opposite hand (symmetrical) versions of the part

® ¢ 6 ¢ o o

Assembly symmetry

Determining Primary or Functional Features

This is probably the most important information to know. Primary or functional features include
how the part mounts or connects to other parts, motion that it needs to accommodate, and
additional structure to support loads.

Often, it is a good idea to create a special sketch as the first feature in the part that lays out the
functional features. This could be as simple as a straight line to denote the bottom and a circle to
represent the position and size of a mating part, or as complex as full outlines of parts and
features from all three standard planes. This technique is called creating a layout sketch, and it is
an important technique in both simple and complex parts. You can use layout sketches for
anything from simply drawing a size-reference bounding box to creating the one point of
reference for all sketched features in the part. You can use multiple layout sketches if a single
sketch on one plane is not sufficient.

Predicting Change

When the marketing department gets out of a meeting at 4:45 r.m., what changes do you need to
be prepared for so that you can still be out the door by 5:00 p.M.? No one expects you to be able
to tell the future, but you do need to model in such a way that your model easily adapts to future
changes. As you gain experience with the software and engineering design processes, keep this
idea in mind: you will develop some instincts for the type of modeling that you do.

I've talked a lot about what success looks like with a good design intent model, but let’s talk a
little bit about failure. Failure will turn out to be more motivating in practice. When design intent
fails, you get a feature tree full of errors, and you have to go through each feature, investigate
what’s wrong, and then fix it. The failures are generally due to errors in the parent/child
dependencies following the original change. Fixing errors like this can take up much more time
than creating a model in the first place. This is, in essence, the big weakness of history-based
modeling. There are a few ways to solve it:

¢ Be really careful. When this method fails, it is mostly due to the fact that you can’t predict
the future. (How will change happen?)

¢ Use a method like Resilient Modeling. This is a structured method where you keep track
of the parent/child connections, and only start new sketches on reference geometry with a
direct link back to something that will not change (origin or base planes).
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¢ Use a method other than history-based design. This would require a different software
package, such as Solid Edge. SolidWorks, in fact, cannot do what is known as “direct
modeling,” although the company will tell you otherwise.

I discuss this issue again in Chapter 12, “Editing, Evaluating, and Troubleshooting.”

Creating a Simple Part

Chapter 2, “Navigating the SolidWorks Interface,” introduced the tools and features you will use
to create simple parts, and this chapter teaches you how to string the simple features together
intelligently. In this section, I'll show you how to build the simple part shown in Figure 4.1.
Although the shape is simple, the techniques used and discussed here are applicable to a wide
variety of real-world parts. The discussion on how to model the part contains information on
some of the topics you must understand in order to do the work.

FIGURE 4.1
A simple machined part

Deciding Where to Start

Deciding where to start can be more difficult than it sounds, especially for new users. For this
reason, I'll go through some sample parts and discuss possible starting points. Figure 4.2 shows
the first part. For reference, all of these parts can be found www.wiley.com/go/mastersolid.

As you decide how to model geometry in SolidWorks, you should be thinking of a 2D shape
and a process. You typically create prismatic shapes by using an Extrude feature and round
shapes by using a Revolve feature. Features can also add material (boss) or remove material (cut).
Obviously, your first feature must add material.

If you look at the 3D geometry and see it as a series of 2D drawing views arranged in 3D
space (as shown in Figure 4.2), you are on your way to deciding where to start.



114 |CHAPTER4 CREATING SIMPLE PARTS AND DRAWINGS

FIGURE 4.2
Which starting sketch
is the best? %

The part in Figure 4.2 has flat and round faces, but if you examine it, you can create the
overall shape using a single extrude. The best option in this case would be to start with a sketch
like the one in the lower-right corner and extrude it. This is a good beginning. Although you can
make the same part starting from any of the three sketches, the one in the lower-right corner gets
you closest to the final shape.

Also realize that you don’t need to make all the geometry in a single feature. It is often best to
use multiple features for elements such as holes, fillets, chamfers, and other groups of geometry
that can be separated out from the main shape.

You might look at the part and see many ways to create it, but the most straightforward way
is to extrude the U shape, a rectangular cutout, and four chamfers, as shown in Figure 4.3.

FIGURE 4.3
Breaking down the
features in this part

Make rectangular
cut out

Create four  CXtrude main U shape

chamfered
corners
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Notice where the part is placed in relation to the origin. Different people might do this
differently, and the same person might even do it differently depending on the function of the
part. In this case, the origin is aligned with the center of the round shape and at the bottom of
the flat face. The placement of the origin suggests that this part sits on the flat face of another
part and may hold a cylindrical face of another part.

If you open the part from www.wiley.com/go/mastersolid, you will notice that the origin is
also placed in the middle of the extrusion depth. This suggests that the part is symmetrical from
front to back.

If you are new to 3D modeling, this might be too much to take in all at once, but you should
try to keep the ideas presented here in mind as you work through your first several parts and
when you examine SolidWorks parts made by more-experienced users.

Figure 4.4 shows another part with other features. Again, you can choose from several ways to
make this part.

FIGURE 4.4
Identify the best starting
point for this part.

In this case, the best option is to use the one on top. (The other two profiles would add
geometry that you would have to remove later.) Notice that the holes in the part are not repre-
sented in any of the profiles. This is because holes are often added as separate features later. This
gives you control over whether the holes are there or not, as well as the size and placement of
the holes.

Returning to the part in Figure 4.1, it should be clear enough that this part would be best
started from a rectangle, although the rectangle could come from any of the three directions.

I personally try to use the biggest sketch that will create a solid that requires the fewest number
of additional features. The first feature that you create should also be positioned relative to the
origin. Whether a corner of a rectangle is coincident to the origin, the rectangle is centered on

the origin, or dimensions are used to stand the rectangle off from the origin at some distance, you
need to lock the first feature to the origin with every part you build.

Many people ask how to move the origin, and this is perhaps one of the first things you need
to understand about working in SolidWorks. You don’t move the origin in SolidWorks. You move
everything else in relation to the origin. If you have a part built with the origin in a certain place
and want to move it, depending on how the part was built, this might be a very big job. If every
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feature was created dimensioned from the origin, you will have to move every feature. If features
were created dimensioned from an edge of the first feature, you only need to move the first
feature. It is also possible to move the entire body, but that is a more complex operation that will
be addressed later.

When working with a simple part, the entire part can sometimes be described as rectangular or
cylindrical. In cases like these, it is easy to know where to start: You simply draw a rectangle or a
circle, respectively. On complex parts, it may not be obvious where to start, and the overall part
cannot be said to have any simple shape. In cases like these, it may be best to select the (or a)
prominent feature, mounting location, functional shape, or focus of the mechanism. For example,
if you were to design an automobile, what would you designate as the 0,0,0 origin? The ground
might be a reasonable location, as would the plane of the centers of the wheels. The end of the
crankshaft in the engine is often used as the assembly origin in automotive modeling. As long as
everyone working on the project agrees, many different reference points could work. With that in
mind, it seems logical to start the rectangular part by sketching a rectangle. Select the Top plane,
and sketch a centerpoint rectangle centered on the part origin.

Building in Symmetry

Your next decision is about part symmetry. The part in Figure 4.1 is not completely symmetrical.
Modeling a quarter of it and mirroring the entire model twice is not the most effective technique.
Instead, you should build the complete part around the origin and mirror individual features as
appropriate. To start this type of symmetry, you need to sketch a rectangle centered on the origin.
Again, to some extent, this is personal judgment.

Sketch a center rectangle where the first point, the centerpoint, is created at the origin. Drag or
click the second point (one of the corners) to an approximate size. This creates symmetry in both
directions. You can use additional construction geometry and sketch relations to make the
rectangle symmetrical side-to-side only.

TIP To make a rectangle work like a square, use an Equal sketch relation on two adjacent sides. This
requires only a single dimension to drive the size of the square.

Beginning with the rectangle you sketched in the preceding section, apply one horizontal
dimension by clicking the Smart Dimension tool on a single horizontal line, placing the horizon-
tal dimension (4.00 inches), and clicking a vertical line, placing the vertical dimension (6.00
inches). The sketch is fully defined at this point because both the size and position of the rectan-
gle have been established. Figure 4.5 shows the sketch at this point.
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Making It Solid

The Extrude feature is one of the staples of SolidWorks modeling. Depending on the type of
modeling you do, the Extrude feature may be one of your main tools. This section describes some
of the available Extrude options.

EXTRUDING FROM A SELECTION

The From panel establishes where the Extrude feature starts. By default, SolidWorks extrudes
from the sketch plane. These other options are available:

Surface/Face/Plane: The extrusion begins from a surface body, a face of a solid, or a reference
plane as shown in Figure 4.6. Surface features are discussed in detail in Chapter 32, “Working
with Surfaces.”
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Vertex: The distance from the sketch plane to the selected vertex is treated as an off-
set distance.

Offset: You can enter an explicit offset distance, and you can change the direction of the offset.

UNDERSTANDING DIRECTION 1 AND DIRECTION 2

Direction 1 is always in the direction of the plane normal. The plane normal for the face of a solid is
always away from the solid. For a reference plane, the interface will show you the normal direction
with an arrow when creating or editing.
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Direction 1 and Direction 2 are always opposite one another. Direction 2 becomes inactive if you
select Mid Plane for the end condition of Direction 1. In the graphics window, you will see a single
arrowhead for Direction 1 and a double arrowhead for Direction 2. For the Blind end condition,
which is described next, dragging the arrows determines the distance of the extrusion.

F Each of the end conditions is affected by the Reverse Direction toggle. This toggle simply changes
the default direction by 180 degrees. You need to be careful when using this feature, particularly
when using the Up To end conditions, because if the entity that you are extruding up to is not in the
selected direction, an error results.

ENDING AN EXTRUSION

Following is a brief description of each of the available end conditions for the Extrude feature:

Blind: In this case, Blind means an explicit distance. The term is usually used in conjunction
with holes of a specific depth, although here it is associated with a boss rather than a hole.

Up To Vertex: In effect, Up To Vertex works just like the Blind end condition, except that the
distance is parametrically controlled by a model vertex, edge, or sketch point.

Up To Surface: Up To Surface could probably be better named Up To Face, because the end
does not necessarily have to be an actual surface feature or body. This end condition may
display a warning if the projection of the sketch onto the selected face extends beyond the
boundary of the face. In that case, it is advisable to knit several faces together into a surface
body and to use the Up To Body end condition.

Offset From Surface: By default, Offset From Surface extrudes until it reaches a specified
distance from a selected surface. There are two methods for determining the type of offset and
one for determining direction.

¢ The default offset method behaves as if the selected surface were offset radially, so that
a surface with a 4-inch radius and a 1-inch offset would give a curvature on the end of
the extrude of a 3-inch radius (Figure 4.7).

¢ The second method, called Translate Surface, behaves as if the surface were moved by
the offset distance (Figure 4.8).

¢ Reverse Offset refers to specifying whether the offset stops short of the selected face
(Figure 4.9 top) or goes past it (Figure 4.9 bottom).

Up To Body: The Up To Body end condition is very useful in many situations, especially
when you receive the error message, “The end face cannot terminate the extrusion,” from the
Up To Surface end condition.

Mid Plane: The Mid Plane end condition eliminates the Direction 2 options and divides the
extrude distance equally in both directions. For example, if you specify a 1.00-inch Mid Plane,
SolidWorks extrudes .50 inches in one direction and .50 inches in the other direction. This is a
useful option for ensuring symmetry in a direction normal to the sketch plane.



FIGURE 4.7
Offset From Surface
using the default

FIGURE 4.8

Offset From Surface
using Translate
Surface options

FIGURE 4.9
The Reverse
Offset option
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Through All: The Through All end condition is available only when solid geometry already
exists in the part. When used for an extruded boss (which adds material), it extrudes to the
distance of the farthest point of the solid model in a direction perpendicular to the sketch
plane. When used for a cut, it simply cuts through everything.

Up To Next: Up To Next extrudes the feature until it runs into a solid face that completely
intercepts the entire sketch profile. If a portion of the sketch hangs over the edge of the face,
the extrude feature keeps going until it runs into a condition that matches that description,
which may be the outer face of the part in the direction of the extrusion. Figure 4.10 shows the
Up To Next end condition used with a Cut extrude.

FIGURE 4.10
Up To Next
end condition

\L’

By default, the Direction Of Extrusion is normal to the sketch plane, but you can also select a
linear entity such as an edge, planar face, face, plane, or axis as the direction. All the end-condi-
tion options are still available when you manually define the Direction Of Extrusion as some-
thing other than the default.

You can also assign a draft option to an extrusion as it is created, and you can control the draft
separately for Direction 1 and Direction 2.

BEST PRACTICE

Arranging draft, fillet, and shell features in the correct order so the model is efficient and achieves
the desired results is challenging. It is usually best to apply the draft as a separate feature rather
than using it in the definition of the Extrude feature. It is also best to apply the draft after most of
the modeling is done, but before you apply the cosmetic fillets and before you use the shell feature.

USING THE THIN FEATURE PANEL

The Thin Feature panel is activated by default when you try to extrude an open-loop sketch (a
sketch that does not fully enclose an area). The end-condition options remain the same. What
changes is that the feature applies a thickness to the sketch elements in the manner of a sheet metal
part, thin-walled plastic part, or rib. The Thin Feature panel of the Extrude PropertyManager,
along with a representative thin feature extrusion, are shown in Figure 4.11.



FIGURE 4.11

The Thin Feature panel
and a thin feature
extrusion
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The Cap Ends option is available only when you specify a Thin Feature to be created from a
closed-loop sketch. This creates a hollow, solid body in a single step. You can also use Thin
Features with cuts, and they are very useful for creating slots or grooves.

USING CONTOUR SELECTION

SolidWorks sketches are easiest to control when the sketches are neat and clean, when nothing
overlaps, and when no extra entities exist. However, when you need to use a sketch that does not
meet these criteria, you can use contour selection as an alternative method. Contour selection
enables you to select areas completely bounded by sketch entities for use with features such as
Extrude. For example, you could use a sketch like the number sign (#) where lines do not connect
at end points. You can use contour selection to select the box in the center, which is completely
bound by sketch elements. Figure 4.12 shows an extrude feature making use of contour selection
in a sketch.
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NOTE The part used in the image shown in Figure 4.12 is available from www.wiley.com/go/
mastersolidandis called Chapter 4 — Contour Selection.sldprt.

BEST PRACTICE

I believe contour selection was introduced into SolidWorks only to keep up with other CAD pack-
ages, not because it is a great feature. I do not recommend using contour selection on production
models. It is useful for creating quick models, but the selection is too unstable for data that you may
want to rely on in the future. The main problem is that if the sketch changes, the selected area
may also change, or SolidWorks may lose track of it entirely.

Using Instant 3D

® Instant 3D enables you to pull handles to create extrusions and to drag model faces to change the

size and location of features. Several feature types enable you to use arrows to adjust elements
visually of parametric features and sketches. Figure 4.13 shows the ruler added by Instant 3D
shows the arrows added by Instant 3D, which are the handles that you pull on to create a solid
from a sketch or edit an existing feature. Notice also that you can make cut features with Instant
3D. In fact, you can change a boss feature into a cut. I'm sure this is a neat sales demo trick, but
I'm not aware of any practical application of changing a boss into a cut. Figure 4.13 shows the
interface for Instant 3D.

FIGURE 4.13
Using Instant 3D and
Live Section

The intent is for this functionality to look and feel like direct modeling, but it is not direct
modeling. What you can do is still limited by the features in the history tree and the sketches and
dimensions driving the design intent. While this may be handy for making quick visual changes
to a model, it is not a great method for precise modeling. Instant 3D can also be an effective tool
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when used in conjunction with the direct editing type of tools such as Move Face. Instant 3D
mimics some of the direct edit type of functionality found in applications such as Solid Edge,
SketchUp, and SpaceClaim.

NOTE When combined with the sketch setting Override Dims On Drag (found at Tools > Options >
Sketch > Override Dimensions On Drag/Move), Instant 3D can be a powerful concepting tool, even
on fully dimensioned sketches.

Instant 3D also offers a tool called Live Section, which enables you to section a part with a
plane or drag the edges of the section regardless of the features to which the edges belong. To
activate Live Section, right-click a plane that intersects the part and select Live Section Plane.
Live Section is shown in Figure 4.13.

Chapter 37, “Using Imported Geometry,” discusses the direct edit theme in more detail and
revisits the Instant 3D manipulators in that light.

Making the First Extrude Feature

Going back to the sketch in Figure 4.5, I will show you how to continue building the part using
the newly learned tools. By centering the sketch on the origin and extruding using a Mid Plane
end condition, the initial block is built symmetrically about all three standard planes, with the
part origin at the center. In many parts, this is a desirable situation. It enables you to create
mirrored features using the standard planes and helps you put parts together later, when parts
must be centered and do not have a hard face-to-face connection with other parts. Figure 4.14
shows the initial feature with the standard planes.
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NOTE When you create a feature from a sketch, SolidWorks by default hides and absorbs (consumes)
the sketch under the feature in the FeatureManager. So, unless the tree is in Flat Tree View mode, you
need to click the plus sign (+) next to the feature to see the sketch in the tree. You can right-click the
sketch in the FeatureManager to show it in the graphics window.
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The next modeling step is to create a groove on the back of the part. How is this feature going
to be made? You can use several techniques to create this geometry. List as many techniques as
you can think of, whether or not you know how to use them.

Figure 4.15 shows multiple methods for creating the groove. From left to right, the methods
are a thin feature cut, a swept cut, and a nested-loop sketch.

FIGURE 4.15
Methods for creating
the groove

STEE—————

With a thin feature cut (shown on the left), you sketch the centerline of the groove and in the
Cut-Extrude feature, select the Thin Feature option and assign a width and depth. The option on
the right is what is called a nested loop, because it has a loop around the outside of the slot and
another around the inside. Only the material between the loops is cut away. The method in the
center is a sweep where the cross section of the slot is swept around a path to make the cut.

Another potential option could include a large pocket being cut out, with a boss adding
material back in the middle. Each option is appropriate for a specific situation. The thin feature
cut is probably the fastest to create, but also the least commonly used technique for a feature of
this type. (Many users are not even aware of the thin feature unless they attended specific
training or read about it in some of my other books.) Most users tend to use the nested-loop
option (one loop inside another) because it enables you to specify geometry more directly, as
opposed to specifying the geometry indirectly using the combination sketch and feature settings.

CONTROLLING RELATIVE SIZE OR DIRECT DIMENSIONS

You can control the size of the groove as an offset from the edges of the existing part, or you can
drive the dimensions independently. Again, this depends on the type of changes you anticipate.
If the groove will always depend on the outer size of the part, the decision is easy—go with the
offset from the outside edges. If the groove changes independently from the part, you need to
re-create dimensions and relations within the sketch to reflect a different design intent.

The decision of how to control the size of the slot is something I've been putting in the context
of design intent, but there is another way of looking at it. Some SolidWorks users, like me, are
focused on the 3D model. Many users, however, need to focus on the 2D drawing. If that’s your
situation, the decision of how to control the 3D model comes down to what dimensions you want
on the 2D drawing. You can take the dimensions from the 3D model and put them directly onto
the 2D drawing. If you can do this, it saves you a lot of time. Sometimes, though, the way you
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create a 3D part is going to be different from how you want to show that part on your drawings.
Both methods work. You have to decide how you want to create your parts and how you want to
create your drawings.

SolidWorks includes tools for Model-Based Definition (MBD). This is a method where you
document the 3D part separate from a 2D drawing. Chapter 41, “Facilities Design Tools,” covers
MBD methods in detail, and drawings start in Chapter 24, “Automating Drawings: The Basics.”

CREATING THE OFFSET

You need to consider one more thing before you create the groove sketch. What should you use
to create the offset—the actual block edges or the original sketch? The answer to this is a Best
Practice issue.

BEST PRACTICE

When creating relations that need to adapt to the largest range of changes to the model, it is best to
go as far back in the model history as you can to pick up those relations. In most cases, this means
creating relations to sketches or reference geometry rather than to edges of the model. Model edges
can be fickle, especially with the use of fillets, chamfers, and drafts. The technique of relating fea-
tures to driving layout sketches helps you create models that do not fail through the widest range
of changes.

One tool to help you easily see the parent/child relations between features is the Dynamic Reference
Visualization, found at View > User Interface > Dynamic Reference Visualization.

Much of the SolidWorks software was created with initial ease of use in mind. Sometimes doing
what’s easy initially creates complications later in the design process. The easiest way to create the
slot is to open a sketch on the back face, and offset a sketch from the edges of the face, and then
apply sketch fillets. This method is very fast, but it is not very robust, meaning that there are several
ways in which errors can happen. In the end, there is no truly bullet-proof way to create a model.
Each method has its benefits and potential problems.

VIDEO Watch the video tutorial www.wiley.com/go/mastersolid for a demonstration of making
a simple part. You can follow along if you like. The finished part is also supplied in the downloadable
materials.

Creating a Simple Assembly

An assembly is a special document type in SolidWorks that allows you to position multiple parts
with respect to one another using geometrical mate relationships (such as coincident and
concentric) or distance relationships (such as dimensions). The simple assemblies you begin
creating here start with a single part that is located with respect to the assembly’s origin and
standard planes. This is very much like orienting the first sketch of a part to the part’s origin.
Parts can be added to the assembly in a number of ways and mated together using reference
geometry or faces. It is best if you can use reference geometry, because items like planes and axes
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tend to be more stable than edges and faces. If you make a change later that removes a face that
an assembly mate depends on, that mate fails or does something unexpected.

SolidWorks assembly documents can become extremely complex, with patterns, layouts,
in-context, virtual parts, subassemblies, flexible subassemblies, configurations, assembly
features, exploded views, in-context features, special Toolbox features, and an assortment of
other assembly-only tools available. For the purposes of this chapter, we'll just talk about putting
parts together with mates.

When creating an assembly, give careful thought to the selection of the first part. The first part
or component of an assembly should always be the key component. In an assembly for a bicycle,
the frame would be added first and locked in place using the assembly planes. Similarly, an
assembly of an engine would be started with the block, where the block is fixed at the assem-
bly origin.

Like other document types, SolidWorks assemblies start from templates. Before you get
started making lots of assemblies, you should make sure you have at least one custom template
that you intend to use. Special settings common for assembly templates are units, plane names,
drafting standard, custom properties, and other items.

Assemblies have a FeatureManager arrangement of their own. In the assembly
FeatureManager, you will find parts and subassemblies, special folders for mates, component
patterns, assembly features, Toolbox parts and features, and other assembly-specific items.

Creating the Assembly

[ New.. To get started with an assembly, click New, find an assembly template, and double-click it. The
settings that come up in the PropertyManager will be the topic of later chapters, starting with
Chapter 13, “Building Efficient Assemblies.” You can insert any of the currently open parts or
assemblies shown in the Browse window by double-clicking the filename and then clicking in
the graphics window to place the part or assembly (Figure 4.16).

Notice that the assembly has some folders and reference geometry just like part documents.

As you add parts to the assembly, they will be listed in the FeatureManager. Very large assem-
blies require some special techniques to manage all the data, but for now we are starting simple.

Populating the Assembly

You can use one of several methods for putting a part into an assembly:
¢ Click Make Assembly from Part/Assembly from the Title Bar toolbar.
Choose Insert > Component.
Drag the part from another SolidWorks window.
Drag the part from Windows Explorer.
Use the Library in the Task pane.
Use the Begin Assembly PropertyManager.

* ¢ 6 ¢ o o

Ctrl+drag to make a copy; Ctrl+C and Ctrl+V to copy and paste parts.
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The first part you put into an assembly is always automatically fixed, meaning it does not
move. Any other parts you put in have no constraints or mates, unless you add them using Smart
Mates or Mate References, as explained in more detail in Chapter 14, “Getting More from Mates.”

Examining Mates

Mates work very much like sketch relations, but they work in 3D space, and they relate edges,
faces, vertices, or different types of reference geometry to one another. They do this in order to
position and orient parts with respect to one another, but also to allow for motion when a part is
dragged with the cursor. Common mates are coincident and concentric—again, just like sketch
relations.

Mates are not just for positioning parts, but are also used to establish design intent in
the assembly.

Figure 4.17 shows the assembly FeatureManager with several components and some mates.

127
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Creating a Simple Drawing

CAD salesmen have been telling us for 30 years that 2D paper drawings are going away. 2D
drawings may never go away, but what is happening less is drawing three views with individual
lines and arcs. Although AutoCAD is still a popular product, it is tedious for view creation.

Drawings in SolidWorks are really just automated snapshots of the model from various views.
Any change to the model automatically updates all the views. You can make section views,
auxiliary views, cutaway views, and other specialized views quickly when you are working from
a 3D model. There are some exceptions to the automatic updates, including when models aren’t
loaded and a setting called Detached Drawings, when they are intentionally not updated.

To create a new drawing, you again start with a drawing template, which contains the
document-specific settings such as units, drafting standard, and so on. You also might use a
format, which determines the paper size and has the drawing border with the title block and
other items. So, the template is the drawing file with overall settings, and the format is the
drawing border. Usually, templates are saved with the format within it, so the blank drawing
already has a sheet size and a border.

You can make drawings of individual parts or assemblies, and you can make multi-sheet
drawings with an assembly on the front and all the detail parts on subsequent sheets. Drawings
can also contain tables such as bills of materials, general tables, hole charts, and other types of
annotated charts.

You can also make drawing views from simple sketches. This is useful for layouts, schematics,
and items that might not have a physical representation.

Figure 4.18 shows a drawing with some simple views, dimensions, and annotations.

Tutorial: Creating a Simple Part
To create the simple part for this chapter from scratch, follow these steps:

1. Click the New icon from the Title Bar toolbar, and select an inch part template. (I have
included an inch part template with the download materials.)

2. Open a sketch on the Front plane.
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FIGURE 4.18
A simple drawing with
views and a title block
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3. Sketch a center rectangle that is 6-inches tall and 4-inches wide, starting from the origin.

4. Create an Extrude feature, using the Direction 1 option for Mid Plane, with a depth of
1 inch. Before you accept the Extrude.

To create the groove, follow these steps:

1. Open a sketch on a face of the part that’s parallel to the Front plane. To create the offset,
expand the Extrude feature by clicking the plus icon (+) next to it in the FeatureManager
so you can see the sketch. Regardless of how it displays here, this sketch appears before
the extrude in the part history. Right-click the sketch and select Show (or expand the
DisplayManager and click the icon in the first column, in the row of the sketch you
want to show).

TIP You can view individual sketches and reference geometry entities such as planes from the RMB
menu. The global settings for the visibility of these items are found in the View menu. You can access
these items faster by using the View toolbar or by linking the commands to hotkeys.

2. Right-click the sketch in the graphics window, and click Select Chain. This selects any
nonconstruction, end-to-end sketch entities. Click Offset Entities on the Sketch toolbar.
Offset to the inside by .400 inches. Apply .500-inch sketch fillets to each of the corners. Exit
out of the Fillet command using the green check when the fillets have been applied to
the sketch.

3. Click Extruded Cut on the Feature toolbar. By default, the extruded cut will cut away
everything inside the closed profile of the sketch. Look down the PropertyManager
window, and select the check box on the top bar of the Thin Feature panel. Make the cut
settings under Direction 1 Blind, .100 inch. The Thin Feature type should be set to Mid
Plane with a width of .400 inches. The PropertyManager and graphics window should
look like Figure 4.19.
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FIGURE 4.19
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USING SKETCH TECHNIQUES

Continue with the part from the previous section, and follow these steps:

1. Open a new sketch on the large face opposite from the groove. Draw an angled line across
the part, as shown in Figure 4.20. Sketchl should be visible. Click on the Extrude button,
and you will be prompted to close the sketch loop. Use the yellow arrow to select the
smaller loop.

TIP If you want to continue using the recommended best practice of making relations to sketches
rather than model edges, here are a few tips. In some situations (such as the current one), the sketch
plane is offset from the sketch that you want to make relations to, and the best bet is to use the Nor-
mal To view. The next obstacle is making sure that automatic relations pick up the sketch rather than
the edge, so you can use the Selection Filter to select sketch entities only.

2. Extrude the sketch to add 0.25-inch material.

3. Choose Tools > Options > Sketch and ensure that Prompt To Close Sketch is turned on;
then click OK to close the dialog box.

4. Open another new sketch on the same face that was used by the last extrusion. Begin
drawing another angled line, but before placing the second endpoint, hover the cursor
over the angled edge created by the previous feature, and it will highlight orange. Now
position the cursor approximately to make a parallel line, and a dotted yellow inference
will appear. Draw the angled line using all the automatic relationships that are appropri-
ate, as shown in Figure 4.21.
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FIGURE 4.20 S
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NOTE The parallel relation will not be applied automatically, as shown in Figure 4.21. The line will be
parallel to the slanted edge, but a relation might need to be applied manually after the line is created.
Time relations are applied automatically based on inference lines only when the mouse hovers over
a sketch entity, not an edge. In this particular case, the relation will be replaced by the dimension
between two parallel lines from step 5, so no redundant parallel relation is needed.

FIGURE 4.21
Using automatic
relationships




132

CHAPTER 4 CREATING SIMPLE PARTS AND DRAWINGS

5. Dimension the angled line such that it is 2.025 inches from the first line.

6. Use the same technique as in step 1 to make a closed loop, and extrude the feature using
the Through All end condition so that it will always match the previous extrusion.

USING THE HOLE WIZARD

The next features that you will apply are a pair of counterbored holes. SolidWorks has a special
tool called the Hole Wizard that you can use to create common hole types. The Hole Wizard
helps you create standard hole types using standard or custom sizes. You can place holes on any
face of a 3D model or constrain them to a single 2D plane or face. A single feature created by the
Hole Wizard may create a single hole or multiple holes, and a feature that is not constrained to a
single plane can create individual holes originating from multiple faces, nonparallel faces, and
even nonplanar faces (holes may go in different directions). All holes in a single feature that you
create by using the Hole Wizard must be the same type and size. If you want multiple sizes or
types, you must create multiple Hole Wizard features.

To apply counterbored holes to your part, follow these steps:

1. Select the face that the groove feature was created on, and click the Hole Wizard tool on
the Features toolbar. Then set the hole to Counterbored, the Standard to ANSI Inch, the
type to Socket Head Cap Screw, the size to one-quarter, and the end condition to Through
All, as shown in Figure 4.22.

2. Click to select the Positions tab at the top of the PropertyManager. This is where you place
the centerpoints of the holes using sketch points. It is often useful to create construction
geometry to help line up and place the sketch points. Make sure the plane or face that the
holes originate from is selected in the Positions tab.

3. Draw two colinear construction lines, horizontally across the part, with Coincident
relations to each side. Select both lines, and give them an Equal relation. The point of this
step is to use parametric relations to evenly space holes across the part without dimen-
sions or equations. Refer to Figure 4.23.

TIP Although several methods exist to make multiple selections, a box or window selection technique
may be useful in this situation. If the box is dragged from left to right, only the items completely
within the box are selected. If the box is dragged from right to left, any item that is at least partially in
the box is selected. Selecting the common point of the two lines applies an equal relation.

4. Place sketch points at the midpoint of each of the construction lines. If there is a sketch
point other than the two that you want to make into actual holes, delete the extra points.
Dimension one of the lines down from the top of the part, as shown in Figure 4.23. All the
sketch relation icons are displayed for reference. Click OK to accept the feature after you
are happy with all the settings, locations, relations, and dimensions.
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FIGURE 4.23
Placing the center-
points of holes

CUTTING A SLOT

SolidWorks provides two types of slots: Hole Wizard slots and sketched slots. Fancier slots with
the counterbores and countersinks can be made more quickly using the Hole Wizard, but the
Hole Wizard is able to create only straight slots. For curved slots, you will need to use the curved
slot sketch entity and extrude the sketch as a cut. In this tutorial, we create a curved slot.

To cut slots in your part, follow these steps:

1. In this case, use the Centerpoint Arc Slot option. Slots are easiest to create with the
Click+click method rather than click-and-drag. Make sure the Sketch 1 under Boss-
Extrude 1 is shown. Open a sketch on the face with the groove. Click near where you want
the center of the curvature of the slot. Click again for the center of one end; click a third
time for the width/end radius. The Slot PropertyManager is shown in Figure 4.24.
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Create a vertical sketch relation between the origin and the centerpoint of the slot. Make
the slot 0.500 inches wide. One way to do this is to place a 0.25 inches radial dimension on
one of the end arcs, but a more interesting way to do it is to hold down the Shift key and
click both of the big arcs with the Smart Dimension tool. This will give you the difference
between the arcs. Continue to dimension as shown in Figure 4.24.

NOTE Using the Add dimensions option in the Slot PropertyManager can help you size the slot more
quickly. This does not require the Enable onscreen numeric-input option to be turned on.

2. From this sketch, create an extruded cut .75” deep.

3. Open a sketch on the bottom of the previous slot, and offset the slot to the inside by 0.110”.
Create a cut using the Through All end condition.

CREATING FILLETS AND CHAMFERS

As mentioned earlier, it is considered a best practice to avoid using sketch fillets when possible
and use feature fillets instead. Another best-practice guideline is to put fillets at the bottom of the
design tree or at least after all the functional features. You should not dimension sketches to
model edges created by fillets unless no better methods are available. Several chapters could be
written just about fillet types, techniques, and strategies in SolidWorks. Chapter 7, “Modeling
with Primary Features,” deals with more complex fillet types.

BEST PRACTICE

Do not dimension sketches to model edges that are created by fillets. Although the previous best
practice about relations to sketch entities instead of model edges was a mild warning, you must heed
this one more carefully.

To add fillets and chamfers to your part, follow these steps:

1. Initiate a Fillet feature, and select the four short edges on the part. Set the radius value to
.600 inches. Click OK to accept the Fillet feature. You can use the first icon on the left of the
pop-up toolbar, as shown in Figure 4.25, to help you select all four edges around the
part quickly.

TIP When selecting edges around a four-sided part, the first three edges are usually visible and the
fourth edge is not. You can select invisible edges by expanding the Fillet Options panel of the Fillet
PropertyManager and selecting the Select Through Faces option. When you have a complex part with
many hidden edges, this setting can be bothersome, but in simple cases like this, it is useful.
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2. Apply chamfers to the edges of the angled slot through the part, as indicated in
Figure 4.26. Make the chamfers .050 inches by 45 degrees.

Chamfers observe many of the same best practices as fillets.

TIP Feature order is important with features like chamfers and fillets because of how they both tend
to propagate around tangent edges. Although you can turn this setting off for both types of features,
it is best to get the correct geometry by applying the features in order.

FIGURE 4.26
Edges for fillet and
chamfer features
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3. Select the four edges that are indicated for fillets in Figure 4.26. Apply .050-inch-
radius fillets.



CREATING A SIMPLE DRAWING | 137

4. Apply alast set of .050-inch chamfers to the backside of the counterbores and slot.

5. Save the part, as Chapter4SimpleMachinedPart and then close it.

The finished part is simple, but you have learned many useful techniques along the way:.

Tutorial: Making a Simple Drawing
In SolidWorks, drawing views are created from the 3D model. Even the most complex section
views are almost free, because they are simply projected from the 3D model. When you make
changes to the 3D model, all 2D views update. You can handle dimensions in a couple of ways,
either using the dimensions that you used to create the model or placing new dimensions on the
drawing. (Best practice for modeling is not necessarily the same as best practice for manufactur-
ing drawings.) Model-Based Definition (MBD) is covered in Chapter 40, “Using Model-

Based Design.”

To make a simple drawing of a SolidWorks native part, follow these steps:

1. Click the New button from the standard toolbar, or choose File > New. From the New
SolidWorks Document window, select the Blank Drawing template. The template contains

all the document-specific settings.

2. After selecting the drawing template, the Sheet Format/Size dialog box appears, as shown
in Figure 4.27. This only appears if the format is not already in the template. If your
template comes up with the border around it, you can change the border/format by
right-clicking on the Sheetl in the FeatureManager and selecting Properties.

Select the D-Landscape sheet size, as well as the format that automatically associates with
that sheet size, and click OK. If the Model View PropertyManager appears, click the red X
icon to exit. (If the template you selected already has a format, you can skip this step.)

FIGURE 4.27
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. From the Drawings toolbar, click the Standard 3 View button, or through the menus,

choose Insert > Drawing View > Standard 3 View. If the Chapter4 SimpleMachinedPart
document does not appear in the list box in the PropertyManager, then use the Browse
button to select it. When you click the OK button, the three drawing views are created.

. After creating views on the drawing, set up some fields in the format to be filled out

automatically when you bring the part into the drawing. Right-click anywhere on the
drawing sheet (on the paper) and select Edit Sheet Format.

. Zoom in to the lower-right corner of the drawing. Notice that there are several variables

with the format $PRPSHEET : { Description}. These annotations are linked to custom
properties. Some of them have properties with values (such as the Scale note), and some of
the properties do not have values (such as the Description).

. Add an annotation in the Drawn row, in the Date column. You can add annotations by

choosing Insert > Annotations > Note, or by activating the Annotations toolbar in the
CommandManager and clicking the Note button. Type today’s date as the text of the note.

CAUTION If you are using a SolidWorks default template and a circle appears around your note,
use the Text Format PropertyManager that appears when you are creating a note, expand the Border
panel, and change the Circle option to None.

7. Add another note, this time to the Name column. Do not type anything in the note, but

click the Link to Properties button in the Note PropertyManager to create a link to a
custom property. In the Link To Property dialog box, click the Model In Drawing View
Specified option in Sheet Properties. Type user in the drop-down text box below the
option. This now accesses a custom property in a part or assembly that is put onto this
drawing and called “user,” and it puts the value where the note is placed.

. To return to Edit Sheet mode (out of Edit Format mode), select Edit Sheet from the RMB

menu. A little text reminder message appears in the lower-right corner on the status bar to
indicate whether you are editing the Sheet or the Format.

. Drawing views can be sized individually or for each sheet. The Sheet Properties dialog

box in Figure 4.27 shows the sheet scale. If this is changed, all the views on the sheet that
use the sheet scale are updated. If you select a view and activate the Drawing View
PropertyManager, you can use the Scale panel to toggle from Use Sheet Scale to Use
Custom Scale.

CAUTION Sometimes, in the United States, the SolidWorks software installs with ISO standard
templates. ISO drawing templates project views using First Angle Projection. To check the projec-
tion method of a drawing, right-click the drawing sheet and select Sheet Properties. The Type Of
Projection setting appears in the top middle of the dialog box, as shown in Figure 4.27.

10. To create an Isometric view, activate the Drawings toolbar in the CommandManager and

click the Projected View button. Then select one of the existing views, and move the cursor
at a 45-degree angle. If you cannot place the view where you would like it to go, press the
Ctrl key to break the alignment and place the view where you want it.
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11. You can change the appearance of the drawing view in several ways:

L 4

L 4

View > Display > Tangent Edges With Font uses the phantom line type for any edge
between tangent faces.

View » Display » Tangent Edges Removed completely removes any tangent edges.
This is not recommended, especially for parts with many filleted edges, because it
generally displays just the outline of the part.

Shaded or Wireframe modes can be used on drawings and are accessed from the
View toolbar.

Perspective views must be saved in the model as a named view and placed in the
drawing using the view name.

RealView drawing views can be placed on the drawing. RealView can be shown in
drawings using Shaded or Shaded With Edges and RealView turned on.

12. Look at the custom properties that you created in the title block. The date is there because
you entered a specific value for it, but the Name field is not filled in. This is because there
is no User property in the part. Right-click the part in one of the views, and select Open
Part. In the part window, choose File > Properties, and in the Property Name column, type
the property name user, with a value of your initials, or however your company identifies
people on drawings. The Properties dialog box, also called Summary Information, is
shown in part in Figure 4.28.

NOTE When used in models and formats, Custom Properties are an extremely powerful combination,
especially when you want to fill in data automatically in the format, in a BOM (Bill of Materials), or a
PDM (Product Data Management) product. These topics are discussed in more detail in Chapter 13.

FIGURE 4.28

The Custom Properties

entry table

Summary Information - m} b4

Summary Custom

BOM quantity:

Gea T
Property Name Type Value / Text Expression Evaluated Value [5)

1 |date Date 3/24/2002 3/24/2002

2 |material Text aluminum aluminum

3 |drawnby Text Matt Matt

4 |checkedby Text You You

5 |description Text description description

6 |weight Text

7 |<Type a new property

oK Cancel Help

13. When you flip back to the drawing (using Ctrl+Tab), the Name column now contains the
value of your initials.



140 ‘ CHAPTER 4 CREATING SIMPLE PARTS AND DRAWINGS

“- 14. Click the Section View button on the Drawings toolbar. This activates the Section View
1 Assist command so you can place a section line in a view. If you need a cutting line other
+ than a single straight line, the PropertyManager has some options, and other options will
be presented after you place the line to allow you to edit it.

15. Bring the cursor down to the midpoint of the top edge of the part. When the midpoint is
active, you can use the dotted inference lines to ensure that you are lined up with the
center. Another option is to manually create sketch relations. Turning on temporary axes
displays center marks in the centers of arcs and circles. Figure 4.29 shows the technique
with the inference lines being used.

FIGURE 4.29 9 section Vi ; @ | e
+ Section View Assist )
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Select Cutting Line and place it on a view. : |
Options: E i
Use the Section View popup to add offsets '
to the Cutting Line. E
OR ‘
Select Auto-start section view for I |
immediate preview and placement of the B 1
section view, E Wl
Cutting Line € E '&\ |
«. | © "0
W[ | |
] 0
' I
1 '?‘of), ; S : -
B N "/
|:|Auto-startsection view \ /
16. As mentioned earlier, you can use two fundamentally different methods for dimension-

ing drawings:

Model Items imports the dimensions used to build the SolidWorks model and uses them
on the drawing. These dimensions are bidirectionally associative, meaning that changing
them on the drawing updates the model and changing them on the model updates them
in the drawing. On the surface of things, this sounds too good to be true, and it is. The
potential problems is that you might not model things the way you would dimension
them for the shop. You have to answer several questions for yourself, such as “Do the
leader lines go to the right locations or can they be moved?” The dimensions usually
come in such a way that they need to be moved around quite a bit.
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Reference (driven) Dimensions can be applied to the drawing view directly. These are
only associative in one direction, meaning that they measure what is there, but they do
not drive the size or position of the geometry. All changes must be made from the model.
Again, on the face of things, this appears to be redundant and a waste of time; but in my
personal estimation, by the time you finish rearranging dimensions, checking to ensure
that you have everything you need, and hiding the extraneous dimensions, you are usu-
ally far better off using reference dimensions.

BEST PRACTICE

Users have strong opinions on both sides of the issue of dimensioning drawings. The best thing for
you to do is to use both methods and decide for yourself.

17. If you choose to use the Model Items approach, you can do this by choosing Insert >
Model Items. Specify whether the dimensions should come from the entire model or just a
selected feature. You also need to ask whether the dimensions should come into all views
or just the selected one, and whether you want just a certain type of dimension, annota-
tion, or reference geometry.

18. After the dimensions are brought in, you need to move some of them from one view to
another, which you can do by Shift+dragging the dimension from the old location to the
new location. Ctrl+dragging predictably copies the dimension. You can move views by
dragging an edge in the view.

SHEET VS. SHEET FORMAT

With new and even experienced users, there is some confusion around the Sheet versus Sheet
Format issue. Part of the confusion is due to SolidWorks terminology. SolidWorks names the two
items Sheet and Sheet Format. In this book, I simply use the terms Sheet and Format to avoid linking
the two items with a common first name. It would be better yet if Format were changed to Border or
Title Block so that the name more closely matched the function. Just be aware that Title Block has a
precise meaning in SolidWorks; there are commands associated with it.

In a SolidWorks drawing, you are editing a view, the sheet, or the format. When editing the sheet,
you can perform actions such as view, move, and create views, but you cannot select, move, or edit
the lines and text of the drawing border. When editing the format, you can edit the lines and text
that make up the drawing border, but the drawing views disappear. Also, you can edit annotations
in the format from the sheet layer.

Often, users save a template that already contains a format to save themselves some time every time
they create a new drawing. Chapter 24 covers setting up automation of drawing creation.
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The Bottom Line

SolidWorks data is made of parts, assemblies, and drawings. In this chapter, you learned how to
create simple examples of each type.

Master It Create a simple block with holes in it, where every item is dimensioned fully. Use
an existing SolidWorks template.

Master It Create a simple assembly where you bring together some of the parts that you
created or worked with in this chapter, and use mates to locate them with respect to
one another.

Master It Create a simple drawing of a single part you made earlier in this chapter. Fill in
some custom properties, and make sure the properties propagate over to fill out the title block
on the drawing. Use various types of views, annotations, symbols, and dimensions.



Using Visualization Techniques

Part of the overall mission of SolidWorks software is to visualize geometry. Visualizing 3D CAD
data is more than seeing shaded solids or shiny surfaces; it includes being able to see the interior
and exterior at the same time and using sections, transparency, wireframe, and other tools or
techniques. SolidWorks takes it so much further than just being able to see things in 3D; you can
look at some parts of an assembly in wireframe while others are transparent and others are
opaque. You can see a part with a reflective appearance. You can create section views in parts and
assemblies to visualize internal details. This chapter will show you important capabilities that
will expand how you can use SolidWorks and maybe even change the way you use the tools or
look at modeling tasks.

IN THIS CHAPTER, YOU WILL LEARN TO:

Customize the view

Use View tools to view parts and assemblies
Make the best use of Real View

Use Display States in parts and assemblies

Apply edge settings to display features clearly

* & 6 0 o o

Sort items in an assembly

Manipulating the View

One of the most important skills in SolidWorks is manipulating the view. (Figure 5.1 shows the
Heads-Up View toolbar, an easy way to access most visualization tools.) This is something you'll
do more frequently than any other function in SolidWorks, so learning to do it efficiently and
effectively is very important, whether you look at it as rotating the model or rotating the point of
view around the model. The easiest way to rotate the part is to hold down the middle mouse
button (MMB) or the scroll wheel and move the mouse. If your mouse does not have a middle button
or a scroll wheel that you can use as a MMB, you can use the Rotate View tool in the menus at
View > Modify > Rotate or via the RMB menu.

The Heads-Up View toolbar can be customized and disabled using the same method you use
for all the other toolbars, through the Tools > Customize dialog box.

Mastering SolidWorks, First Edition. Matt Lombard.
© 2019 John Wiley & Sons, Inc. Published 2019 by John Wiley & Sons, Inc.
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FIGURE 5.1

Use the Heads-Up View U o o2 29
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access most visualization
tools.

TIP Some mouse drivers change the middle-button or scroll-wheel settings to do other things. Of-
ten, you can disable the special settings for a particular application if you want SolidWorks to work
correctly and still use the other functionality. For example, the most common problem with mouse
drivers is that when the model gets close to the sides of the graphics window and the scroll bars
engage, the middle mouse button suddenly changes its function. If this happens to you, you should
change the function of the MMB to Middle Mouse Button from its present setting.

For visualization, you cannot buy any hardware that’s quite as nice as a spaceball (3D mouse).
It allows you to rotate with one hand and select with the other hand. It is also great for custom-
izing buttons; depending on the model you get, it may even have some keyboard buttons such as
Alt, Esc, and Ctrl right there on the device.

Using Arrow Keys

You can use the arrow keys on the keyboard to manipulate the view in predictable and control-
lable ways. You can use the Shift, Ctrl, and Alt keys to add to the behavior. The arrow keys
enable you to rotate to the following views:

Arrow: Rotate 15 degrees (to customize this setting, choose Tools > Options > View)
Shift+arrow: Rotate 90 degrees
Alt+arrow: Rotate in a plane flat to the screen

Ctrl+arrow: Pan

Using the Middle Mouse Button

Most, if not all, mice sold today have middle mouse buttons (MMBs), usually in the form of a
clickable scroll wheel. The MMB or scroll wheel has several uses in view manipulation:

MMB alone: Rotate

Click or hover: Work on an edge, a face, or a vertex with MMB and then drag MMB: Rotate
around selected entity

Ctrl+MMB: Pan
Shift+MMB: Zoom
Double-click MMB: Zoom to fit

Scroll with wheel: Zoom in or out (to reverse direction of the zoom setting, choose Tools >
Options > View)

Alt+MMB: Rotate in a plane flat to the screen
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When you're rotating the model view with the MMB, the view can easily get into a state
where it’s hard to see. Using the Rotate About Scene Floor option, however, makes this easier.
Figure 5.2 shows this option in the RMB menu. You may see documentation that describes this as
“lock vertical axis,” but it does not do that. “Lock vertical axis” would be if the model were
sitting on a turntable going around. The Rotate About Scene Floor option seems to understand
which way is “up,” and it doesn’t allow the view to proceed in such a way that the model gets
turned upside down easily. It’s possibly more difficult to describe in writing than to just try
it—so just try it. You may agree that this should have been the default method for rotation.

FIGURE 5.2
Using the Rotate About
Scene Floor option
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To change the floor position or orientation, go to the DisplayManager tab of the
FeatureManager area, right-click Scene, and select Edit Scene. In the Floor panel, change the
setting in the Align Floor With selection box and select the appropriate plane or Bottom
View Plane.

As a caution, you may be prevented from accessing the Edit Scene PropertyManager if you
are using the Plain Viewport Background color (Tools > Options > Colors > Background
Appearance). This uses System Options to determine the background for each document rather
than allowing each document to control its own background. To access the Scene options, you
have to change to Use Document Scene.

Using Mouse Gestures

Mouse gestures are an interface method that you can customize to do anything a SolidWorks
toolbar button can do, but by default, it controls view orientation. Figure 5.3 shows the default
configuration of the mouse gesture donut.

It may take a little time for you to get used to the mouse-gestures interface. It works best
when you understand what the commands are before you use them, so you can invoke the Top
View command in a single motion, without pausing to see where each command is located on

145
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the donut. For this reason, it might be better to limit the donut to four commands rather than
eight or 12 and to set it up intuitively such that the top view is an RMB stroke up, a right view is
an RMB stroke to the right, and so on.

FIGURE 5.3

Click+drag the right -
mouse button (RMB) to PN
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You can customize the mouse-gestures donut in the Tools > Customize > Mouse Gestures.
This works much like the Keyboard (hotkey) customization, where you can turn gestures on or
off, set the mouse gesture donut to two, four, eight, or 12 sections, and set any gesture direction
to any available command.

Using the View Toolbar

The View toolbar, shown in its entirety in Figure 5.4, contains the tools that you need to manipu-
late the view in SolidWorks. Not all the available tools are on the toolbar by default, but I have
added them here for this image. To customize your own View toolbar, you must use choose

Tools > Customize from the menu and select the Commands tab. Then click the View toolbar,
and either drag items from the Customize dialog box to the View toolbar to add them or from the
View toolbar into the empty graphics area to remove them. You can use all these tools with part
and assembly models, but only a few of them with drawings.

The toolbar that holds tools for direct access to standard named views such as Front, Top, and
Normal To is called the Standard Views toolbar and is described later in this chapter. The Add
Walk-through tool is discussed more in Chapter 22, “Working with Large Scale Design,” and
Chapter 23, “Animating with the MotionManager.” This is a means of creating an animation for a
large-scale design. The Ambient Occlusion option is covered in this chapter, and it simply adds
self-cast shadows to a model to make it look more realistic.

The Take Snapshot option works like the combination of a custom-named view and a display
state. It allows you to return to a particular view of an assembly with parts hidden or shown as
they were when you took the snapshot. You remain “in” the snapshot until you click the button
to exit it, much like Isolate. You can find the saved snapshots in the DisplayManager on the
Scene, Lights, And Cameras tab. The Filter Modified Components option makes any parts that
have not been modified transparent, so that what you see as opaque are the parts that have
been changed.
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Adding Scrollbars and Splitters

An option exists to add scrollbars and view pane splitters to the graphics window. To use it,
choose Tools > Options > Display/Selection, Display Scrollbars in graphics view. This selection
is grayed out if any SolidWorks documents are open (so you must close all SolidWorks docu-
ments to change it). When you zoom in such that the part, assembly, or drawing is partially off
the screen, the scrollbars activate on the right side and bottom of the SolidWorks window,
enabling you to scroll up and down as well as left and right to pan the view. Scrollbars and
splitters are turned off by default. You cannot turn off one or the other; scrollbars and splitters
come as a package deal.

Figure 5.5 shows a detail of the bottom-right corner of the SolidWorks graphics window,
where you find the scrollbars and splitters. Notice the cursor in the lower right, over one of the
splitters. The splitters can be easy to miss if you do not know what they look like.
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FIGURE 5.5 H
Scrollbar and splitter

controls can be turned P
on or off.

The splitters enable you to split the main graphics window into multiple view ports. The
options are two ports horizontally, two ports vertically and four ports, two horizontal and two
vertical for a total of four view ports per document. The splitter bars are located at the intersec-
tion of the scrollbars in the lower-right corner of the graphics window. Of course, you can also
use the icons on the View Orientation box for splitting the view into two vertical ports, two
horizontal ports, or four ports.

After a viewport has been split, you can remove the split with the toolbar icons, either by
dragging the border back to the edge of the display window or by double-clicking the split
border. If the view has been split into four, you can set it back to a single viewport by double-
clicking the intersection of the horizontal and vertical port borders.

Using the Magnifying Glass
You can invoke the Magnifying Glass by pressing G and dismiss it when you select something or
when you press Esc. To change the hotkey it is associated with, choose Tools > Customize >
Keyboard. Magnifying Glass is listed in the Other category. The Magnifying Glass is intended to
magnify a small area of the view to enable you to make a more precise selection without zooming.
The magnified area follows your cursor as it moves, and you can zoom in and out by scrolling
the MMB. Ctrl+dragging the MMB keeps the Magnifying Glass centered on the cursor. Pressing
Alt creates a section view parallel to the view current, and scrolling the wheel with the Alt key
pressed moves the section plane farther away or closer. Figure 5.6 shows the Magnifying Glass in
operation, cutting a section view through a part.

FIGURE 5.6

Using the Magnifying
Glass with the
section view
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Clicking the Triad Axes

The Triad is the multicolored coordinate axis in the lower-left corner of the SolidWorks graphics
window. You generally use it passively to see how the view is oriented and to get X, Y, Z refer-
ence directions for features that need them. To use the Triad to actively control the view orienta-
tion, try the following:

Click an axis: The view rotates to point this axis out of the screen.
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Click an axis a second time: This axis points into the screen.
Shift+click an axis: This view spins 90 degrees about that axis (using the right-hand rule).

Alt+click an axis: This view spins 15 degrees (or the default view rotation angle)
around the axis.

When you are in a named view, the name of the view is shown in the lower-left corner under the
Triad. This includes standard named views and custom named views. Anything that shows up in
the View Orientation box (accessed by the spacebar) displays a name in the corner. Figure 5.7
shows the Triad and the named view in the lower-left corner.

By Shift+clicking an axis of the Triad, the view is rotated 90 degrees from the original

FIGURE 5.7
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orientation about that axis. Alt+clicking rotates the view around the clicked axis by the view
rotation increment set in Tools > Options > View, which is 15 degrees by default. Pressing Ctrl
in conjunction with any of these causes the view to rotate in the opposite direction. Therefore,
if pressing Shift+click makes the view rotate against the right-hand rule about the clicked axis,
pressing Ctrl+Shift+click makes the view rotate with the right-hand rule.

Using the View Tools

SolidWorks has many additional tools for managing the view, and you can easily access them
through the Heads-Up View toolbar, hotkeys, RMB menu, View Orientation box, or the normal
toolbars and menus.

The tools in this section help you to control how you view parts and assemblies. The follow-
ing tools are mainly found in the View, View > Display, and View > Modify menu areas.

Zoom To Fit: This resizes the contents of the graphics window to include everything that is
shown in the model. You can also access this command by pressing the F key or double-
clicking with the MMB.

149



150

CHAPTER5 USING VISUALIZATION TECHNIQUES

(i)

& H P 0N

Zoom To Area: When you drag the diagonal of a rectangle in the display area, the display
zooms to fit it to the current window. The border size around the fit area is fixed and cannot
be adjusted. This only zooms in, not out.

Zoom In/Out: Drag the mouse up or down to zoom in or out, respectively. You can also access
this command by holding down the Shift key and dragging up or down with the MMB. The
hotkey Z and Shift+Z work for Zoom Out and Zoom In, respectively. The percentage of the
zoom is a fixed amount and cannot be adjusted. You can also use the scroll wheel to zoom in
and out, and if you are accustomed to using a different CAD product where the scroll works
the opposite way, a setting exists at Tools > Options > View that allows you to reverse the
function of the scroll wheel.

Zoom To Selection: This resizes the screen to fit the selection. You can also access this
command by right-clicking or left-clicking a feature in the FeatureManager. For example, if
you select a sketch from the FeatureManager and right-click and select Zoom To Selection, the
view positions the sketch in the middle of the screen and resizes the sketch to match the
display. The view does not rotate with Zoom To Selection.

TIP A reciprocal function to Zoom To Selection enables you to find an item in the tree from graphics

window geometry. If you right-click a face of the model, then you can select Go To Feature In Tree,
which highlights the parent feature. This function has been relegated to the expanded menu, so you
may have to click the double arrow at the bottom of the RMB menu to see it.

Zoom About Screen Center: This enables you to zoom straight in and straight out. This tool is
off by default. The default behavior is that zooming with the scroll wheel works around the
cursor. If the cursor is off to one side, zooming in and out can cause the view to “walk” away
from that side. Turning on Zoom About Screen Center is not dependent on the location of the
cursor. If you are frustrated with how zooming with the scroll wheel works, try this setting
and see if you like it better. This command is found only in the menus at View > Modify and
does not have an icon.

Rotate View: This enables you to orbit around the part or assembly using the left mouse
button (LMB). You can also access this command by using the MMB without the toolbar icon.

Roll View: This spins the view on the plane of the screen, similar to Rotate View with
the Alt key.

Pan: This scrolls the view flat to the screen by dragging the mouse. You can also access this
command by holding down the Ctrl key and dragging the MMB without using the toolbar
icon; another way to access it is with Ctrl+arrow.

3D Drawing View: This enables you to rotate the model within a drawing view to make
selections that would otherwise be difficult or impossible. This is available only in drawing
documents.

View Orientation (Standard Views flyout) toolbar: View Orientation is discussed later in this
chapter. The flyout enables you to access all the Standard Views tools. This button is also
called the View Orientation flyout, depending on where you see it.

Wireframe: This displays the model edges without the shaded faces. No edges are hidden.
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FIGURE 5.8

Sectioning a 3D model
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Hidden Lines Visible (HLV): This displays the model edges without the shaded faces. Edges
that would be hidden are displayed in a font.

Hidden Lines Removed (HLR): This displays the model edges without the shaded faces.
Edges that are hidden by the part are removed from the display.

Shaded With Edges: The model is displayed with shading, and edges are shown using HLR.
Edges can all be a single color that you set in Tools > Options > Colors (typically black), or
they can match the shaded color of the part. Tools > Options > Document Properties > Colors
is where you find the document-specific setting to use the same color for shaded and wire-
frame display, which becomes very useful in an assembly when all the parts shown in
wireframe are the same color as they are when they are shaded, instead of all being black.

Shaded: The model is displayed with shading, and edges are not shown.

Shadows In Shaded Mode: When the model is displayed shaded, a shadow displays on a
plane parallel to the floor as established in the scene. The shadow is not necessarily on the
floor, but on the plane at the furthest extent of the model parallel to the floor.

Section View: This sections the display of the model. Figure 5.8 shows the Section View
command at work. You can use up to three section planes at once. Solid and surface models,
as well as assemblies, can be sectioned. You can use the spin boxes, enter numbers manually,
or drag the arrows that are attached to the section planes to move the section through the
model. Section planes can also be rotated by dragging the border of the plane. Parts can be
omitted from the cut, or the cut parts can be transparent. You can show the cut caps or leave
the cuts looking hollow.

¢ Clicking the checkmark icon in the Section View PropertyManager enables you to
continue working with the sectioned model, although you may not be able to reference
edges or faces that are created by the section view. It is only a displayed section; the actual
geometry is not cut.

& Section views can be saved either to the View Orientation box or to the Annotation View
folder, which enables 3D section views to be reused on the drawing. When you are
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working in a section view, if you want to alter it, you can access Modify Section View
through the menus at View > Modify > Section View. You should notice that no toolbar
icon exists for modifying a section view. You have to access this command through the
menus or by turning off the Section View tool and then turning it back on. You might also
notice that Modify Section View is available in the hotkey assignment area, Tools >
Customize » Keyboard.

¢ The orange interface elements allow you to move or rotate the section, which can also be
done in the PropertyManager. Notice the many options in the PropertyManager.

¢ You can section by 2D planes (act as cutting planes) or by 3D zones (bounding box
segmented into solid zones by section planes)

I encourage you to experiment with this tool to see what it can do.

RealView: This creates a more realistic reflective or textured display for advanced material
selections. This feature does not work with all graphics hardware, so check the SolidWorks
system requirements website to see if it supports your hardware. An entire section of this
chapter is devoted to the various tools available with RealView graphics.

Cartoon: This applies a cartoonish, less realistic appearance to the model. It creates a harsh
lighting and a different type of shadow that doesn’t rely on shadow settings. It is an effect you
may want to experiment with, especially when using the edge and silhouette edge display
options.

Ambient Occlusion: This option displays shadows that the part casts on itself. It is particu-
larly useful when a part or assembly has an interior area that can be seen from outside the
model. The interior area will be shown in shadows with this setting on. The setting may affect
performance especially on large assemblies.

View Bounding Box: This option enables you to turn on the display of the bounding box
(Insert > Reference Geometry > Bounding Box). The bounding box encloses the entire model
(parts only) and looks like the edges of a cube created in a phantom-line 3D sketch.

Apply Scene: This enables you to apply a scene to your document background. It may also
turn off the system background color you are using.

Edit Appearance: This enables you to apply and edit colors, textures, and materials to faces,
bodies, features, parts, and components.

Copy Appearance: This enables you to copy an appearance from the model to the Clipboard.
Paste Appearance: This enables you to paste a copied appearance onto a model.

Draft, Undercut, and Parting Line Analysis: These display options enable you to evaluate the
manufacturability of plastic and cast parts. These three types of geometric analysis are
discussed in more detail in Chapter 12, “Editing, Evaluating, and Troubleshooting.”

Simulation Display: If your model contains results from a stress analysis, this button will
allow you to display those results on your model.
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Walkthrough: The Walkthrough helps you create an animation that records a movie as if you
were walking through a part or assembly.

Change Display States: Display states help you retain visual or display settings for a docu-
ment, and this tool enables you to switch between stored states.

Hide All Types: Any of the icons with a picture of an eye on them can be used to show or hide
the entity depicted in the icon. This includes planes, axes, sketches, curves, relations, parting
lines, decals, and so on. You can access these icons quickly from the Heads-Up View toolbar.
The eye icon on its own is Hide All Types, and it toggles each of these individual settings.

Zebra Stripes and Curvature

Zebra Stripes, another geometrical analysis tool that helps you visualize the quality of transitions
between faces across edges, simulates putting a perfectly reflective part in a spherical room

where the walls are painted with black-and-white stripes. In high-end shape design, surface
quality is measured qualitatively using light reflections from the surface. Reflecting stripes make
it easier to visualize when a transition between faces across an edge is not smooth. Zebra Stripes
can help you identify these three cases (see Figure 5.9):

FIGURE 5.9

Contact: Faces intersect at an edge but are not tangent across the edge, such as at the edges of
a cube. This condition exists when stripes do not line up across the edge.

Tangency: Faces are tangent across an edge but have different radii of curvature on either side
of the edge (noncurvature continuous), such as between a fillet face and an adjacent face. This
condition exists when stripes line up across an edge, but the stripe is not tangent to itself
across the edge.

Curvature continuity: Faces on either side of an edge are tangent and match in radius of
curvature. Zebra Stripes are smooth and tangent across the edge.

Zebra Stripes @
Zebra Stripes help you v
visualize the qualities
of curvature. Settings -~
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In Figure 5.9, the Zebra Stripes in example A do not match across the edge labeled A at all.
This is clearly the nontangent, contact-only case. Example B shows that the stripes match in
position going across the indicated edge, but they change direction immediately. This is the
tangent case. Example C shows the stripes flowing smoothly across the edge. This is the curva-
ture continuous case.

You can use the remaining icons in the View toolbar to toggle the display of various types of
entities from reference geometry to sketches.

Curvature colors the model with various colors depending on the local surface curvature.
Mathematically, curvature is the inverse of radius, so c = 1/r. A large radius is a small curvature
and vice versa. Generally, on models where you are looking at curvature, you are looking for
sudden changes, flat spots, constant radius, or inflections. Figure 5.10 shows a model of a cricket
bat with the curvature displayed.

FIGURE 5.10
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properties of 107002
smooth models. 45152 Cancel
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0.0291
0.0278
0.0266

You can control the colors for various curvature values at Tools > Options > Document
Properties > Model Display > Curvature using the table shown in Figure 5.10.

Curvature *

Apply

View Orientation

@ The View Orientation dialog box and the Standard Views toolbar are very similar to one another.
View Orientation is the more modern of the interfaces. The View Orientation dialog box and
the View Selector are shown in Figure 5.11.
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You can access the View Selector independently from the View Orientation dialog box by

pressing Ctrl+spacebar or by accessing it from the Standard Views toolbar. The View Selector
graphic enables selection of various angled unnamed views, giving you a visual preview for
selection. The View Orientation dialog box contains the following controls:

Pushpin: This keeps the dialog box active.
New View: This creates a new custom-named view.

Update Standard Views: This sets the current view to be the new Front view; all other views
update relative to this change. This also updates any associated drawing views but does not
move any geometry or change plane orientation.

Reset Standard Views: This resets the standard views so that the Front view looks normal to
the Front plane (Planel, XY plane).

Previous View (undo view change): You can access this tool by pressing the default hotkey
Shift+Ctrl+Z.

The Normal To option has four modes of operation:
First Mode: With nothing selected, Normal To will find the nearest orthogonal view.

Second Mode: Click a plane, planar face, or 2D sketch. When you click Normal To, the view
reorients normal to the selected plane, face, or sketch and zooms to fit the model in the view.
This method is shown in Figure 5.12.
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FIGURE 5.12
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Third Mode: Click Normal To a second time. The view rotates 180 degrees to display the
opposite direction.

Fourth Mode: After making the first selection, Ctrl+select another planar entity. The view is
normal to the first selection, and the second selection is rotated to the top. This method is
shown in Figure 5.13.

Annotation Views

Annotation views enable you to group annotations that were made in a 3D model into views
that will be used on the drawing. They are collected under the Annotations folder in the
FeatureManager for parts and assemblies. Annotation views can be created automatically
when 3D annotations are added or created manually. An Unassigned Items annotation view
acts as a catchall for annotations that are not assigned to any particular views. In the 3D model,
you can use the views to reorient the model and display annotations. As mentioned earlier,
annotation views can also capture a model section view to be shown in a drawing view.

Annotation views are listed in the Annotations folder in the FeatureManager of the document
where they are created. Right-clicking the Annotations folder provides all the options for
Annotation views. The Annotation views are shown for the Chapter5SampleCasting part in
Figure 5.14.
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Using the DisplayManager

e The DisplayManager organizes all the display and visual information into a form that makes it
easier to understand and control. The DisplayManager lists Appearances, Decals, Scenes, Lights,
and Cameras. You can find the DisplayManager as a tab in the FeatureManager window area.

Figure 5.15 shows the Appearances data for a part with a material and color applied to two faces
and a feature.
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Appearances in SolidWorks are a combination of color and texture. In order to have
appearances display and sort in the DisplayManager, you have to first apply appearances.
Most of the appearances are meant to look like idealized materials in real life. Remember that
materials are applied separately and control physical properties such as density, strength, and
so on. Appearances deal with cosmetic properties. Polished, cast, knurled, machined, sand-
blasted, and other surface finish types are available to add realism to your models.

Applying Appearances
You can apply appearances to faces, bodies, features, parts, assembly components, or even the
top-level assembly. Even if you don’t apply an appearance, every part and assembly template

starts with a default appearance (except very old templates), which is white, glossy plastic.
You can apply appearances in several ways:

Double-click: Double-clicking an appearance in the Appearances panel of the Task pane
applies the appearance to the document (part or assembly).
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Drag-and-drop: Dragging an appearance from the Appearances panel of the Task pane
enables you to drop it on geometry in the graphics window. When you do this, the appear-
ance palette pops up and presents you with several options. Figure 5.16 shows this toolbar
with the options for Face, Feature, Body, and Part.

FIGURE 5.16
Determining a target for
the appearances after

drag-and-drop

Appearance palette: If you pin the Appearance palette, the workflow reverses. Select the type
of entity to which you want to apply the appearance and select model faces.

Appearance filter: The Appearance filter enables you to change all items of a given
appearance to a new appearance. Just drag the new appearance onto any face with the
old appearance, and click the Appearance filter when it appears. All other items with that
particular appearance are changed to the new appearance.

Context toolbar: You can also invoke the Appearance function from the context bars (left-click
or right-click). You can do this with preselection or no selection. This method also gives you
options for the target to which to apply the appearance, face, feature, body, or part. Figure 5.17
shows this method.
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You can copy and paste appearances from the DisplayManager (or the model) onto the model.
To distinguish between copying geometry and copying appearances, the appearance copy
shortcut is Ctrl+Shift+C, and the appearance paste shortcut is Ctrl+Shift+V.
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DIFFERENTIATING APPEARANCES AND MATERIALS

It is easy to confuse appearances and materials. The biggest reason for this is that, in many cases,
appearances have the same names as materials, and the texture associated with the appearance
typically also has the name of a material. SolidWorks has appearances with names such as
high-gloss plastic, wrought iron, and chromium plate. It may become even more confusing
because materials (which you can assign from the FeatureManager on the left) have appearances
(which you assign from the Task pane on the right) assigned to them. For example, you could
assign an appearance called polished aluminum to a material called AISI 304.

You cannot use appearances to assign mass properties (such as density or stiffness) to a part,
but you can use materials to assign an appearance as 